Jump to content

[Solved] disk read errors while rebuilding


Recommended Posts

I'm currently in the process of replacing disks in my server. While replacing a 4tb disk18 with a 12tb. Disk3 threw a ton of read errors but stayed  online. I had issues with that disk prior to a parity where it would go offiline, after swapping the cable on this one I was able to rebuild disk3 successfull to get it back online with a valid parity.


For my understanding right now i can't trust the disk integrity of the rebuld disk18, correct? What would be the proper steps to ensure data integrity there? should i swap back disk18 for the old one, make a new config and replace and rebuild disk3?


rebuild didn't finish yet, bit I'm beyond the 4tb mark for the disk i replaced.


Edited by mason
Link to comment

I think I would cancel the rebuild, check connections on disk3, and try the rebuild again.


You have more disks than I would want without dual parity.


Why were you replacing disk18 anyway? Was there anything wrong with it?


Another possibility would be to New Config with the original disk18 and use that replacement for parity2.

  • Like 1
Link to comment

Rebuild finished with the errors overnight. How do i start another rebuild on that disk? edit: found that part in the docs. Just ordered a new breakout cable for that hba and will rebuild disk18 again I guess.


It was replace since it was an old one with some udma errors.

and yeah I know, dual parity would be adviced, but there is nothing on that server that is irreplaceable. Also I would need another 14tb disk.

Edited by mason
Link to comment

So I replaced the breakout cable and tried another rebuild of disk18, so far it is running. But the speed seems way slower, before maybe 150mb/s compared to 80mb/s now and the array "sounds" different... it "grinds" any idea whats the issue there? could this be the "quality" of the cable?!

Link to comment
10 minutes ago, mason said:

maybe 150mb/s compared to 80mb/s now

Lots of factors can affect the current speed. For example, it writes the outer tracks first and works toward the inner tracks. Since the RPM is constant, and the outer tracks are longer than the inner, the outer tracks have more data per rotation. So, the outer tracks will have a faster data rate than the inner.


Maybe you just never noticed these details before.


If you think you still have a hardware problem post new diagnostics.

Link to comment

yeah i know, but there was nothing running and nothing accessin it afaik.

anyway, that rebuild was successfull without any errors now. thanks for the moral and tech support :)

it's weird what issues cabling can cause, you'll never notice until you run something like unraid.


so in conlusion: it looks like the issue was caused by a faulty breakout cable

Edited by mason
Link to comment
  • mason changed the title to [Solved] disk read errors while rebuilding

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...