[SUPPORT] Ahmad's Templates

Recommended Posts

I'm creating and maintaining a bunch of templates mainly around web development tools.




GitHub Templates Repository: https://github.com/ahmadnassri/unraid-templates/

Edited by Ahmad
correct repo link
Link to comment
On 8/6/2022 at 3:34 AM, fornol said:



There seems to be an error in plugin:

/usr/local/bin/start-vscode: line 6: VSCODE_SERVE_MODE: unbound variable


Prevents to start docker.

I've created the VSCODR_SERVER_MODE with the value: serve-local and the container started without problem

Link to comment

oops, apologies for this, corrected the issue in the template: https://github.com/ahmadnassri/unraid-templates/commit/78c883529bb063681ca527e6792f9307c54c8d37 the next refresh of CA Community Applications will surface this fix, in the meantime: as @resuarezsaid, adding a variable named VSCODR_SERVER_MODE with value set to "local" will allow it to run properly.


note: this is in prep to allow the container to run as a remote target for vscode.dev (vs. local), however this is currently nonfunctional due to an issue: https://github.com/microsoft/vscode-remote-release/issues/7018



Link to comment
14 hours ago, ALERT said:

same error for me. can you describe the difference between serve modes local and remote?


"local": runs completely independently, locally on your unraid

"remote": allows the container to act as a remote target for vscode.dev, however, this is behind a beta invite for now, and as per previous post, is not functional due to an issue with vscode-server itself, and awaiting Microsoft to address my ticket.


for now stick to "local" until I announce it fully functional.

Link to comment
  • Ahmad changed the title to [SUPPORT] Ahmad's Templates
  • 2 months later...
  • 3 months later...
On 2/6/2023 at 3:59 PM, Nick.L said:

i wonder if there is a login panel, just for the security concern. i have entered the keyring but it never ask me to login


are you referring to vscode?


you should be able to login with your Github / Microsoft accounts.

Link to comment
  • 2 months later...
On 2/13/2023 at 8:20 AM, Ahmad said:


are you referring to vscode?


you should be able to login with your Github / Microsoft accounts.

I think he meant when pulling up the GUI to enter a password of some sort like some of the the Open-VSCode ones do.   What is the  passkey for in the config by the way, I did think that was for some sort of GUI Passcode to be able to access?  

Link to comment
Posted (edited)
13 hours ago, manolodf said:

What is the passkey for in the config by the way


The passkey is used in the `gnome-keyring-daemon` to remember your vscode login credentials for the settings sync feature between container runs.


see code here:



see info on settings sync here:

Edited by Ahmad
Link to comment

Not sure if you have seen the Linuxserver version of code-server. I think that is what the other user was referring to in terms of a password on a splash screen. I just switched to yours because it’s frankly better since I can run all extensions but the password protection would be a bonus

Sent from my iPhone using Tapatalk

Link to comment
Posted (edited)
16 minutes ago, manolodf said:

Not sure if you have seen the Linuxserver version of code-server

indeed I have (and used it for a bit), though that one is NOT the official VS-Code and hence it doesn't have the full extensions functionality as you indicated, hence why I made this one.


I don't plan on adding functionality beyond what the official image provides, so things like password protection can be achieved with a reverse proxy like Authelia and SWAG: https://www.linuxserver.io/blog/2020-08-26-setting-up-authelia

Edited by Ahmad
Link to comment
  • 5 weeks later...

I wanted to see if you could help me get my local Unraid Time within code-server, or to set a time.   I tried mapping /etc/localtime and that did not seem to work, and the timedatectl did not seem to work also.  

Is there an argument or parameter I can pass through to assign my timezone so that when testing a python script within code-server it has my correct timezone instead of UTC? 

Link to comment
33 minutes ago, Ahmad said:

have you tried the TZ environment variable?


it might need adding the tzdata package to the image to work, I haven't tried it.


give it a try and open a pull request if it works?

I tried adding the TZ Variable within unraid and applied, and same result, still showing UTC time for me when running python script. 



Link to comment
5 hours ago, Ahmad said:

just published a new version 1.4.0 that supports TZ env, also upgrade to ubuntu:23.04



Awesome that got the timezone result!  Maybe the ubuntu upgrade is what gave an error when doing "pip3 install requests" that used to work and had to change it.  But definitely getting the desired timezone!  Thanks!


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.