Error response from daemon: Address already in use

Go to solution Solved by bonienl,

Recommended Posts


I have numerous vlans all configured like this:
10.0.50.x/28 where x is the second last address in range. The last address in range is gateway.

So my first vlan is 50 and is configured like this:

I'm trying to install the app Nextcloud with the address, but get: "Error response from daemon: Address already in use".
I can however install Nextcloud with the address
For whatever reason I get the same error with vlan 51 when using address, but not on vlan 52 when using

I've been searching through the network of Unraid and Docker and can't seem to find any trace of the ip address
Does anyone have an idea of what is causing this behavior and, not less important, how to fix it?

Regards, Anders


The full docker command with error:

[email protected]:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='nextcloud' --net='br0.50' --ip='' -e TZ="Europe/Paris" -e HOST_OS="Unraid" -e HOST_HOSTNAME="ADsNAS" -e HOST_CONTAINERNAME="nextcloud" -e 'TCP_PORT_443'='443' -e 'PUID'='99' -e 'PGID'='100' -e 'UMASK'='022' -l net.unraid.docker.managed=dockerman -l net.unraid.docker.webui='https://[IP]:[PORT:443]' -l net.unraid.docker.icon='' -v '/mnt/user/nextcloud/':'/data':'rw' -v '/mnt/user/appdata/nextcloud':'/config':'rw' ''

docker: Error response from daemon: Address already in use.

The command failed.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.