Jump to content

No Dockers after cache drive upgrade

Go to solution Solved by JorgeB,

Recommended Posts

I've just upgraded my cache drive following these instructions found here

  • Stop all running Dockers/VMs
  • Settings -> VM Manager: disable VMs and click apply
  • Settings -> Docker: disable Docker and click apply
  • Click on Shares and change to "Yes" all cache shares with "Use cache disk:" set to "Only" or "Prefer"
  • Check that there's enough free space on the array and invoke the mover by clicking "Move Now" on the Main page
  • When the mover finishes check that your cache is empty (any files on the cache root will not be moved as they are not part of any share)
  • Stop array, replace cache device, assign it, start array and format new cache device (if needed), check that it's using the filesystem you want
  • Click on Shares and change to "Prefer" all shares that you want moved back to cache
  • On the Main page click "Move Now"
  • When the mover finishes re-enable Docker and VMs


When I re-enabled Docker, it was empty.   I say a comment on another thread that you can just re-add them via CA previous apps.  I tried this with a single docker and after the reinstall, the docker was running the default config not the config it was running before the upgrade.

Before I try anything else and possibly make things worse does anyone have any wisdom that could get me out of this hole.


I'm generating the diagnostics now, does it normally take a long time?  Been running about 30 minutes so far.

Link to comment

I've rerun Mover with logging now enabled.

New diagnostics attached

The share is still showing some appdata content on array disks. but only a few bytes on 1 drive and a few KB on the other.

There are a few SVG files deep in the Krusader directory, a cookie file in the QdirStat dir and a mongodb-27117.sock file under unifi controller.  Could I manually move these files over manually?  TBH, other than maybe the unifi controller file, the rest are not important and I can redeploy those later if needed.





Edited by [email protected]
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...