ASUS WRX80 onboard NICs won't do 2500mbps


Recommended Posts

I have Unraid 6.10.4 on an ASUS WRX80 PRO WIFI. Both of the onboard NICs are supposed to go up to 10gbps. I have a 2.5gbps switch and both NICs will only do 1000mbps or lower for some reason. I've tried 3 brand new Cat 6a cables and from the switch to my modem show 2.5gbps but the WRX80 to the switch trying those same 3 short cables only do 1gbps. 

 

Rebooting doesn't help. 

Link to comment

I looked at your Diagnostics file.  The ethtool.txt file (in the system folder of your Diagnostics file)  indicates that you have a 4 port 10Gb Intel NIC installed and they are capable of 'doing' 10Gb/s.  You have ports eth0 and eth1 connected to a switch.   However, the negotiated speed is 1000Mb/s for those ports.  This would imply that there is a problem on the switch side of the equation...

Link to comment

The 2.5Gb Switch has no issues with other 2.5Gb ethernet ports. I've tried them all. It's only the 2 10Gb Ethernet ports on this motherboard I am having issues with. The other 2 10Gb ports are SPF+ and I can't find my SFP+ to RJ-45 adapter so I can't use them yet. 

 

I even tried another 2.5Gb switch and same results.

 

Is there a chance this could be a CPU mounting issue preventing those ports from working properly since this is an LGA type CPU? I do have a weird issue with one of my PCIe slots where it bricks the BIOS if I set the slot to 4x4x4x4 and use the included ASUS Hyper NVMe card.

Link to comment

I tried both 6.10.3 and 6.9.2 and they both do 1gbps. While Unraid is booting the link lights on the Switch go from 2.5gbps to 1gbps.  I installed Windows 10 to an empty SSD and both ethernet port can do 2.5gbps.  Haven't tried 6.11.5 yet. 

 

EDIT: Well 6.11.5 didn't fix it. 

Edited by chuckthetekkie
Update info
Link to comment

Any other ideas on why the onboard NICs are only negotiating at 1000mbps rather than 2500?

 

I even reseated the CPU incase it was a PCIe issue.

 

I's weird how the switch will initially show 1gbps while posting than 2.5gbps during initial Unraid boot up then 1gbps after Unraid loads the NIC drivers. 

Link to comment

If it works with Win10 is suggests a Linux in tree driver issue, problem is that the Intel Linux out of tree drivers usually cause different issues, best bet it to wait for a newer release with a newer in tree driver, soon also there should be an option to easily install out of tree drivers with Unraid, so you can then try those.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.