My Servers cant view docker web ui

Go to solution Solved by Squid,

Recommended Posts

Hi, My first post and I have tried searching for the above issue.


I have followed Spaceinvader One video on setting up My Server and that works as expected as it always does with his clear videos.


I can login from out side my network, see the main screen, reboot, spin down etc and see my dockers.


I am trying to access docker web ui and the address bar has the server ip and port for the docker im trying to access but it just times out


What am I missing? Do each of the dockers I want to access need a port forward?


Many thanks... marco

Link to comment
  • Solution

Are you doing this remotely.


Multiple problems (and not an easy solution) with doing this and something I brought up a few years ago.


Your best bet is to actually either use a real reverse proxy with appropriate forwarding for your apps (eg: SWAG), or alternatively create a barebones VM that uses VNC.  The VNC VM is accessible remotely via MyServers and from it's browser you can then access any of the docker containers installed.

Link to comment

Cheers Squid


Yes I am accessing remotley.


Was hoping i had missed a check box or somthing 😆


I will work through the above info you have given me and see how I get on. I can access the server to reboot and update etc so thats a start.


All started when my wife tried to remote access radarr and sonnar from her phone where I had saved them as faviourites in her browser to add some downloads because I hadnt explained it was local only. Thought My Server might have been the solution but seems I have more to look at.


Thanks for the pointers 👍

Link to comment