Jump to content

Windows Server 2016 no network

Recommended Posts

I'm really upset because of the actual behavior...

I can't get networking up to work on a new install of Windows Server 2016 - and what it is making even worse: I can't use networking on an old install of Windows Server 2016 any more...

The install of NetKVM always failes, whatever I try... Even if I come to the point, where the adapter is up and running no network is available.

The point which is really bleaming me, is the sandboxed version, which was untouched also won't work anymore.

Already installed Windows clients are doing well - only the servers are involved.


I already tried

bcdedit /set testsigning on


pnputil -i -a netkvm.inf


no success...

Link to comment

Thank you for your reply.


I already tried

- virtio-net

- virtio

- e1000

- vmxnet3


I know, there are other possibilities (network-cards) which can be used directly within the XML, but I didn't tried this so far...


and also

- virtio-win-0.1.225-2.iso

- virtio-win-0.1.225-1.iso

- virtio-win-0.1.221-1.iso

- virtio-win-0.1.217-2.iso

- virtio-win-0.1.217-1.iso

- virtio-win-0.1.215-2.iso

- virtio-win-0.1.215-1.iso

- virtio-win-0.1.208-1.iso

- virtio-win-0.1.204-1.iso

- virtio-win-0.1.196-1.iso

- virtio-win-0.1.190-1.iso

- virtio-win-0.1.189-1.iso

- virtio-win-0.1.187-1.iso

- virtio-win-0.1.185-2.iso

- virtio-win-0.1.185-1.iso


all of them without sucess.


The e1000 (for example) is there (in the device manager), but there are no network connections available. I had the same result for virtio-net etc.


Thanks for your help - hope somebody has another idea... 


My systemspecs are:


Asus Prime B450-PLUS

AMD Ryzen 7 2700



1x Realtek

R2-UNRAID kernel: Linux version 5.19.9-Unraid (root@Develop) (gcc (GCC) 12.2.0, GNU ld version 2.39-slack151)

Unraid OS 6.11.0

Edited by pepino1109
Link to comment

This is the configuration of the second Windows Server 2016, where I didn't changed anything, but showing the same strange behavior:

(Just to remember - all other VMs (linux server, linux clients and windows clients doing absolutly well!)




Config XML (just edited UUID for public):


<?xml version='1.0' encoding='UTF-8'?>
<domain type='kvm'>
  <uuid>***edited for public eyes***</uuid>
  <description>Windows Server 2016</description>
    <vmtemplate xmlns="unraid" name="Windows Server 2016" icon="windows.png" os="windows2016"/>
  <memory unit='KiB'>16777216</memory>
  <currentMemory unit='KiB'>16777216</currentMemory>
  <vcpu placement='static'>4</vcpu>
    <vcpupin vcpu='0' cpuset='2'/>
    <vcpupin vcpu='1' cpuset='10'/>
    <vcpupin vcpu='2' cpuset='6'/>
    <vcpupin vcpu='3' cpuset='14'/>
    <type arch='x86_64' machine='pc-i440fx-6.2'>hvm</type>
    <loader readonly='yes' type='pflash'>/usr/share/qemu/ovmf-x64/OVMF_CODE-pure-efi.fd</loader>
  <cpu mode='host-passthrough' check='none' migratable='on'>
    <topology sockets='1' dies='1' cores='2' threads='2'/>
    <cache mode='passthrough'/>
    <feature policy='require' name='topoext'/>
  <clock offset='localtime'>
    <timer name='rtc' tickpolicy='catchup'/>
    <timer name='pit' tickpolicy='delay'/>
    <timer name='hpet' present='no'/>
    <disk type='file' device='disk'>
      <driver name='qemu' type='raw' cache='writeback'/>
      <source file='/mnt/user/domains/ManageEngine/vdisk1.img'/>
      <target dev='hdc' bus='virtio'/>
      <boot order='1'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x05' function='0x0'/>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/mnt/user/isos/server/windows/WinServer2016_14393.0.161119-1705.RS1_REFRESH_SERVER_EVAL_X64FRE_DE-DE.ISO'/>
      <target dev='hda' bus='ide'/>
      <address type='drive' controller='0' bus='0' target='0' unit='0'/>
    <disk type='file' device='cdrom'>
      <driver name='qemu' type='raw'/>
      <source file='/mnt/user/isos/virtio-win-0.1.225-2.iso'/>
      <target dev='hdb' bus='ide'/>
      <address type='drive' controller='0' bus='0' target='0' unit='1'/>
    <controller type='usb' index='0' model='ich9-ehci1'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x7'/>
    <controller type='usb' index='0' model='ich9-uhci1'>
      <master startport='0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x0' multifunction='on'/>
    <controller type='usb' index='0' model='ich9-uhci2'>
      <master startport='2'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x1'/>
    <controller type='usb' index='0' model='ich9-uhci3'>
      <master startport='4'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07' function='0x2'/>
    <controller type='pci' index='0' model='pci-root'/>
    <controller type='ide' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x01' function='0x1'/>
    <controller type='virtio-serial' index='0'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x04' function='0x0'/>
    <interface type='bridge'>
      <mac address='52:54:00:8d:4b:20'/>
      <source bridge='br1'/>
      <model type='virtio-net'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    <serial type='pty'>
      <target type='isa-serial' port='0'>
        <model name='isa-serial'/>
    <console type='pty'>
      <target type='serial' port='0'/>
    <channel type='unix'>
      <target type='virtio' name='org.qemu.guest_agent.0'/>
      <address type='virtio-serial' controller='0' bus='0' port='1'/>
    <input type='tablet' bus='usb'>
      <address type='usb' bus='0' port='1'/>
    <input type='mouse' bus='ps2'/>
    <input type='keyboard' bus='ps2'/>
    <graphics type='vnc' port='-1' autoport='yes' websocket='-1' listen='' keymap='de'>
      <listen type='address' address=''/>
    <audio id='1' type='none'/>
      <model type='qxl' ram='65536' vram='65536' vgamem='16384' heads='1' primary='yes'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x02' function='0x0'/>
    <memballoon model='virtio'>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06' function='0x0'/>


Thank you for any kind of help!


Link to comment

I have some news:

1. I installed the trial of windows server 2019 with the same setup as windows server 2016 without any trouble - network is working fine (the install of virtio-guest was completed without error)

2. Yesterday I took an old PC from the basement, installed a trial version of unraid 6.11.5 and setup a windows server 2016 with virtio-win-0.1.225-2.iso and ran into the same trouble. The virtio-guest driver for 2k16 can't be installed.


Is anybody out there able to confirm problems with windows server 2016 and the 2k16 virtio network drivers?


Link to comment

Jorge, thank you very, very much for your patience!!!


Today I tried the install again and made an interesting effort. Inspired of your screenshot I tried the us version of windows server 2016 and the install was successful!

But, the german version still won't work - I can't install the virtio network drivers.

I didn't tried to install a windows client (I'll try the german version of windows 10 later) - but I had no problems with windows server 2019 - it's just the install of the GERMAN version of windows server 2016...

Link to comment

Is it error code 56?

Localized windows isos could have issues with network drivers; if you search in internet you can read that it's still not clear on what it depends, windows or qemu.

For q35 machine type a fix is to use machine version 5.1, but it seems it doesn't fix it for i440fx type...

You could try this "funny" fix I found, maybe it will work:

follow exactly these instructions, it worked at least for 2 people:


Edited by ghost82
Link to comment

I didn't knew this post, but did exact the same procedure a few days ago. The result was an successfully installed Virtio Ethernet Adapter without function. There was no network connection available... Version 5.1 was my default at that time. I also tested q35 - all ended up in an non functional network.

After several days of unsuccesfully testing with the GERMAN version, I decided to use the US version, wich works (at the moment). 


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...