Data drive replaced with larger capacity but not using new space

Go to solution Solved by itimpi,

Recommended Posts

Hey, I've done a cursory Google search for this info but haven't found anyone with exactly the same issue that I'm having. As the title states I've done a drive replacement in my array with a unit that is 'larger' than the original drive but it hasn't expanded the file system to use the new space.

Is there something I'm missing to get it to expand the FS on the drive?


More info:

I had an 8TB drive that, after a parity check ended, had spit out 1100+ Reported uncorrect and 350,000+ Reallocated sector count so I decided to proactively replace the drive with the 10TB hot spare before UNRAID marked it bad. I stopped the array, unassigned the 8TB drive and assigned the 'new' 10TB drive. Started the array and let it complete the data rebuild.

This process completed normally and all the data was rebuilt onto the new 10TB drive, however, it is reporting that the 10TB drive has a capacity of 8TB and I don't see an obvious way to expand the drive out to the full 10TB.


Array information:

Parity 1 and Parity 2 are 10TB drives

There are already 2 other 10TB drives in the array working normally.

The Drive is in XFS format.

The array hasn't been restarted after the data has rebuilt.



First 2 things that have come to mind:

Stop the array and check the disk properties, there might be something there that will allow an expand operation but only when the array is offline.

Run a parity check and it may automatically build parity for the last 2TB of the 10TB drive


The only reason I haven't tried these yet is this isn't a high priority as I will work on it over the weekend but since that is still a little way away I thought I'd ask the awesome community! Any thoughts or knowledge is, as always, much appreciated!

Link to comment
  • Solution
1 hour ago, TheIronAngel said:

The array hasn't been restarted after the data has rebuilt.

I think the file system resize happens at array start, so an array stop/start may fix it.  If not a reboot probably will.

Link to comment

New disk should expand on rebuild, but the log is spammed with the previous errors and missing some info, so when you can reboot, if the disk is still not expanded after array start, and most likely it won't, post new diags.

Link to comment
Posted (edited)

Morning, I've finished maintenence and installed a new hotspare for the array. Once I took the array offline and installed the new disk Unraid stopped responding to network requests other than Ping so I had to force a shutdown. After reboot, the array came online and Data Disk 2 is now showing 10TB



As you can see, Parity check is also running (Removed a drive from the array in addition to an unclean shutdown) - still not sure why it didn't expand the cap on rebuild but all things are back as they should be. Time to leave it alone until the next bad drive XD

Edited by TheIronAngel
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.