Jump to content

Adding drives to native Z pool.

Go to solution Solved by JorgeB,

Recommended Posts

I recently upgraded to the most recent version of Unraid. I was running a separate z pool on unread, but now since the feature was added I created a native Z pool with extra drives then transferred the data from my old Z pool to the new one. I was trying to figure out how I could integrate those drives into the new Z pool. Total there are 6 14 terabyte drives (native Z pool) and 8 12 terabyte drives. When I try to use the native feature to add them it spit out an error saying the drives were not of the same size. Is there a way around this without losing the data that I have on the 14 terabyte drives? I was hoping not to have to lose another drive for parody.

Screenshot 2023-06-02 071714.png

Link to comment
  • Solution

There's currently an issue where the GUI doesn't let you add a vdev with smaller capacity drives, but you can do it manually and then re-import the pool, note that the new vdev needs to be the same width as the existing one, so if you have 6 x 14TB you can add only another 6 x 12TB.

Link to comment

I tried to add them via the GUI...no joy. Does same width mean since I have 8 12TB drives I wound Need to add 8 14TB drives? Currently only have six. Is there a different way to add them? Or would I need to delete pool and reestablish it with all the drive at once instead of adding to it?

Edited by luminus
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...