Jump to content

Very poor read speed


Recommended Posts

Hi all,


I'm having some problems with very low read speeds from my unRAID setup - when copying to my cache drive, the speed is great, around 70mbyte/sec. But when I read from the array the speed is only 3-4mbyte/sec, even when only copying 1 file at a time. Parity check speed also seems reasonable at 45mb/sec.


My setup is as in my signature, the drives are connected as follows:


Parity - WD EARS 2TB with alignment jumper - Connected to motherboard SATA

Cache - 500GB Seagate 7200.12 - Connected to motherboard SATA

Rest of the drives are split across the motherboard and a Raidcore PCI-X card I have installed (on a PCI-X slot)


I am using a vanilla install of 5.0-beta11


Thanks in advance for any help!

Link to comment

ARGH this makes no sense:


I tried with a direct cable connection between my PC and unraid server ... full speed.

Using switch, slow speed. So I figured there must be a problem with the switch ... so I ran iperf between unraid and my PC over the switch and these were the results:




Anyone got any ideas, this problem has totally got me stumped!

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...