Jump to content

(version 6.11.5)x520-da2 NIC recognition problem

Recommended Posts

Hello everyone.


I recently purchased a x520-da2 network card, but when I plugged it into the motherboard, I found that the dual-port network card can only recognize one port.


It is strange that there are 3 SFP+ ports clearly visible in the system equipment, but only two are shown in the network. (There are two x520 network cards on my motherboard, da1 and da2 respectively.So theoretically there should be three 10G Ethernet ports and one onboard 2.5G Ethernet port)


I have tried to delete the network and network rule files in the boot folder, but it doesn't work.


There are screenshots below for your reference, please reply if you need more information.


Thanks for the support!874674678_.png.49a82f09d3a60e86802566d46445f27b.png165193290_.png.46392c6779af5c072a29de6d8740da5d.png

Link to comment
5 hours ago, JorgeB said:

Not sure but looks like the second NIC is duplicating, also and possibly related there's a problem with the module:


Jun 25 19:36:46 BJ-Server kernel: ixgbe 0000:01:00.1: failed to load because an unsupported SFP+ or QSFP module type was detected.


I found a similar situation on Google, and many people reported that the driver could not be loaded normally because of module problems.


You can solve this problem with the command modprobe ixgbe allow_unsupported_stp=1, but it didn't work after I tried it.


In addition, I tried to update the driver and found that the version of ixgbe is 5.19.17-Unraid, but the official version of Intel is 5.18.13. This makes me a little confused.


root@:~# ethtool -i eth1
driver: ixgbe
version: 5.19.17-Unraid
firmware-version: 0x000161bf
bus-info: 0000:01:00.0
supports-statistics: yes
supports-test: yes
supports-eeprom-access: yes
supports-register-dump: yes
supports-priv-flags: yes


Link to comment
46 minutes ago, JorgeB said:

Unraid uses the kernel in-tree driver.

I would like to ask what is the command to restart the network service in unraid.

I tried several common commands and it didn't work. I need to restart the unraid network service after reinstalling the driver to try to fix the problem.

In addition, I would like to ask, is the ixgbe driver updated in the new version?

Thanks a lot for the reply.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...