corrupted usb key, steps to recover

Recommended Posts

Hi all,


It all started with a notification telling me, suddenly, that my usb key was not writable / readable anymore in Unraid webui. 

After a reboot, I've got the nice Syslinux 6.XX loard error / Boot error message. 


I took the usb key out of my server and made the usual disk checks, it's full of errors. 

testdisk was actually able to find the UNRAID partition on the usb drive, and eventually copied 1275 files out of 1275, successfully. 


Copy done! 1275 ok, 0 failed



This seems to be good news, but once I started looking at the files several a first severe strange thing popped-up:


1. here is a recent screenshot I've made of my array : 




but here is what the "DISK_ASSIGNMENTS.txt" file on my key is listing : 


Disk Assignments
Disk: parity  Device: ST20000NM007D-3DJ103_ZVT5JD71  Status: DISK_OK
Disk: disk1  Device: WDC_WD140EDFZ-11A0VA0_9MGJZH6K  Status: DISK_OK
Disk: disk2  Device: WDC_WD140EDFZ-11A0VA0_9MGH0SWK  Status: DISK_OK
Disk: disk3  Device: WDC_WD140EDFZ-11A0VA0_9RJ9AXPC  Status: DISK_OK
Disk: disk4  Device: WDC_WD80EDAZ-11TA3A0_VG02A8XG  Status: DISK_OK
Disk: disk5  Device: WDC_WD80EFZX-68UW8N0_VK0V8N6Y  Status: DISK_OK
Disk: disk6  Device: WDC_WD180EDGZ-11B2DA0_3FHEU4PT  Status: DISK_OK
Disk: disk7  Device: ST6000DM003-2CY186_ZR10LGGX  Status: DISK_OK
Disk: disk8  Device: WDC_WD180EDGZ-11B2DA0_3FHSBHAT  Status: DISK_OK
Disk: disk9  Device: WDC_WD140EDFZ-11A0VA0_XHG4ZE5H  Status: DISK_OK
Disk: disk10  Device: WDC_WD140EDFZ-11A0VA0_9RHVA5KC  Status: DISK_OK
Disk: disk11  Device: ST6000DM003-2CY186_ZR10PK1V  Status: DISK_OK
Disk: disk12  Device: TOSHIBA_MG09ACA18TE_6250A5Z7FG0H  Status: DISK_OK
Disk: disk13  Device: TOSHIBA_MG09ACA18TE_6260A3JGFG0H  Status: DISK_OK
Disk: disk14  Device: ST18000NM000J-2TV103_ZR53Z8L8  Status: DISK_OK
Disk: disk15  Device:   Status: DISK_NP
Disk: disk16  Device:   Status: DISK_NP
Disk: disk17  Device:   Status: DISK_NP
Disk: disk18  Device:   Status: DISK_NP
Disk: disk19  Device:   Status: DISK_NP
Disk: disk20  Device:   Status: DISK_NP
Disk: disk21  Device:   Status: DISK_NP
Disk: disk22  Device:   Status: DISK_NP
Disk: parity2  Device:   Status: DISK_NP_DSBL
Disk: cache  Device: KINGSTON_SA2000M81000G_50026B76844E1A84  Status: DISK_OK
Disk: vms  Device: PNY_120GB_SATA_SSD_PNA0322700061AT04833  Status: DISK_OK
Disk: flash  Device: DataTraveler_3.0  Status: DISK_OK



In regards to everything else, docker, plugins, etc. I don't really mind, but I really would like to get my array back. since I do have my parity drive ID, it must be possible. 


it is safe to think this is not the place where my array config actually is stored on my usb stick ? Is it afe to assume I could simply re-flash an unraid usb drive, and copy the whole config folder to its root, and that I4d get all my previous config back in place ? 


What are the steps to follow here ? 


thanks !



Link to comment

Thanks for the quick reply @JorgeB


So, am I right thinking I should


1. flash a new key with the usb creator tool

2. one finalised, copy the config folder (all lower caps folder names) to the root of my newly created usb boot key

3. start unraid and cross fingers and toes



Link to comment

By the way, the data I've got back was recovered by testdisk, and even with a copy result that is OK, it seems like some folders are now in upper case : 



I believe this will make things harder...


I think I did enable flash backups on Unraid connect, but fr some reason, when I head there, I keep seeing the Loading message, and cannot see my backups. I also tried using another browser and incognito mode, same result. Is there a chance I could find my "connect" backups somewhere ? 


If not, is it safe to pass ALL the folders and files I see in the above list in lower cap ? 

Link to comment

OK you were right, the server started, all disks are detected, all plugins are running ! 

but the array wont start as I already had a usb key failure a few months ago and transferred it to the "new" one that failed as well. 


So I guess I made too much key transfers in less than a year




what now ? 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.