Help! A recent power failure corrupted the USB stick

Recommended Posts

We recently had a (3 hours) power failure.  When everything came back up, I could no longer connect with my unRAID server.


When I connected a monitor/keyboard, I saw what was happening...  "LZMA data is corrupt" was the error.


I figured all I had to do was reformat and re-install the latest/greatest load onto the USB stick and put my Plus.key back into the config directory.


Well that didn't work.  So now what?

Link to comment

Yes I did run the "Make Bootable" file.  When I reformatted, and rebuilt the USB flash drive, I followed the instructions as indicated on the the unRAID site.


I was running on 5.0rc10, but decided to upgrade to rc16c after the power failure.

Is the system booting at all?    You may need to test your BIOS to boot from the USB stick!

Link to comment

The server no longer boots.  My BIOS settings have not changed since it was working previously.  I have so far followed the BIOS setup tips as per to no avail.


As the server boots, it appears to go normally, until it comes to a line...


VFS: Insert root floppy and press ENTER 


I then hit enter and then I get...


VFS: Cannot open root device "(null)" or unknown block (2,0): error -6 Please append a correct "root=" boot option; here are the available partitions:


0800 7819264 sda driver: sd

0801 7819248 sda1 00000000-01


Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)

Pid: 1, comm: swapper/0 Not tainted 3.9.6p-unRAID #23


Call trace:


(then a lot of text)

Link to comment

I don't have any extra Kingston sticks laying around.  I do have other (Patriot) sticks, but they are not deemed "acceptable" when I tried to register them.  This is why I had to get this Kingston stick.

You don't need to register them, this is just a test to see if your server will boot from it.
Link to comment

When you ran "MakeBootable" did you right-click and "Run as Administrator" ??


If not, redo the whole process ==> format the drive with the "UNRAID" label;  copy all of the files from RC16c to it; then navigate to the drive with Explorer; right-click on "MakeBootable" and select "Run as Administrator" ... a windows should open with a "Press any key to continue" when the process finishes.  Then do a "Safely Remove" for the flash drive ... and try it on your system.


If that doesn't work, do the same thing with one of your Patriot sticks.


Link to comment

When you ran "MakeBootable" did you right-click and "Run as Administrator" ??



And did you do a "Safely Remove" before unplugging it?


Just to be certain, I'd repeat the whole preparation process.


If it still doesn't work repeat the preparation process one more time, BUT use the v4.7 AIO download instead of v5.    There's a difference in the way the older Syslinux prepared the flash drive => I've found some systems that will boot when prepared from the 4.7 files, but NOT when prepared with the v5 files !!  [You can then upgrade them to v5 with no problem]


Link to comment

The goal is to take ANY usb stick large enough to copy unRAID source to, you will not be placing any (license) key file or altering it in any way, besides following the procedure on how to create an unRAID  usb stick (which you know how to do) and see if your system boots it (place the stick in the same usb port your original license unRAID usb stick was in). Do NOT start the array, basically don't do anything and shut it down; based on if it even boots. A quick test to weed out if its your original usb stick is OK or not.

Link to comment

OK, so using another USB stick, the server does indeed boot to idle.  So then, just as the initial error indicated, a corrupt flash drive?  This brings up another issue then (after I run out and buy another "authenticated" flash drive). I have to re-register the "Flash GUID".  What would the process be for that?  (assuming that unRAID reps are reading this forum).

Link to comment

The problem could be a corrupt flash drive ... but it could also be a failing memory module that was not used with the decompression of bzroot/bzimage on the new basic install.


Boot to the flash drive that works -- but select the MemTest option ... and let it run for at least 3-4 full cycles (probably a couple hours).    If no errors are detected, try one more thing with your original flash drive:  Do the preparation again, but be sure you do a full format (NOT a "Quick Format", which is the default option).


If that still doesn't work; send LimeTech a note outlining the problem (just point to this thread), and you can make arrangements to get another key.    Problems like this are why Tom sells a 2nd key for only $30 when you buy your key ... so you can have an inexpensive backup flash drive.  :)

Link to comment
  • 2 weeks later...

I know this is an old thread, but I wanted to say thanks & Kudos(!) to garycase.  I went on vacation & had powered down my unRAID server from the GUI.  Came back & got that  "VFS unable to boot message.  I did as garycase suggested  & I do have a backup of my original RC5 setup (with valid license).  I guess the Microcenter USB stick I'm using just gave up the ghost for a little while.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.