Jump to content
ironicbadger

[XEN VM IMG] ArchVM <--- deprecated 01/07/2014

688 posts in this topic Last Reply

Recommended Posts

 

 

 

Never used crashplan but will add it to the repo this evening.

 

Perfect !

Thanks for all of your hard work on behalf of the community!

 

 

-Gary

Share this post


Link to post

Got the VM up and running, I am having trouble mounting my shares. I edited my fstab with no avail

#
# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>       <dump>  <pass>
#192.168.1.6:/mnt/user/DVDs/        /mnt/Tower     nfs rw,rsize=4096,wsize=4096$
//Tower/user/DVDs/   /mnt/Tower     cifs    rw,guest,uid=owncloud,iocharset=utf$
# /dev/xvda1
UUID=93ec2c22-36c1-487c-a888-adde602a16fe       /               ext4           $

then I get this error

[root@ArchApplianceVM_v3 ~]# mount -a
mount: failed to parse mount options

 

Share this post


Link to post

Got the VM up and running, I am having trouble mounting my shares. I edited my fstab with no avail

#
# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>       <dump>  <pass>
#192.168.1.6:/mnt/user/DVDs/        /mnt/Tower     nfs rw,rsize=4096,wsize=4096$
//Tower/user/DVDs/   /mnt/Tower     cifs    rw,guest,uid=owncloud,iocharset=utf$
# /dev/xvda1
UUID=93ec2c22-36c1-487c-a888-adde602a16fe       /               ext4           $

then I get this error

[root@ArchApplianceVM_v3 ~]# mount -a
mount: failed to parse mount options

 

This is what I used and as is, the permissions utilize the guest account in unraid for a read-only share. Change "ro" to "rw" for a read-write share and the permissions if you wish to use another user.

 

//192.168.1.6/Movies /mnt/Movies cifs noauto,x-systemd.automount,ro,username=nobody,password=,_netdev 0 0

Share this post


Link to post

Like that? This is pretty frustrating cant mnt plex shares.......I'm beginning to question my switch over to the vm.

# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>       <dump>  <pass>
#//192.168.1.6/DVDs /mnt/DVDs cifs noauto,x-systemd.automount,ro,username=nobody,password=,_netdev 0 0

# /dev/xvda1

Share this post


Link to post

Like that? This is pretty frustrating cant mnt plex shares.......I'm beginning to question my switch over to the vm.

# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>       <dump>  <pass>
#//192.168.1.6/DVDs /mnt/DVDs cifs noauto,x-systemd.automount,ro,username=nobody,password=,_netdev 0 0

# /dev/xvda1

 

Looks good. Try it and see. The share is automounted when first accessed so if you try to do a LS on /mnt/DVDs, it may return an error for a few seconds though I haven't had any issues with Plex running on those shares to access my media.

 

I think the /mnt/DVDs placeholder directory needs to exist prior. If it fails to mount at boot, the fail message will give you a command to enter to see why it failed.

Share this post


Link to post

hmmmm...

[root@ArchApplianceVM_v3 ~]# cd /mnt/DVDs
-bash: cd: /mnt/DVDs: No such file or directory

 

I thought for sure this was the easy part.

Share this post


Link to post

hmmmm...

[root@ArchApplianceVM_v3 ~]# cd /mnt/DVDs
-bash: cd: /mnt/DVDs: No such file or directory

 

I thought for sure this was the easy part.

 

I'm not sure you're joking or not but I'm assuming you should also type in first:

mkdir /mnt/DVDs

Share this post


Link to post

No joke sir. I'm an idiot at this stuff. Looks like I can cd into it the DVDs directory but I can't figure out how to add to plex.

Share this post


Link to post

No joke sir. I'm an idiot at this stuff. Looks like I can cd into it the DVDs directory but I can't figure out how to add to plex.

 

Do not proceed until you can type in at the bash prompt "ls -l /mnt/DVDs" and get the listing of files & directories you expect.

 

First, view your plex admin, change IP to match yours: http://192.168.1.201:32400/web/

Click on the "+" icon under "My Library"

Click on the "Movies" icon

Type a name for the library section and click on "Add Folder"

Type in "/mnt/DVDs" in the text field or browse to the location and click "Add".

 

Based on the size of your library, it may take some time to display everything. There is an activity icon at the top of the page to let you follow the status.

Share this post


Link to post

No joke sir. I'm an idiot at this stuff. Looks like I can cd into it the DVDs directory but I can't figure out how to add to plex.

 

Hey dude,

 

Welcome to Linux! I can sense your frustration from here, but don't be disheartened by having these teething issues (and they are just that) you are probably learning a great deal. Stick at it, its worth it. :)

 

As for your original issue it looks like some errant $ exist in your fstab file? I'll double my instructions tomorrow just in case that was my fault.

 

To be clear when trying to mount something via fstab both parts must exists. So before you can mount your unraid it must exist (obviously) but the same goes for the second half of the equation, your mount point. In your case this appears to be /mnt/DVDs so make sure that exists by doing the mkdir command.

 

mkdir /mnt/DVDs

mount -a

ls /mnt/DVDs

 

Did that show you your file listing? Good. Move on.

 

Then in plex adding a library section should take seconds. Login via your IP to plex, usually something like

 

192.168.0.4:32400/web

 

Will work. Then look for add section, then navigate to /mnt/DVDs

 

That /should/ be it. :)

 

Sent from my Nexus 5 using Tapatalk

 

Share this post


Link to post

@jbartlett good advice ;)

 

You beat me to it! Damn phone keyboards.

 

Sent from my Nexus 5 using Tapatalk

 

 

Share this post


Link to post

As for your original issue it looks like some errant $ exist in your fstab file? I'll double my instructions tomorrow just in case that was my fault.

 

I believe the $ sign is indicating that there's more data to display at the end of line inside nano.

Share this post


Link to post

[glow=red,2,300]//Tower/user/DVDs/[/glow]  /mnt/Tower    cifs    rw,guest,uid=owncloud,iocharset=utf$

 

Note the glowing part. This assumes that your UNRAID server is named "Tower", you have a share configured in UNRAID named "user", and there's a directory under that share named "DVDs".

 

From my experience, it is best to reference the IP address of the UNRAID server if you have a static IP address configured. Otherwise, you'll need to continue to refer to it by it's "Tower" label.

 

You can test the share's address in Windows Explorer by typing it in using "\" instead of "/".  If you can't browse to "\\Tower\user\DVDs" using Windows Explorer, you WON'T be amount to successfully mount the share in the VM.

 

Assuming that you have an UNRAID share named "DVDs", you'll want to test the share out in Windows Explorer by navigating to "\\Tower\DVDs". If it is successful, enter into the /etc/fstab file "//tower/DVDs"

Share this post


Link to post

Thanks for the support. I believe I have Unraid on a static ip of 192.168.1.6. I will change the stab to reflect the change in user which doesn't exist.

Share this post


Link to post

the -w param for nano will not cause line wrap - ex nano -w filename....

 

Myk

 

 

As for your original issue it looks like some errant $ exist in your fstab file? I'll double my instructions tomorrow just in case that was my fault.

 

I believe the $ sign is indicating that there's more data to display at the end of line inside nano.

Share this post


Link to post

suggestion, the pacman update of:

 

pacman -Syu

 

could possibly be added to a daily cron to keep it updated by default in the image?

 

thanks for the work

 

Myk

 

Share this post


Link to post

No joke sir. I'm an idiot at this stuff. Looks like I can cd into it the DVDs directory but I can't figure out how to add to plex.

 

Hey dude,

 

Welcome to Linux! I can sense your frustration from here, but don't be disheartened by having these teething issues (and they are just that) you are probably learning a great deal. Stick at it, its worth it. :)

 

As for your original issue it looks like some errant $ exist in your fstab file? I'll double my instructions tomorrow just in case that was my fault.

 

To be clear when trying to mount something via fstab both parts must exists. So before you can mount your unraid it must exist (obviously) but the same goes for the second half of the equation, your mount point. In your case this appears to be /mnt/DVDs so make sure that exists by doing the mkdir command.

 

mkdir /mnt/DVDs

mount -a

ls /mnt/DVDs

 

Did that show you your file listing? Good. Move on.

 

Then in plex adding a library section should take seconds. Login via your IP to plex, usually something like

 

192.168.0.4:32400/web

 

Will work. Then look for add section, then navigate to /mnt/DVDs

 

That /should/ be it. :)

 

Sent from my Nexus 5 using Tapatalk

 

Thanks for the good work I apologize for my short bus knowledge of linux. The command after mkdir shows

[root@ArchApplianceVM_v3 ~]# ls /mnt/DVDs
[root@ArchApplianceVM_v3 ~]#

Share this post


Link to post

No joke sir. I'm an idiot at this stuff. Looks like I can cd into it the DVDs directory but I can't figure out how to add to plex.

 

Do not proceed until you can type in at the bash prompt "ls -l /mnt/DVDs" and get the listing of files & directories you expect.

 

First, view your plex admin, change IP to match yours: http://192.168.1.201:32400/web/

Click on the "+" icon under "My Library"

Click on the "Movies" icon

Type a name for the library section and click on "Add Folder"

Type in "/mnt/DVDs" in the text field or browse to the location and click "Add".

 

Based on the size of your library, it may take some time to display everything. There is an activity icon at the top of the page to let you follow the status.

 

I ran the command and this is the read out

[root@ArchApplianceVM_v3 ~]# ls -l /mnt/DVDs
total 0

Share this post


Link to post
Thanks for the good work I apologize for my short bus knowledge of linux. The command after mkdir shows

[root@ArchApplianceVM_v3 ~]# ls /mnt/DVDs
[root@ArchApplianceVM_v3 ~]#

 

Hey - you figured out how to use the CODE button, there's hope for you still.  ;)

 

The place for the mount exists, what are the current contents of your /etc/fstab file? You can type in "/cat /etc/fstab" instead of viewing in nano.

 

What is a working share location in Windows Explorer?

Share this post


Link to post

I swear, I need to create a link to nano because I can't seem to NOT type "nemo" instead.

Share this post


Link to post

Thanks for the good work I apologize for my short bus knowledge of linux. The command after mkdir shows

[root@ArchApplianceVM_v3 ~]# ls /mnt/DVDs
[root@ArchApplianceVM_v3 ~]#

 

Hey - you figured out how to use the CODE button, there's hope for you still.  ;)

 

The place for the mount exists, what are the current contents of your /etc/fstab file? You can type in "/cat /etc/fstab" instead of viewing in nano.

 

What is a working share location in Windows Explorer?

 

LOL I try hard coach:

[root@ArchApplianceVM_v3 ~]# cat /etc/fstab
#
# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>       <dump>  <pass>
#//tower/DVDs /mnt/DVDs cifs noauto,x-systemd.automount,ro,username=nobody,password=,_netdev 0 0
# /dev/xvda1
UUID=93ec2c22-36c1-487c-a888-adde602a16fe       /               ext4            rw,                 relatime,data=ordered   0 1

 

Index of \\tower\dvds\

Name Size Date Modified

[parent directory]

BLURAY/ 2/12/14 3:42:17 AM

Original/ 2/11/14 9:23:38 AM

TV/ 7/6/11 11:42:26 AM

Share this post


Link to post

# at the start ofa line is a comment and that line is therefore ignored.

 

Remove it and try again.

 

Sent from my Nexus 5 using Tapatalk

 

 

Share this post


Link to post

Okay so remove the # sign?

 

[root@ArchApplianceVM_v3 ~]# ls -l /mnt/DVDs

total 4

drwxr-xr-x 2 root root 4096 Feb 12 23:21 BLURAY

 

Share this post


Link to post

Index of \\tower\dvds\

Name Size Date Modified

[parent directory]

BLURAY/ 2/12/14 3:42:17 AM

Original/ 2/11/14 9:23:38 AM

TV/ 7/6/11 11:42:26 AM

 

Once you get the mount working, here's a modification to the paths you should enter into Plex - run through the process twice, once for each. I believe if you type "Movies" twice, it combines the contents into the same section - or you can create two sections, one for BluRay and one for DVD (assuming that's for original)

/mnt/DVDs/BLURAY

/mnt/DVDs/Original

 

Then add a new section clicking on the TV icon and enter

/mnt/DVDs/TV

 

Share this post


Link to post
Guest
This topic is now closed to further replies.