Jump to content
ironicbadger

[XEN VM IMG] ArchVM <--- deprecated 01/07/2014

688 posts in this topic Last Reply

Recommended Posts

I just checked the security DVDs is public while the other shares are private and require a password. I think that may be the snag? Thank you sir I got it. Changed the security to public and all is fine. I read over the chmod 600 credential file and that sounds like jebberish.

 

You can also update the UserID & password fields in the fstab file to reflect a user id that has access.

Share this post


Link to post

Yup. That'd do it!

 

You're literally causing havoc. Glad your issues are sorted fella.

 

Sent from my Nexus 5 using Tapatalk

I appreciate the vast knowledge you guys have. Next VM I'm gonna tackle is the owncloud. Fingers crossed.

Share this post


Link to post

First off - badger, incredible guide...been excitedly waiting for this since you first announced you had unraid on arch with hypervisor support.

 

To the question - I'm having an issue with Plex on my TV and i'm trying to get to the logs to post on the plex forums...from what i understand the logs are located at:

 

/opt/plexmediaserver/Library/Application Support/Plex Media Server/Logs/

 

for some reason I can't change directories beyond Library...any ideas why? It seems to drop off Support from the command

 

[root@ArchApplianceVM_v3 ~]# cd /opt/plexmediaserver/Library/Application Support
-bash: cd: /opt/plexmediaserver/Library/Application: No such file or directory
[root@ArchApplianceVM_v3 ~]# cd /opt/plexmediaserver
[root@ArchApplianceVM_v3 plexmediaserver]# cd /opt/plexmediaserver/Library/Application_Support
-bash: cd: /opt/plexmediaserver/Library/Application_Support: No such file or directory
[root@ArchApplianceVM_v3 plexmediaserver]# cd /opt/plexmediaserver/Library/ApplicationSupport
-bash: cd: /opt/plexmediaserver/Library/ApplicationSupport: No such file or directory
[root@ArchApplianceVM_v3 plexmediaserver]# cd /opt/plexmediaserver/Library
[root@ArchApplianceVM_v3 Library]# ls
Application Support
[root@ArchApplianceVM_v3 Library]# 

Share this post


Link to post

[root@ArchApplianceVM_v3 Library]# find / -name logs
/opt/headphones/.git/logs
/opt/couchpotato/.git/logs
[root@ArchApplianceVM_v3 Library]# 

 

strange, the app is set to debug to PMS.

Share this post


Link to post

Tbh I'm not a huge plex knowledge base. Maybe start a separate thread on this issue please to get eyeballs that know as opposed to me who is just guessing.

 

Sent from my Nexus 5 using Tapatalk

 

 

Share this post


Link to post

First off - badger, incredible guide...been excitedly waiting for this since you first announced you had unraid on arch with hypervisor support.

 

To the question - I'm having an issue with Plex on my TV and i'm trying to get to the logs to post on the plex forums...from what i understand the logs are located at:

 

/opt/plexmediaserver/Library/Application Support/Plex Media Server/Logs/

 

for some reason I can't change directories beyond Library...any ideas why? It seems to drop off Support from the command

 

[root@ArchApplianceVM_v3 ~]# cd /opt/plexmediaserver/Library/Application Support
-bash: cd: /opt/plexmediaserver/Library/Application: No such file or directory
[root@ArchApplianceVM_v3 ~]# cd /opt/plexmediaserver
[root@ArchApplianceVM_v3 plexmediaserver]# cd /opt/plexmediaserver/Library/Application_Support
-bash: cd: /opt/plexmediaserver/Library/Application_Support: No such file or directory
[root@ArchApplianceVM_v3 plexmediaserver]# cd /opt/plexmediaserver/Library/ApplicationSupport
-bash: cd: /opt/plexmediaserver/Library/ApplicationSupport: No such file or directory
[root@ArchApplianceVM_v3 plexmediaserver]# cd /opt/plexmediaserver/Library
[root@ArchApplianceVM_v3 Library]# ls
Application Support
[root@ArchApplianceVM_v3 Library]# 

 

Maybe I'm missing something here, but this is Linux, so spaces are a pain and require a "\" before the space.  Shouldn't you be typing cd /opt/plexmediaserver/Library/Application\ Support/

 

Or just type cd /opt/plexmediaserver/Library/App and then hit TAB.

Share this post


Link to post

Just press tab, if it's the only directory it will auto complete for you, and yeah spaces are not a great idea

Share this post


Link to post

ironicbadger first off thank you very much for  the videos they are golden for a noob with this stuff as I am. Question I have installed everything as per your videos and have a little more under standing of how this all works I am stuck trying to start up Logitech media server it is install ok but not sure if the correct command is systemctl enable logitechmediaserver this does not seem to start it, also trying  systemctl start logitechmediaserver file name does not exist or bad filename. Also where would I find the .ini file to change the setting as you described with nano for ports ects.

Thanks again

lou

Share this post


Link to post

[root@ArchApplianceVM_v3 Library]# find / -name logs
/opt/headphones/.git/logs
/opt/couchpotato/.git/logs
[root@ArchApplianceVM_v3 Library]# 

 

strange, the app is set to debug to PMS.

 

cd /opt/plexmediaserver/Library/Application\ Support/Plex\ Media\ Server/Logs/

 

Share this post


Link to post

cd /opt/plexmediaserver/Library/Application\ Support/Plex\ Media\ Server/Logs/

Maybe I'm missing something here, but this is Linux, so spaces are a pain and require a "\" before the space.  Shouldn't you be typing cd /opt/plexmediaserver/Library/Application\ Support/

Or just type cd /opt/plexmediaserver/Library/App and then hit TAB.

Just press tab, if it's the only directory it will auto complete for you, and yeah spaces are not a great idea

 

Thanks guys!

Share this post


Link to post

I just copied and pasted the path from my Plex install... Spaces are a pain and so are caps vs no caps,  but I don't control what the app does. 

 

Glad I could help.

Share this post


Link to post

In reply to the networking issues:

 

Set a static IP address in Arch

 

1. Find out your LAN information such as your Gateway and DNS settings.

 

2. Copy the template into the right directory the load up nano to edit it

 

cd /etc/netctl
cp examples/ethernet-static ethernet
nano ethernet

 

3. You will have a file with many lines, you only need to edit Address, Gateway and DNS. For example:

 

Address=('192.168.1.23/24')    <--- only one IP address here
Gateway='192.168.1.1'             <--- usually your router, ditto for DNS
DNS=('192.168.1.1')

 

3. Press Ctrl + X to exit and save the file with nano.

 

4. Enable the profile you've just created

 

netctl enable ethernet   <--- enables connection autostart at boot
netctl start ethernet <--- or reboot here, will have the same effect

 

 

This does not work for me... I get "Job for netctl@ethernet.service failed. See 'systemctl status netctl@ethernet.service' and 'journalctl -xn' for details."

 

[root@ArchApplianceVM_v3 netctl]# systemctl status netctl@ethernet.service -l

netctl@ethernet.service - A basic static ethernet connection

  Loaded: loaded (/etc/systemd/system/netctl@ethernet.service; enabled)

  Active: failed (Result: exit-code) since Sat 2014-02-15 08:47:34 GMT; 2min 5s ago

    Docs: man:netctl.profile(5)

  Process: 795 ExecStart=/usr/lib/network/network start %I (code=exited, status=1/FAILURE)

Main PID: 795 (code=exited, status=1/FAILURE)

 

Feb 15 08:47:34 ArchApplianceVM_v3 network[795]: Starting network profile 'ethernet'...

Feb 15 08:47:34 ArchApplianceVM_v3 network[795]: The interface of network profile 'ethernet' is already up

Feb 15 08:47:34 ArchApplianceVM_v3 systemd[1]: netctl@ethernet.service: main process exited, code=exited, status=1/FAILURE

Feb 15 08:47:34 ArchApplianceVM_v3 systemd[1]: Failed to start A basic static ethernet connection.

Feb 15 08:47:34 ArchApplianceVM_v3 systemd[1]: Unit netctl@ethernet.service entered failed state.

 

The command shown in https://wiki.archlinux.org/index.php/Network_Configuration#Static_IP_address

"ip addr add 192.168.1.xxx/24 broadcast 192.168.1.255 dev eth0"

 

works fine, but I have to do in manually when archVM starts...

 

Thoughts?

 

Best regards

Nic

 

Share this post


Link to post

Post the Ethernet file contents.

 

Description='A basic static ethernet connection'

Interface=eth0

Connection=ethernet

IP=static

Address=('192.168.1.8/24')

#Routes=('192.168.0.254/24)

Gateway='192.168.1.254'

DNS=('192.168.1.254')

 

## For IPv6 autoconfiguration

#IP6=stateless

 

## For IPv6 static address configuration

#IP6=static

#Address6=('1234:5678:9abc:def::1/64' '1234:3456::123/96')

#Routes6=('abcd::1234')

#Gateway6='1234:0:123::abcd'

 

Thanks for your help :)

Nic

Share this post


Link to post

One other small thing ...

 

I've edited fstab in archVM to access shares on Unraid via CIFS, however I have to manually issue the 'mount -a' command after a reboot of the VM, then it picks up the access correctly.

 

 

cheers

Nic

Share this post


Link to post

Yes Nic, this is due to the 30-60 delay as previously mentioned. I don't know a way around this yet. it is why I prefer the autofs NFS option ( /net/unraid etc..)

Share this post


Link to post

ironicbadger first off thank you very much for  the videos they are golden for a noob with this stuff as I am. Question I have installed everything as per your videos and have a little more under standing of how this all works I am stuck trying to start up Logitech media server it is install ok but not sure if the correct command is systemctl enable logitechmediaserver this does not seem to start it, also trying  systemctl start logitechmediaserver file name does not exist or bad filename. Also where would I find the .ini file to change the setting as you described with nano for ports ects.

Thanks again

lou

Anyone is this the correct enable & start name for  logitechmediaserver  as in (systenctl enable logitechmediaserver) ? I can not get it to start

Thanks

Share this post


Link to post

Hey guys

 

Was helping a friend setting up his new Unraid server and used this great vm.

 

I noticed two things that I had to do:

 

Madsonic

Letters like Ö ü á etc did not work since it wants en_US.UTF-8 not the locale set in the arch vm en_UK.UTF-8

 

The fix is to uncomment line 157 en_US.UTF-8 in /etc/locale.gen

Then run locale-gen

 

The other solution would be to change the locale in lines 21-22 in /var/madsonic/madsonic.sh

 

Sickbeard

The other problem I saw was auto processing.

I had to give the sabnzbnd user access to the post processing files

chown -R sabnzbd:sabnzbd /opt/sickbeard/autoProcessTV/

 

My recommendation is that sick/sab/headphones/cp all run as user:nobody I don't see the reason to have multiple users for this :)

 

Then we have to accomidate that we both have python2 and python3 in this vm

Change the first line in to /opt/sickbeard/autoProcessTV/sabToSickBeard.py to  #!/usr/bin/env python2

 

Since we are talking about Sickbeard the update fails since it has wrong permission but running this command fixes that

chown -R sickbeard:sickbeard /opt/sickbeard/

Share this post


Link to post

ironicbadger first off thank you very much for  the videos they are golden for a noob with this stuff as I am. Question I have installed everything as per your videos and have a little more under standing of how this all works I am stuck trying to start up Logitech media server it is install ok but not sure if the correct command is systemctl enable logitechmediaserver this does not seem to start it, also trying  systemctl start logitechmediaserver file name does not exist or bad filename. Also where would I find the .ini file to change the setting as you described with nano for ports ects.

Thanks again

lou

Anyone is this the correct enable & start name for  logitechmediaserver  as in (systenctl enable logitechmediaserver) ? I can not get it to start

Thanks

 

Lou, look through this thread as its already been covered how to find the name of your service.

 

Sent from my Nexus 5 using Tapatalk

 

 

Share this post


Link to post

ironicbadger first off thank you very much for  the videos they are golden for a noob with this stuff as I am. Question I have installed everything as per your videos and have a little more under standing of how this all works I am stuck trying to start up Logitech media server it is install ok but not sure if the correct command is systemctl enable logitechmediaserver this does not seem to start it, also trying  systemctl start logitechmediaserver file name does not exist or bad filename. Also where would I find the .ini file to change the setting as you described with nano for ports ects.

Thanks again

lou

Anyone is this the correct enable & start name for  logitechmediaserver  as in (systenctl enable logitechmediaserver) ? I can not get it to start

Thanks

 

Lou, look through this thread as its already been covered how to find the name of your service.

 

Sent from my Nexus 5 using Tapatalk

Thanks did that several times maybe need a break for a bit. lot to take in at once.

Lou

Share this post


Link to post

Thanks for the advice follow the thread to find the service /usr/lib/systemd/system came up with logitechmediaserver.service

did the systemctl enable logitechmediaserver.service

did the ip addr and I only get the arch ip

grep shows:

root    13137  0.0  0.0  5088  1032 pts/0    S+  19:07  0:00 grep logitechmediaserver.service

 

I did install owncloud with no problem just can't seem to lock on to this one.

lou

Share this post


Link to post

Okay, I am 99% done configuring this VM as I want it, but am having an issue.

 

I've configured a static IP address:

 

Description='A basic static ethernet connection'

Interface=eth0

Connection=ethernet

IP=static

Address=('192.168.1.43/24')

Gateway='192.168.1.1'

DNS=('192.168.1.10' '192.168.1.11')

 

## For IPv6 autoconfiguration

#IP6=stateless

 

## For IPv6 static address configuration

#IP6=static

#Address6=('1234:5678:9abc:def::1/64' '1234:3456::123/96')

#Routes6=('abcd::1234')

#Gateway6='1234:0:123::abcd'

 

I've confirmed that the address is assigned:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

      valid_lft forever preferred_lft forever

    inet6 ::1/128 scope host

      valid_lft forever preferred_lft forever

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether 00:16:3e:00:00:00 brd ff:ff:ff:ff:ff:ff

    inet 192.168.1.43/24 brd 192.168.1.255 scope global eth0

      valid_lft forever preferred_lft forever

    inet6 fe80::216:3eff:fe00:0/64 scope link

      valid_lft forever preferred_lft forever

 

I can ping out no problem from the VM:

 

[root@ArchApplianceVM_v3 netctl]# ping 192.168.1.1

PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.

64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=0.501 ms

64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=0.527 ms

64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=0.604 ms

64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=0.595 ms

^C

--- 192.168.1.1 ping statistics ---

4 packets transmitted, 4 received, 0% packet loss, time 3000ms

rtt min/avg/max/mdev = 0.501/0.556/0.604/0.052 ms

 

However when I try and ping the VM from an outside computer I get:

 

Pinging 192.168.1.43 with 32 bytes of data:

Reply from 192.168.1.43: bytes=32 time=19ms TTL=64

Reply from 192.168.1.43: Destination port unreachable.

Reply from 192.168.1.43: Destination port unreachable.

Reply from 192.168.1.43: Destination port unreachable.

Reply from 192.168.1.43: Destination port unreachable.

 

Ping statistics for 192.168.1.43:

    Packets: Sent = 5, Received = 5, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 19ms, Maximum = 19ms, Average = 19ms

 

I occasionally get a proper ping, but 99.9% of the time I get 'destination port unreachable'. This has been tested from multiple computers, all with the same result.

 

Also, the VM has been up for 10-15 minutes so it's not the issue of networking taking time to initialize.

 

Any idea why this would be? Any suggestions on how to fix this?

Share this post


Link to post

I forgot to mention, if I change it back to DHCP, I can ping all day without issue:

 

[root@archvm ~]# ip addr

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default

    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00

    inet 127.0.0.1/8 scope host lo

      valid_lft forever preferred_lft forever

    inet6 ::1/128 scope host

      valid_lft forever preferred_lft forever

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000

    link/ether 00:16:3e:00:00:00 brd ff:ff:ff:ff:ff:ff

    inet 192.168.1.63/24 brd 192.168.1.255 scope global eth0

      valid_lft forever preferred_lft forever

    inet6 fe80::216:3eff:fe00:0/64 scope link

      valid_lft forever preferred_lft forever

 

From external machine:

 

Pinging 192.168.1.63 with 32 bytes of data:

Reply from 192.168.1.63: bytes=32 time=4ms TTL=64

Reply from 192.168.1.63: bytes=32 time<1ms TTL=64

Reply from 192.168.1.63: bytes=32 time=1ms TTL=64

Reply from 192.168.1.63: bytes=32 time=10ms TTL=64

Reply from 192.168.1.63: bytes=32 time=2ms TTL=64

Reply from 192.168.1.63: bytes=32 time=1ms TTL=64

Reply from 192.168.1.63: bytes=32 time=1ms TTL=64

 

Ping statistics for 192.168.1.63:

    Packets: Sent = 7, Received = 7, Lost = 0 (0% loss),

Approximate round trip times in milli-seconds:

    Minimum = 0ms, Maximum = 10ms, Average = 2ms

 

It is only an issue if I assign a static ip address.

 

UPDATE: Apparently my issue was with the specific IP address I picked. Even though I don't think I had anything else using it, I tried a completely different one with Static IP and life is good.

 

Carry on... nothing to see here.  :-[

 

Share this post


Link to post
Guest
This topic is now closed to further replies.