Jump to content

User password change not saving to smbpasswd file....Bug?

Recommended Posts

Running 5.0.6 and when attempting to change a (non root) user password through the web interface, after typing the correct password twice and applying, it shows the smb restarting, but the password for the user is not being changed. I tried straight smbpasswd -a USER from the console, but it doesn't save either. Any ideas?

Link to comment

alpha numeric 12 characters password...


flash drive definitely not read only, i'm able to change my smb shares config through a flash drive share.


Is there a way to do it manually beyond what i've already tried?



Link to comment

After doing a bit of playing...something wonky and intermittent


the command line smbpasswd is changing /etc/samba/private/smbpasswd

and /etc/samba/private/passdb.tdb


the password location in unraid seems to be /boot/config/smbpasswd

and /boot/config/shadow


/usr/bin/smbpasswd -a username -D 1 -c /boot/config/smbpasswd

entering new password, (after changing the wrong location), cp'ing it to the flash location


then update the password through the web interface to the new password

updates /boot/config/shadow and /boot/config/smbpasswd


I'm guessing that the command line is changing something necessary other than the smbpasswd that is not being updated by the webgui. Both changes seem necessary for Win7 clients to login to shares. Could an in place update previously have caused some incompatibility?


Link to comment


This topic is now archived and is closed to further replies.

  • Create New...