Jump to content

Reinstall and need to ID the disks


Recommended Posts

I was running unRAID as an ESXi VM and had a power failure that caused my ESXi and unRAID usb drives to fail. I was able to reinstall both but I am unsure how to identify each of the existing disks from the previous unRAID setup. Each of the 3 drives are showing up in web gui but I don't have the assigned. I don't want to loose the data. What is the best way to get it running again?


Thanks in advance!

Link to comment

Sorry... I want to be careful and not screw it up; I have 3 drives. The main tab on the web interface has the 4 devices listed (parity, disk1, disk2, and flash). Under the Indentification section I have drop downs for the 3 physical drives. The array is currently stopped and not in mainenance mode. If I select one of the 3 drives for disk1 or disk2, I see the temp and size listed but no frees space listed.


Am I doing something wrong or missing a step?


I've attached a screenshot of what I'm seeing.


Link to comment

I don't have any syslogs from the previous installation, but I saved from the current one. I zip'd it for size.


That's from the current system, not the previous, so is no help as to what you had previously assigned.  I have to admit some surprise, as it's hard to imagine you not having a single syslog or screen pic or note about what drives were assigned.  We still have possibilities, do you have a copy of your super.dat, preferably from a backup.  The super.dat file is found on your flash drive in the config folder.


By the way, please see Need help? Read me first! for the correct way to download the syslog.  We always need it in its original raw text form.

Link to comment

WHen I assign a drive to device and then click on the device I get the following page (see attached). All three drives are listed as unknown file system type. This is really starting to get me worried!  :(


I don't think that's a problem, it's "unknown" because it hasn't tried to examine the file system yet.  Don't assign anything to the parity drive.  If you assign one drive (to Disk 1), then try to start the array, it should tell you pretty quickly if it's not formatted.  Quit without continuing to start the array, and re-assign a different drive to Disk 1, and test again.

Link to comment

THAT'S IT!!! It worked! I wasn't starting the array to see the results. The drives ended up being in order and fully working. I was jsut terrified to start the array, thinking that by doing so it would force whatever position I chose to be the new order and possible reformat or somehow destory the existing contents. I was just so very cautious about pressing button without knowing the consequences.


Regarding notes; I had orginally stored everything on a separate workstation but well after the initial installation I moved everything to a directory on the unRAID for longterm storage. Silly me... I just didn't consider that if the entire ESXi server went down I wouldn't have access to any of it.


Anyways... THANK YOU so very much for helping with this. I am soo relieved.


Link to comment


This topic is now archived and is closed to further replies.

  • Create New...