Jump to content
linuxserver.io

[Support] Linuxserver.io - Codiad

14 posts in this topic Last Reply

Recommended Posts

linuxserver_medium.png

 

Application Name: Codiad

Application Site: http://codiad.com/

Docker Hub: https://hub.docker.com/r/linuxserver/codiad/

Github: https://github.com/linuxserver/docker-codiad

 

Please post any questions/issues relating to this docker you have in this thread.

 

If you are not using Unraid (and you should be!) then please do not post here, instead head to linuxserver.io to see how to get support

Edited by linuxserver.io

Share this post


Link to post

I tried to install this, but could not get past the initial configuration.  After filling all the fields and selecting Install, it keeps insisting that all fields must be filled out.  I have checked every field on the page, and every one is filled, but it will not pass past that point.

Share this post


Link to post
I tried to install this, but could not get past the initial configuration.  After filling all the fields and selecting Install, it keeps insisting that all fields must be filled out.  I have checked every field on the page, and every one is filled, but it will not pass past that point.
Probably a required field that appears if you hit show more settings or advanced view

Sent via telekinesis

Share this post


Link to post

The only thing in show more settings is the appdata config path which is filled out.  advanced view also just shows blank spaces for extra parameters and post arguments.  but there is no indication of what would need to be put in there.

Share this post


Link to post

Perhaps I should clarify. the container installs into Unraid just fine.  its when you first run it, you go to the WebUI and it asks  you do do an initial setup like setting up a username/password and initial project.  thats the stage I cant pass.  

Share this post


Link to post
1 hour ago, mattekure said:

Perhaps I should clarify. the container installs into Unraid just fine.  its when you first run it, you go to the WebUI and it asks  you do do an initial setup like setting up a username/password and initial project.  thats the stage I cant pass.  

Just tried this, worked absolutely fine for me.
2019-05-17_20-01.png.4cbcff534a3c679772880064aeba4fb4.png

Share this post


Link to post

I get to that page, and when I click install I get the message saying all fields must be filled out.  when I click OK there, I get the second message saying do you really want to create project.....  clicking ok on that dismisses the message, but nothing happens.  it never goes into the actual codiad gui.

Screenshot_3.jpg

Screenshot_4.jpg

Share this post


Link to post
7 minutes ago, mattekure said:

I get to that page, and when I click install I get the message saying all fields must be filled out.  when I click OK there, I get the second message saying do you really want to create project.....  clicking ok on that dismisses the message, but nothing happens.  it never goes into the actual codiad gui.

 

What's your docker run command and anything in the logs?

Share this post


Link to post

On another note, it looks like the Codiad maintainers have given up maintaining the project, so it's future as a container we'd offer may be in doubt, there is a fork though, so I need to look into things a little more and speak to the team.

Share this post


Link to post

I'm not sure how to see the docker run command.  The images are everything in the log and all the settings from the docker.

Screenshot_5.jpg

Screenshot_6.jpg

Screenshot_7.jpg

Share this post


Link to post

Hmm, on https://hub.docker.com/r/linuxserver/codiad/ it shows that there is a docker parameter for TZ.  should I add that parameter?  it didnt exist when I installed it.

 

Edit: that didnt appear to do anything.  I set it exactly as it appears on the webpage, but it still asks for all fields to be filled out.

Edited by mattekure

Share this post


Link to post

Oh, I found the run command.

 

docker run -d --name='codiad' --net='bridge' -e TZ="America/New_York" -e HOST_OS="Unraid" -e 'PUID'='99' -e 'PGID'='100' -p '8088:80/tcp' -v '/mnt/cache/appdata/codiad':'/config':'rw' 'linuxserver/codiad' 

 

Edited by mattekure

Share this post


Link to post

Ok, sorry for the false alarm.  It was my fault.  one of my browser extensions (chromeiPass to auto fill in passwords) was injecting input fields into the page which were triggering the code that looks for blank fields.  once I disabled that extension, it worked just fine.

Share this post


Link to post
Guest
This topic is now closed to further replies.