[deprecated] paulpoco - DelugeVPN-Flexget


Recommended Posts

nice work paul_ber!, couple of points you might want to look into:-

 

1. changing the incoming port is only necessary if the vpn provider is NOT PIA, as i automagically set this for the user :-), you might want to note that in your instructions.

 

2. you might want to consider looking into AUR (arch user repository), this will vastly simplify the install of FlexGet for you, basically all the hard work is done by arch users and you simply then chmod/chown it for the correct user the docker container runs as, and then start it via supervisord, take a look here for examples of how im using this for another container i maintain (couchpotato):-

 

https://raw.githubusercontent.com/binhex/arch-couchpotato/master/setup/root/aur.sh

 

search result from AUR showing the stable and bleeding edge versions of flexcget on aur:-

https://aur.archlinux.org/packages/?O=0&SeB=nd&K=flexget&outdated=&SB=n&SO=a&PP=50&do_Search=Go

 

so you could simply take this above script, change the name to flexget in there, and include it as part of the docker build, just makes things easier, but of course its completely up to you :-).

 

edit - i must be going blind, i cant see where you define the install of flexget :-). spotted it, i see your installing it using python pip.

Link to comment

Binhex thanks.

 

Yes the incoming port was because I wasn't using PIA, I'll edit that later.

 

What do you think of the way I set the the Flexget-webui password?  It was a pain to have to enter the container and set it.

 

Sent from my XT1563 using Tapatalk

 

 

Link to comment

Binhex thanks.

 

Yes the incoming port was because I wasn't using PIA, I'll edit that later.

 

What do you think of the way I set the the Flexget-webui password?  It was a pain to have to enter the container and set it.

 

Sent from my XT1563 using Tapatalk

 

if you cant set the password via command line then the password could be done in a couple of ways:-

 

1. create an env var (expose via unraid xml) and allow the user to define it that way, then on init it sets the password:-

flexget web passwd <env var password>

 

2. find out what file the above command is modifying and sym link the file outside of the container, this then allows the user to edit, save, and restart for the change to take effect.

 

 

Link to comment
  • 2 weeks later...
  • 4 months later...

This is perfect although I used binhex's container without issue but wanted the Flex Get.  However, when running this container with the exact same variables for PIA that I had before, the web UI for deluge comes up for a few minutes but then becomes unreachable.  Also, in his container, the network interface etc is shown but everything is blank in the preferences.  I realize the thread talks about configuring the auth file, but with what username:password?  Any?  Doesn't seem to help as I cannot commit changes to the preferences table and within a couple of minutes the UI is unreachable as if it connects to VPN but did not take the -e LAN_NETWORK variable for whatever reason.  Container is up and running.  Also, there is no passing of the port 3589, should there be?  Otherwise it is unreachable.  I am going to destroy and re-build with changing the ports but for whatever reason I must be missing a step.  Thanks!

Link to comment

Actually, a bit of an update.  I rebuilt the container and the deluge piece is now working as expected.  Needed to delete the existing container config file although not sure if that was a culprit or just a wonky build the first time.  I cannot get to the Flexget piece with or without passing 3539 to the container or not.  When I attempt to set the password it gives the below:

 

 

Link to comment

So once configuring the initial config.yml file for Flexget, I assume we restart etc. Issue is, when I do that, I get the above issue with the Deluge piece stopping and becoming inaccessible.  If I delete the config file from the container path, rebuild the container, it seems to correct that behavior but then I have lost the flexget config as well.  Tried to look other places for submitting the issues, but I am afraid this older thread is the only place I could find.  Thanks for any help.

Link to comment

So, I'd been running for some time without issues. I went ahead and allowed an update (no, I don't know why...) and now I can't get a connection.

 

Log file is showing me:

 

2016-10-08 16:03:30,788 DEBG 'start-script' stdout output:
Sat Oct  8 16:03:30 2016 VERIFY ERROR: depth=1, error=self signed certificate in certificate chain: C=US, ST=OH, L=Columbus, O=Private Internet Access, CN=Private Internet Access CA, emailAddress=secure@privateinternetaccess.com
Sat Oct  8 16:03:30 2016 OpenSSL: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
Sat Oct  8 16:03:30 2016 TLS_ERROR: BIO read tls_read_plaintext error
Sat Oct  8 16:03:30 2016 TLS Error: TLS object -> incoming plaintext read error
Sat Oct  8 16:03:30 2016 TLS Error: TLS handshake failed

 

Any suggestions what I've got going on here?

Link to comment

Hi Paul,

 

Is there any way you could also make a docker that just has flexget without deluge?

 

Rix removed his docked template and suggested that you might be able to create one without the deluge component.

 

Thanks!

 

 

Sent from my iPhone using Tapatalk

 

+1

 

A vanilla flexget would be great.

Link to comment
  • 4 weeks later...

Hi Paul

 

Is it possible to add the variable NAME_SERVERS as used in binhex-delugevpn? I user BT as my ISP and I have added the router (192.168.1.254) as the primary DNS server under binhex-delugevpn and this allows the VPN to connect. Using the standard Google DNS is not allowed and the lookup fails. I can connect the the DelugeVPN-Flexget VPN if I specify the IP address of the VPN server, but leaving it this way is not ideal.

 

I have tried adding the variable manually, but this seems to prevent the VPN initialising and the Deluge UI does not come up.

 

Many thanks.

Link to comment
  • 3 months later...

I updated to unRAID v6.3.2, updated all docker containers and plug-ins and now Deluge is no longer downloading. The torrents will show up but is full of errors like these:

 

opentrackr.org: Error: Invalid argument

checkmytorrentip.net: Error: Connection timed out

62.138.0.158: Error: Invalid argument

trackerfix.com: Error: Connection timed out

leechers-paradise.org: Error: Invalid argument

 

Any suggestions? Thank you.

 

Peter

Link to comment
  • 3 weeks later...
2 hours ago, Paul_Ber said:

Has Binhex fixed it for his DelugeVPN?

 

I can look at what Binhex did to implement the PIA change.

 

This Container is just a hobby, not really an active Dev.  If it works, I usually don't work on it.

 

I thought he had but when I tried to run his as a test, got the same issue. I'll keep an eye out for a fix from him and let you know. No worries.

Link to comment

I got it updated to what Binhex has done so far.

 

I see the update in Dockers.  The Docker-template is still the Feb 12 version, not sure how long this update takes.  So I haven't tried the update yet, waiting for the Template in the Apps section to show March 10, 2017. The newer app template has the new ENV variables that Binhex has introduced.

Edited by Paul_Ber
Link to comment
  • Paul_Ber changed the title to [deprecated] paulpoco - DelugeVPN-Flexget

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.