Chmod 077? How to search and fix


Akio

4 posts in this topic Last Reply

Recommended Posts

As confusing as it might be for some, leaving the default permissions alone on certain popular dockers like sonarr, radarr, sabnzb, couchpotato etc etc seems common sense.

 

Those of us to want to make better use or setup expert/advanced settings can still mess up and have a typo cause alot of trouble. Ive trawled through the forum best i can and still havent manage to fix my issue.

 

My question and plea for some help is this:

Is there a command someone help me with,  i want to find and correct the folder/file chmod  from 077  to 0777?

 I tried the new docker permissions tool but after some 2 hours of work it didnt relsove this one issue.

 

By the way, this was a mistake i made in couchpotato settings before moving and renaming some rips  from a temp folder to one of the movie share folders.

That parent share folder is accessible from my win10 pc and few of the older sub folders but any created by couch is doomed to be restricted.

Details-

All the user shares are set up in place and havent been touched. 

Win10pro pc  accessing smb share  on Unraid 6.3.3 

Know the file inside restricted folder works as plex was playing 

 

Link to post
  • 2 years later...

Very Helpful Squid!  Thanks.

 

I first tried newperms on a particular share, but it did not seem to fix an issue I was having with some old backups that I am trying to purge.  I ended up using 

 

 

chmod -R 0777 /mnt/user/SHARENAME

 

There seems to be files that this does not work on.  I have not completely narrowed it down, but it seems it is either extremely long file names, file names with special characters, or folders with special characters that the command is not working on (I thought it also had to do with files or folders that had spaces in them but that does not seem to be the case.  Is there a command that can be added as a catch all for those type conditions?  OR is there a way to strip special characters from file names, or truncate long file names?

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.