Jump to content

[SOLVED] BTRFS Cache disks wrong space (RAID0)


Recommended Posts



My problem is each day the cache free space is lower although I remove data from the VMs. I have used the balance, scrub, etc but my problem is still there.


In the past, I had this problem as well and I solved it moving the data to the array and recreating the cache disks but it is tedious to make always.


Here the info about the space using df, btrfs df and btrfs usage:

root@Casa:/mnt/cache# df -h | grep sdc1
/dev/sdc1       466G  462G  2.3G 100% /mnt/cache
root@Casa:/mnt/cache# btrfs filesystem df /mnt/cache
Data, RAID0: total=461.71GiB, used=459.44GiB
System, RAID1: total=32.00MiB, used=48.00KiB
Metadata, RAID1: total=2.00GiB, used=659.02MiB
GlobalReserve, single: total=512.00MiB, used=0.00B
root@Casa:/mnt/cache# btrfs filesystem usage -h /mnt/cache
    Device size:                 465.77GiB
    Device allocated:            465.77GiB
    Device unallocated:            2.05MiB
    Device missing:                  0.00B
    Used:                        460.73GiB
    Free (estimated):              2.26GiB      (min: 2.26GiB)
    Data ratio:                       1.00
    Metadata ratio:                   2.00
    Global reserve:              512.00MiB      (used: 0.00B)

Data,RAID0: Size:461.71GiB, Used:459.44GiB
   /dev/sdc1     230.85GiB
   /dev/sdd1     230.85GiB

Metadata,RAID1: Size:2.00GiB, Used:659.03MiB
   /dev/sdc1       2.00GiB
   /dev/sdd1       2.00GiB

System,RAID1: Size:32.00MiB, Used:48.00KiB
   /dev/sdc1      32.00MiB
   /dev/sdd1      32.00MiB

   /dev/sdc1       1.02MiB
   /dev/sdd1       1.02MiB

They are the values shown but if I use DU and btrfs du it is shown the correct size I have:

root@Casa:/mnt/cache# btrfs filesystem du -s /mnt/cache
     Total   Exclusive  Set shared  Filename
 345.57GiB   344.02GiB     1.55GiB  /mnt/cache
root@Casa:/mnt/cache# du -sh
346G    .


I have tried the balance multiples times with dconvert=raid0 and mconvert=raid1 without results. Also I have checked others posts in the forum but the problem is still there. The most probably is I don't know something related with the btrfs system, I am a newbie.


Does anybody know how I could solve it?


Thank you very much.


Attached my diagnostic.



Link to comment

Thank you for your answer johnnie.


But I just have two vdisks in the cache. One with 105GB and another with 240GB. They are the size shown in the OS of the VMs. Also have some config files of Dockers.


Really so much space is lost? When I created the cache the space was correct but each day is lower. I have configured them in RAID0. 


Maybe the btrfs is not the correct to my case?


Kind regards.

Link to comment

I have put it in the first post summarized, here all content without summarized option:


root@Casa:/mnt/cache# du -h /mnt/cache
16K     /mnt/cache/appdata/CUPS/cups/ssl
56K     /mnt/cache/appdata/CUPS/cups/ppd
120K    /mnt/cache/appdata/CUPS/cups
0       /mnt/cache/appdata/CUPS/spool/tmp
272K    /mnt/cache/appdata/CUPS/spool
64K     /mnt/cache/appdata/CUPS/logs
0       /mnt/cache/appdata/CUPS/cache/rss
6.5M    /mnt/cache/appdata/CUPS/cache
0       /mnt/cache/appdata/CUPS/cloudprint
7.0M    /mnt/cache/appdata/CUPS
0       /mnt/cache/appdata/plex/transcode/Transcode/Sessions
0       /mnt/cache/appdata/plex/transcode/Transcode
0       /mnt/cache/appdata/plex/transcode
........... Much files of config and metadata of plex
779M    /mnt/cache/appdata/plex/config
779M    /mnt/cache/appdata/plex
785M    /mnt/cache/appdata
105G    /mnt/cache/domains/Pedro
240G    /mnt/cache/domains/Sara
345G    /mnt/cache/domains
346G    /mnt/cache

Thank you very much johnnie.


Kind regards.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...