Jump to content

(Solved) Can't see nvme disk


Recommended Posts

Hey folks,


Complete newbie here starting out with a new unRaid 6.5.3 build on a Ryzen based system on an X470 based board.  Problem is that the 256 GB Sandisk nvme disk I was hoping to use as a cache disk is not showing up in unRaid.  If I boot on a Windows 10 PE disk, I can see it fine.  I have the unassigned devices plug-in and have tried enabling world wide names, but unraid doesn't seem to see the disk at all.  Boot logs seem to make no reference to the disk at all.  I've googled this to death, but can't find any useful info.


Can you give a newbie a hand?





Link to comment

Thanks for the advice.  I disabled virtualisation in the BIOS (called SVM in my UEFI BIOS), but it made no difference.  I was hoping to use this drive, simply because I had it spare and my board has an NVME socket on it.  I guess I'll just have to buy an SSD without a Marvell chipset.


Link to comment

Thanks for persisting with me - you were right.  The IOMMU option was buried several layers deep under the north bridge settings in my BIOS - not easy to find.  So now I see my SSD - Thank you so much.


Related question:  I know that hardware pass-through is important for VM performance.  Does it have any affect on dockers?  I was hoping to run Plex on this server.  Do dockers also make use of hardware passthrough?

Link to comment
  • BillR changed the title to (Solved) Can't see nvme disk


This topic is now archived and is closed to further replies.

  • Create New...