Jump to content
m4f1050

VM questions. Q35 vs i440fx, SeaBios vs OVMF, Hyper-V enabled or not

8 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Ok, so I installed a new unRAID server, and in the process, I mounted the old cache drive to the new unRAID server, and cloned my cache drive which contains all my dockers, vms, etc etc....


In the process my VM's got all whack.  I couldn't boot from my Win 10 VM, miraculous my Win2k8 R2 did boot.  I tried using the same "settings" from the W2k8R2 but didn't work, so I removed all the controller stuff and what not... Long story short, I now have my Win 10 booting and working, BUT, I did notice some different settings on my machines now.  I do know my W2k8R2 had to restart several times, so I am not sure what all changed, and would like if someone would be nice enough to explain to me a few things.

 

I would like to learn about each of these:

1. Machine:  i440fx-# (# is version I am assuming) vs Q35-#   --  Differences, advantages and features of each?

2. BIOS: SeaBIOS vs OVMF  --  Again, differences, advantages and features of each?

3. Hyper-V: Enabled or Disabled  --  If I am not going to run VM should this matter and should I disable it?  Any advantage of having it enabled or disabled?

 

The rest I pretty much understand, since it pertains to physical hardware types, etc etc, like:

USB controller, I use 2.0 (EHCI) since I have no user for USB 3.0 which I might change in the future since I recently purchased a USB 3.0 thumb drive and might be using it in the future.

Primary vDisk Bus (which I use SCSI and with the discard='unmap' for trim.

Graphics Card: I do video pass-thru, but I had to enable VNC so I could troubleshoot why it wasn't coming up and seeing the behavior it was having.

Sound Card: passing it through.

And finally but not least, USB Devices: I just pick the ones I want for that particular VM.  I also have the Libvirt Hotplug USB installed so I can attach/detach as I wish.

 

Thank you very much in advance.

 

EDIT:

Forgot to ask... Is it possible to mix USB 2.0 with USB 3.0 on my VM's?  (I have 4 USB 3.0 ports and I would like tho share 2 for one VM and 2 for the other and I have 10 USB 2.0 ports I would also like to share between VM's.)   Or do I have to say Win 10 VM is USB 3.0 only and W2kR8 is USB 2.0?

Edited by m4f1050

Share this post


Link to post

Anybody???

 

Trying to get (before I return it, ordered the GT 730) a GT 710 PCIe x1 to work, but it's giving me errors.  Maybe one of these settings might help?

Share this post


Link to post

The "Help" function gives more information about the different settings. Switch on Help by clicking on the Help button.

Share this post


Link to post

I wish I could say this helped, but it doesn't.  I need technical help, as to WHAT each feature is or does.  An explanation of the benefits, what they are intended for, etc etc.

 

What will SeaBIOS do?   What will OVMF do?  What are the differences between these?  Those kind of answers are what I am looking for.  More in-depth explanation.

 

Thanks!

Share this post


Link to post

This is getting *VERY* annoying quick!

I have tried EVERYTHING I have found on this website to no success.

What's up with NVidia graphics cards???

What makes them so "special" to get error 43's?

I asked a few questions, and I know some people know the answer to these, can you please explain the differences and help me configure this VM?

I *DONT* want to use anything lower than a GT 730 (or GT 710 if it works) since that's the fastest PCIe x1 I could find, and it's already not the greatest video card to have and want to do some minor gaming on that VM.

Share this post


Link to post

SeaBIOS vs OVMF: I think SeaBIOS is used for older OS that do not support UEFI and does not play as well with video card passthrough.

 

I440fx vs Q35: i440fx is a older, more supported hardware profile for windows, Q35 is a newer one that works best in Linux (and osx).

 

Your code 43 issue is because Nvidia does not want you to pass your video card to a VM.  I think KVM can hidethe HyperV flag so that the video card does not see it and it works.

 

FWIW: I have 2 Windows 10 VM's running as i440fx/OVMF with Nvidia GTX 1060 & 1070 cards passed through along with a usb card and nvme ssd with no issue.  I also have a OSX VM that is Q35/OVMF with the GTX 1070 passed to it along with the USB card and it works well also.

  • Upvote 1

Share this post


Link to post

THANK YOU!   These are the answers I was looking for.  🙂

 

I will try i440fx-3.0/OVMF.  I did find the USB 3.0/USB 2.0 answer myself, I setup one of my machines USB 3.0 and on my other VMs, both USB 3.0 were greyed out.  Now, which USB 3.0 XHCI is best, nec or qemu?

 

EDIT:

 

I didn't have EFI boot on my drive, going through repair and also searching Google to add EFI on my boot drive in case the repair doesn't add it.

 

In case someone else needs to do the same:

 


Convert MBR to GPT:

https://www.thewindowsclub.com/convert-mbr-to-gpt-disk

 

Fix EFI boot:

https://www.dell.com/support/article/us/en/04/sln300987/how-to-repair-the-efi-bootloader-on-a-gpt-hdd-for-windows-7-8-81-and-10-on-your-dell-pc?lang=en

 

Edited by m4f1050

Share this post


Link to post

🤬🤬🤬   This GT 710 will *NOT* work no matter what!

 

I put the GT 210 (pci) back on there and works FINE, no vBIOS, any BIOS (SeaBIOS or OVMF) and any machine (i440fx or Q35)

 

I'm done with NVidia's...   Going to buy different motherboard with 3 PCIe full size so I can use the RX 460.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now