Jump to content
tucansam

Power lost, UPS didn't work, unraid shutdown hard

3 posts in this topic Last Reply

Recommended Posts

Posted (edited)

root@ffs2:~# cat /boot/config/plugins/dynamix.apcupsd/dynamix.apcupsd.cfg
SERVICE="enable"
UPSCABLE="usb"
CUSTOMUPSCABLE=""
UPSTYPE="usb"
DEVICE=""
BATTERYLEVEL="10"
MINUTES="10"
TIMEOUT="0"
KILLUPS="no"
root@ffs2:~#
 

 

Nearly new Tripp Lite, tons and tons of capacity, with my unraid server being the only item plugged in.  Its a 17 drive system though, but usually a drive or two are spun up, at the most, so there isn't a huge power draw.

 

I just tripped a breaker, and heard the UPS complain.  I ran out to the panel and reset the breaker (15 amp circuits FOAD), and kept doing what I was doing.  Few hours later I noticed the unraid server was powered down.  Sweet, I hadn't tried the UPS since I installed it (not sure how to do it without risking hard-shutdowns).  I figured unraid must have shutdown shortly after the UPS went to battery, and powered it back on.

 

Parity check!

 

Logged in and system was doing a parity check (none scheduled), so a hard shutdown had occurred.  

 

Pic attached of UPS screen.  I don't know what to configure or how to (safely) test.  Any advice welcome.

 

Thanks.

ups.jpg

Edited by tucansam

Share this post


Link to post

Are you POSITIVE the server is plugged in to the correct outlet? Some UPS's have both battery protected and surge only outlets in the same area, distinguished only by some vague labels.

Share this post


Link to post

I notice the runtime report 180min and weird loading was zero (could be normal). As @jonathanm said, pls confirm unraid was plug-in UPS protect socket. 

Pls also check does other docker / VM cause unraid couldn't shutdown too.

 

2 hours ago, tucansam said:

how to (safely) test

Stop the array first.

 

Edited by Benson

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now