Jump to content
Sign in to follow this  
SSD

Strange Networking Issue

5 posts in this topic Last Reply

Recommended Posts

Hey all -

 

I've been away for a bit, but trying to update my server to 6.7.0 from 6.4.1.

 

Boots fine, but the server cannot access the Internet. It does see the local network.

 

Attempts to update plugins and dockers fail because server is unable to access the Internet.

 

When I start my Windows VM, the Windows VM CAN see the Internet.  It works fine.

 

Any help greatly appreciated!

 

I have attached my diagnostics.

 

Thanks for the help!!

 

-SSD

merlin-diagnostics-20190612-2239.zip

Share this post


Link to post

Did some Googling and found a suggestion to run the command ...

ip route add default via 192.168.1.1

which resolved the issue.

 

Why is this necessary? Have I misconfigured something?

 

Before running the command above:

root@merlin:~# route -n
Kernel IP routing table

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
172.17.0.0      0.0.0.0         255.255.0.0     U     0      0        0 docker0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br0
192.168.122.0   0.0.0.0         255.255.255.0   U     0      0        0 virbr0

 

After running the command above:

root@merlin:~# route -n
Kernel IP routing table

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 br0
172.17.0.0      0.0.0.0         255.255.0.0     U     0      0        0 docker0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br0
192.168.122.0   0.0.0.0         255.255.255.0   U     0      0        0 virbr0

-SSD

Share this post


Link to post
Posted (edited)

There is a syntax error in the gateway declaration in the network.cfg file.

GATEWAY[0]="192.168.1.1#213"

The "#213" part must be removed. This is automatically done when upgrading via the GUI (legacy removal).

Did you do a manual upgrade?

 

Edited by bonienl

Share this post


Link to post
5 hours ago, bonienl said:

This is automatically done when upgrading via the GUI

Does 6.4.1 support GUI upgrade to 6.7.x?

Share this post


Link to post
4 hours ago, jonathanm said:

Does 6.4.1 support GUI upgrade to 6.7.x?

AFAIK, it should

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this