Jump to content
Bogardo

Solved: Corrupted USB

11 posts in this topic Last Reply

Recommended Posts

Posted (edited)

Yesterday I rebooted my unRAID server but it wouldn't boot up again.

I connected a monitor and keyboard and noticed the following error during boot:

PXE-E53: No boot filename received

I checked the boot devices in the BIOS and couldn't find my USB device.

To verify if the USB drive worked at all, I pulled the drive from the server and connected it to my computer and I was able to read (most of?) the files on it. I immediately copied the contents of the USB drive to my computer but got read errors on a (large-ish) file in the `/previous/` directory (can't remember the name of the file at the moment).

I've read some posts about similar issues and understood that I could use a new USB drive and copy the contents of the old drive to the new one.
Before copying the files over I used the USB creator tool from unRAID to format the drive (and load a version of unRAID on it). After that I copied all files I recovered from the old USB drive to the new one I tried booting from that drive.

 

I was able to boot the the unRAID OS but noticed the server name was still the default 'tower' and after logging in I could not find any of my shares.
Did I do something wrong with the creation of the new USB drive? Did I miss any configuration files?
What are my options here? I've got a lot of data on the 4 disks and have a lot of docker containers running which I would hate to reinstall/configure.

 

Edit:

I'm running unRAID 6.6.6 currently

Edited by Bogardo
Problem has been solved

Share this post


Link to post

Attach a copy of your Diagnostics file to your next post.     Tools   >>>   Diagnostics

 

Get a screen shot/capture of the Main tab showing the disk assignments (including the cache drive(s)).  

Share this post


Link to post

You either missed or they were corrupted all the files in /config.

 

How many parity drives did you have?

Share this post


Link to post

@Squid I have 1 parity drive. I do have files in my /config folder and most files seem to be ok. I'm not sure which config files are crucial for booting my unraid system.

Share this post


Link to post

Look in the config folder/directory of the backup that you made.  There is where all of your configuration files are basically saved.  The files that should be there are listed here:

 

     https://wiki.unraid.net/Files_on_v6_boot_drive

 

Let's know which files are missing (or empty).   Don't fear, your data should be perfectly safe and it is fairly straightforward even if the old configuration files are toast.  Did you have a cache drive/array?  

Share this post


Link to post
Posted (edited)

@Frank1940 
 

I'm missing:

- /extra (optional)

- /packages (optional)

- /config/smart-all.cfg

- /config/secrets

 

All other files seem to be ok.

The only things I'm worried about are the bzroot and bzimage files in de /previous/ directory because these gave errors during the copy process.

 

I've manually checked most of the files to see if I was able to read them and I haven't noticed any issues with any of the files.

 

There is 1 cache drive in the array.

 

From: /config/DISK_ASSIGNMENTS.txt

Disk Assignments
Disk: parity  Device: WDC_WD40EFRX-68N32N0_WD-WCC7K3FSH59A  Status: DISK_OK
Disk: disk1  Device: WDC_WD40EFRX-68N32N0_WD-WCC7K3UR1EL1  Status: DISK_OK
Disk: disk2  Device: WDC_WD20EARS-00MVWB0_WD-WCAZA6738343  Status: DISK_OK
Disk: disk3  Device: WDC_WD20EARS-00MVWB0_WD-WCAZA5728174  Status: DISK_OK
Disk: parity2  Device:   Status: DISK_NP_DSBL
Disk: cache  Device: Samsung_SSD_840_PRO_Series_S12PNEAD130049R  Status: DISK_OK
Disk: cache2  Device:   Status: DISK_NP
Disk: flash  Device: Ultra_Fit  Status: DISK_OK

 

Edited by Bogardo

Share this post


Link to post
Posted (edited)

Don't worry about those missing files/directories.  Make a flash drive with a totally new install on it.  Then copy the contents of your old configuration folder into the config folder of that new install.  ---> EDIT:   Force overwrite pf existing files as required  <--  Now boot with that flash drive.  You will probably be up and running with all of your old settings. 

Edited by Frank1940

Share this post


Link to post

You can use any recent version that you want to.  The configuration files are the same for all of them.  (Basically, you can change from one version to another version by just replacing all of the bz* files in the old version with the ones from the new version.)  

Share this post


Link to post

Thanks @Frank1940 your suggestion got me up and running again. I did have to purchase a new USB drive because the old one was dead.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.