Jump to content

NIC Stubbing Problem

3 posts in this topic Last Reply

Recommended Posts

I am running unraid 6.8.3 on an asus b85m-e. I am trying to stub an extra NIC so that I can run Pfsense. I have followed spaceinvaders videos, read multiple different posts on forums and I cannot get the NIC to show up in my VM (other pci devices).

I got my device id from tools->system Devices (I did notice there are no IOMMU groups in my list like the video) not sure if this is the reason. Board not support this?

Next I selected my flash drive and added the (append vfio-pci.ids=10ec:8169 initrd=/bzroot), rebooted, the network card still shows up in my network list and I cannot add to VM.

I have tried everything I can think of. Am I doing something wrong? Does my board not support this? I noticed the video is a couple years old, is it done differently in 6.8.3? Any help would be greatly appreciated.




Share this post

Link to post

It appears to be a problem with my Motherboard. Guessing not compatible? I swapped out an older board with a gen1 i7 and I am able to stub NIC's using

pci-stub.ids=****. I searched through bios and i'm just not finding anything I would have incorrect. Guess I am going to have to go shopping for a new board,cpu.

Share this post

Link to post
22 hours ago, xxnumbxx said:

I did notice there are no IOMMU groups in my list like the video

That is definitely a problem. You need to Google ways to enable IOMMU. It might be something in the BIOS that you enable, or it might be adding "iommu=pt" to the append line, or you might need to enable "unsafe interrupts" (enable Help on Settings -> VM Manager). Or perhaps your hardware doesn't support it.


Then, see the release notes for Unraid 7 that explain a different way of "hiding" devices from Unraid so they are available for passthru:


Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.