captaincu

Members
  • Posts

    9
  • Joined

Everything posted by captaincu

  1. SOLUTION AT THE END OF MY POST I did my own little testing and it seems like only the last line in mover_ignore.txt gets evaluated. This is for directories at least in my use case. Not sure what happens if you sprinkle files into mover_ignore.txt. My test setup: test_folder/ ├── test/ │ ├── test.txt ├── test2/ │ ├── test2.txt ├── test3/ │ ├── test3.txt Test command find "/mnt/downloads/Media/Downloads/test_folder" -depth -type f | grep -vFf '/mnt/user/appdata/mover_ignore.txt' Single top level directory in mover_ignore.txt mover_ignore.txt /mnt/downloads/Media/Downloads/test_folder/ No files found as expected Multiple directories in mover_ignore.txt When mover_ignore.txt has multiple directories including parent directory test_folder/ and test3/ is on the last line /mnt/downloads/Media/Downloads/test_folder/ /mnt/downloads/Media/Downloads/test_folder/test/ /mnt/downloads/Media/Downloads/test_folder/test2/ /mnt/downloads/Media/Downloads/test_folder/test3/ Files found in output /mnt/downloads/Media/Downloads/test_folder/test/test.txt /mnt/downloads/Media/Downloads/test_folder/test2/test2.txt EDIT: Figured it out using this page. Having my mover_ignore.txt save with CRLF broke the patterns for preceding lines so only my last pattern in the file would work. Solution was to save the file with LF as the end of line sequence.
  2. I attempted the above but I can't seem to get the skip file list to skip files inside a directory. Maybe it's not looking recursively at sub-directories? Any suggestions? Log snippet Dec 16 13:10:57 Tower root: mvlogger: Adding Skip File List Dec 16 13:10:57 Tower root: mvlogger: Skip File List Path: /mnt/user/appdata/mover_ignore.txt Dec 16 13:10:57 Tower root: mvlogger: Skipfiletypes string: find "/mnt/downloads/Media" -depth -mtime +0 | grep -vFf '/mnt/user/appdata/mover_ignore.txt' Dec 16 13:10:57 Tower root: mvlogger: find "/mnt/downloads/Media" -depth -type f -mtime +0 | grep -vFf '/mnt/user/appdata/mover_ignore.txt' | grep -v -e '!qB' -e '.!qB' | du -shc --files0-from - | tail -n1 Dec 16 13:10:57 Tower root: mvlogger: Running in Test Mode: find "/mnt/downloads/Media" -depth -mtime +0 | grep -vFf '/mnt/user/appdata/mover_ignore.txt' | grep -v -e '!qB' -e '.!qB' Dec 16 13:10:57 Tower root: /mnt/downloads/Media/Downloads/sonarr/[SubsPlease] One Piece - 1003 (1080p) [8637D29D]/[SubsPlease] One Piece - 1003 (1080p) [8637D29D].mkv Dec 16 13:10:57 Tower root: /mnt/downloads/Media/Downloads/sonarr/[SubsPlease] One Piece - 1003 (1080p) [8637D29D] mover_ignore.txt attempt /mnt/downloads/Media/Downloads/ /mnt/downloads/Media/Downloads/*
  3. For any future users troubleshooting "Swap file in use: X", you may need to update the Swap file location to exclude the trailing slash. Ex: Swap file location: /mnt/cache/swap/ Should instead be -> Swap file location: /mnt/cache/swap
  4. It seems to be working properly on my initial move. Will report back if there's anything funky I notice. Thanks for working on that!
  5. I updated to version 2021.11.07 and unfortunately I'm still having trouble moving files greater than 24 hours old. Setting "Move files that are greater than this many days old" to 1 results in the following command being run. find "/mnt/downloads/Media" -depth -type f -mtime +1 -print0 | du -shc --files0-from - | tail -n1 I believe it should be using the following option. -mtime +0
  6. I did my own digging and found that the -mtime +1 command returns files modified >= 2 days ago. Thus, to get files >= 1 day old, -mtime +0 should be used. Source Currently, the mover test logs indicates that -mtime isn't used at all when "Move files that are greater than this many days old" is set to 0. This results in everything being moved. The next increment of 1 runs -mtime +1, which selects files modified >= 2 days ago. I think this setting should be modified such that setting it to 0 omits -mtime and setting it to 1 starts at -mtime +0. The next integers should increase -mtime by 1.
  7. I've noticed that setting mover tuning to move based on age at greater than 1 days old only moves once the file hits 48 hours from MTIME. That makes sense to me, but going with this logic I'd expect setting it to 0 days would move files only when they hit the 24 hour mark using MTIME. Unfortunately, in practice it moves all files even if it's less than 24 hours. Is there a way for me to move files that have been on the cache for at least 24 hours? Move files off cache based on age? Yes Move files that are greater than this many days old: 0
  8. I'm having a similar experience. Additional arguments other than powerlimit seem to make no difference on hashrate for me. Given enough power, I'm getting 30 MH/s on my Vega 56 no matter what I set the cclock and mclock to.