Jump to content

johnodon

Community Developer
  • Content Count

    1878
  • Joined

  • Last visited

Everything posted by johnodon

  1. @ich777 Just checking in to see if there has been any progress with BF2 and/or BF2SF. Thanks, John
  2. One other point regarding BF2 and BF2SF...they can use the same appdata folder since they use the same source files and the BF2SF settings and maps are stored in their own folder separate from BF2.
  3. UPDATE: Apparently BF2142 requires a hacked profile to get around the initial login screen (if you don't already have an EA Games account). The other option would be to use something like Gameranger (which I have no interest in). FYI... As discussed over PM, Battlefield 2 Special Forces uses the same source files as BF2. You just launch using 'start.sh +modPath mods/xpack'. Battlefield 1942 and Battlefield 2142 server source files are also freely available. John
  4. Thanks. I'll PM you with what I have done so far. The real trick (whihc I probably would have never figured out) is to use 'expect' and 'spawn' to run the shell script as it asks to accept the EULA for both BF2 and PunkBuster. Both BF2 server source files and BF2HUB installer are direct links (2nd is not required unless you want to host a ranked or unranked server on BF2HUB). BF2CC would be nice also (for admin) but requires mono and modmanger installed (both direct DLs also) and I just haven't messed with it yet. John
  5. Is Battlefield 2 an option? The source files for a dedicated linux server are readily availble (I am running a server in a Docker container right now) but I wasn't sure of the legality. The place where I downloaded the source from has these disclaimers: If this all looks good, I can certainly help with getting this stood up but I wold love @ich777 to officially own it. John
  6. Request for Unreal Tournament 2004. I see a few dockerized versions on docker hub and github so I imagine it is quite doable. John
  7. Thx insane. I'll add those to the autoexec.cfg on the boys. machines. BTW, I sent you a PM (hope you don't mind...didn't want to make this thread longer than needed). I only got rcbot2 to play nicely on tf2 just the once although the bots didn't move. Ever since, it generates a segfault when I try to join my local server. Disabling rcbot2 and I am able to join without issue. John
  8. First off...thank you for these awesome game servers. I have my 8 and 9 year old boys playing HL2DM and TF2. The interaction is hilarious. As described earlier in this post, I also added RCBOT2 to both games and have it running as expected. The issue is that the console is now spammed with messages like these: weapon_357[257]: Playing sequence 3 but there's only 2 in total? weapon_357[257]: Playing sequence 3 but there's only 2 in total? weapon_357[257]: Playing sequence 3 but there's only 2 in total? weapon_357[257]: Playing sequence 3 but there's only 2 in total? weapon_357[257]: Playing sequence 3 but there's only 2 in total? More info here: https://steamcommunity.com/sharedfiles/filedetails/?id=157466467 So, I added the lines below to my server.cfg file but it does not seem to have any effect. If I type the commands in a console, they work. con_filter_enable 1 con_filter_text_out "Playing sequence" Any ideas? TIA. John
  9. I think I confirmed that the same is true for 17.10.1. Testing now.
  10. I'm having much better luck on 18.04. However, in order for the splash screen to work, I have to append the GRUB_CMDLINE_LINUX line. Appending the GRUB_CMDLINE_LINUX_DEFAULT has no impact (at least not for me). If this works satisfactorily, I run through my entire Retropie setup process on 18.04. John
  11. Calling all Linux geeks...I know there are lots here. I am on the very last step of turning an x86 system into a Retropie appliance. It is essentially Ubuntu Server 17.10.1 x64 with Openbox as the window manager and Retropie installed (yes...you can run the Retropie setup script on Ubuntu). I borrowed a lot of work that was already done but then wanted to hide all of the background (gnome terminal window, mouse pointer, etc.). Normally coming in and out of a game you would see the mouse pointer and a the gray gnome terminal window with a light blue title bar. Here is the *almost* finished product if anyone is interested (I will write-up a full how-to): Where I am stuck is hiding the usual Ubuntu boot dialog. I really want to use a fancier splash screen using Plymouth, but, I can't get even get the standard splash screens to work. I was hoping it would be as easy as turning it back on in the grub config (shown below) and updating grub... GRUB_DEFAULT=0 #GRUB_HIDDEN_TIMEOUT=0 GRUB_HIDDEN_TIMEOUT_QUIET=true GRUB_TIMEOUT=2 GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian` GRUB_CMDLINE_LINUX_DEFAULT="splash" GRUB_CMDLINE_LINUX="" but it hangs at the following: And then eventually this... I have tried on a VM in unRAID and two different physical hardware. I even tried Ubuntu Server 16.04.4 with the same result. Can anyone help?!?!?!
  12. I'll second the Supermicros.
  13. These just started popping up in my syslog the other day. Anyone else? Version 1.8.1.4139
  14. Answered my own question (I hope). This is what I am using and seems to setting perms consistent with newperms. If anyone sees issue, please let me know.
  15. What are the proper values to assign for file, folder, user and group that aligns with what the 'New Permissions' script does in unRAID? For chown, do you use 99/100 or nobody:users? What values for chmod?
  16. Wait...maybe I misunderstood... Are you saying to use PIAs DNS servers as the default and only servers in pfsense? Or, assign PIA's DNS servers as part of a static mapping for individual IPs? If the latter...no worky. The container still shows only 127.0.0.1 for the DNS and a leak is present when I nslookup.
  17. My understanding is that the local host will override it but I have not tried. I guess it is worth a shot.
  18. I know that this is completely taboo, but would the same hold true if there was a single mount point at a higher point... i.e. /mnt/user/?
  19. Just a theoretical question... If I create a container that contains both Radarr and NZBget, will processed files be moved to the final location rather than copied/deleted? I want to say yes since both apps are technically running on the same 'machine'. Thoughts? John
  20. UPDATE: While this seems to work from a DNS leak perspective, it is also having a negative impact on speeds (namely NNTP). I am seeing speeds being throttled at around 1.3MB/s even though I have my pipe fully open (100Mbit). From what I read online, one of the factors that could impact NNTP speeds is name resolution failure. If I set DNS entries to my VPN providers servers via Extra Parameters, speed is throttled. If I remove those entries I get full speed. In both instances the traffic is tunneling though the OVPN client on my pfsense box via an alias and firewall rules. Back to that drawing board.
  21. I closed the unRAID webui on my desktop (192.168.1.35) and the messages stopped. I am currently on my laptop.
  22. My syslog is being flooded with these all of a sudden. I have removed the preclear plugin and rebooted and there are still being logged. Aug 3 07:31:55 UNRAID dnsmasq[8274]: read /etc/hosts - 2 addresses Aug 3 07:31:55 UNRAID dnsmasq[8274]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 addresses Aug 3 07:31:55 UNRAID dnsmasq-dhcp[8274]: read /var/lib/libvirt/dnsmasq/default.hostsfile Aug 3 07:31:55 UNRAID kernel: virbr0: port 1(virbr0-nic) entered disabled state Aug 3 07:32:00 UNRAID nginx: 2017/08/03 07:32:00 [error] 4084#4084: *6 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 192.168.1.35, server: , request: "POST /plugins/preclear.disk/Preclear.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "unraid", referrer: "http://unraid/Dashboard" Aug 3 07:32:04 UNRAID nginx: 2017/08/03 07:32:04 [error] 4084#4084: *6 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 192.168.1.35, server: , request: "POST /plugins/preclear.disk/Preclear.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "unraid", referrer: "http://unraid/Dashboard" Aug 3 07:32:05 UNRAID nginx: 2017/08/03 07:32:05 [error] 4084#4084: *6 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 192.168.1.35, server: , request: "POST /plugins/preclear.disk/Preclear.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "unraid", referrer: "http://unraid/Dashboard" Aug 3 07:32:10 UNRAID nginx: 2017/08/03 07:32:10 [error] 4084#4084: *6 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 192.168.1.35, server: , request: "POST /plugins/preclear.disk/Preclear.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm.sock:", host: "unraid", referrer: "http://unraid/Dashboard" Aug 3 07:32:14 UNRAID nginx: 2017/08/03 07:32:14 [error] 4084#4084: *6 FastCGI sent in stderr: "Primary script unknown" while reading response header from upstream, client: 192.168.1.35, server: , request: "POST /plugins/preclear.disk/Preclear.php
  23. OK...so while using the --dns=xx.xx.xx.xx Extra Parameter does not modify the resolv.conf within the container, it does appear that the container is using the entries. I am using this method to test for DNS leaks: https://www.privateinternetaccess.com/forum/discussion/23924/easy-quick-dns-and-ipv6-leak-testing-via-command-prompt-line-method-no-browser-or-website-needed If I do not set DNS entries in the Extra Parameters, my public IP is exposed when I perform an nslookup as described above. (I replaced my public IP with xx.xx.xx.xx) root@fff1d16a37d1:/$ nslookup whoami.fluffcomputing.com nslookup: can't resolve '(null)': Name does not resolve Name: whoami.fluffcomputing.com Address 1: xx.xx.xx.xx xx-xx-xx-xx.rest.of.fqdn If I include my VPN's DNS entries in Extra Parameters, my VPN IP is returned (replaced with yy.yy.yy.yy): root@154df63b5b93:/$ nslookup whoami.fluffcomputing.com nslookup: can't resolve '(null)': Name does not resolve Name: whoami.fluffcomputing.com Address 1: yy.yy.yy.yy ip-yy-yy-yy-yy.rest.of.fqdn
  24. I'm still trying to work through this and please excuse my ignorance as I am learning as I go. I also did not want to hijack another thread. @bonienl since you seem to be dialed into this stuff. I want my SAB and Deluge containers to be tunneled through my VPN provider using firewall rules/aliases in pfsense. Right now I use the Pipework container to handle the static IP assignment and use the Extra Parameters fields in the container to assign static DNS entries (--dns=xx.xx.xx.xx). I am trying to move away from this and and retire my Pipework container. I have edited my Deluge container as shown below: However, the DNS entries are not sticking... root@UNRAID:~# docker exec -ti Deluge /bin/bash root@663c25303022:/$ cat /etc/resolv.conf nameserver 127.0.0.11 options ndots:0 As a reference, this is what I see in the resolv.conf for my SAB container which is still using the Pipework container. root@UNRAID:~# docker exec -ti SABnzbd /bin/bash root@e8fe4bb265ba:/# cat /etc/resolv.conf nameserver 209.222.18.218 nameserver 209.222.18.222 Do I need to create a new custom network instead of using br0? Also, the piece the I don't know how to configure (and honestly don't even know if it will help) is the --dns-opt= parameter. I haven't had much luck finding good documentation on what exactly the options are. Other than the DNS snafu, the good news is that I am able to reach the Deluge webui. The bad news is that Sonarr is not able to reach the Deluge container using the same IP/Port. TIA for any help! John