maciekish

Members
  • Content Count

    41
  • Joined

  • Last visited

Everything posted by maciekish

  1. I can confirm the new setting to allow custom networks to communicate with host fixes the issue.
  2. Thank you. Can we please go back on topic now?
  3. Dear devs, thanks for adding a nice new login page. Also dear devs, thanks for breaking my certificate authentication with my reverse proxy. Can you please make basic auth an option in the settings?
  4. So anything writing in a docker or VM could show up as shfs activity? Pardon me but i have no idea what shfs is. Any way to tell more precisely what is happening other than iotop?
  5. Can anyone figure out what is going on here please? Mover is not running (anyway it should read not write if anything). Mechanical disks are completely idle, both SSDs in cache have writes of 300Mb/s.
  6. For future reference the issue is due to "buffering" in gzip in Caddy. Workaround: gzip { not /plugins }
  7. Interesting, i thought you would have to reenter all shared folders, ip adresses and so on. Either way, moving back the original file with COW disabled won't hurt will it?
  8. Won’t recreating the image remove all dockers and force you to redownload the images and reconfigure them? Sure appdata wont be lost but if you have 20+ dockers this takes a lot longer than just copying the file twice? Also my method doesn't introduce any issues does it?
  9. It is - in fact checking for the C or NOCOW flag. The problem is that you can't set the NOCOW flag for a file larger than 0 bytes. That is - already containing data. You can only set it for newly created 0 byte files which have not yet been written to. There is a workaround though: 1) Move your docker.img to a safe location on a different device. 2) Make sure the "live" image /mnt/cache/system/docker/docker.img is removed and that you only have an empty docker folder. 2) chattr +C /mnt/cache/system/docker (Yes, the folder, not the file). By setting the C or NOCOW flag on
  10. As a matter of fact, i never got the answer "no". And even if you would said no, you cannot answer for everybody. Maybe someone else would be able to help. You made your suggestion and i wasn't interested. Why continue forcing it on me?
  11. I respectfully disagree. It is a arguably easier to set up a password-only PPTP VPN than a reverse proxy as this is built-into for example Windows-Server and provides a point-and-click UI to do it. Incorrectly configured VPN and reverse proxy will both be equally insecure. Correctly configured VPN and reverse proxy will both be equally secure. I was asking if anyone knows why a small part of the web ui doesn't work and instead i'm being lectured on security... Gee, thanks.
  12. I don't understand this witch hunt on reverse proxies. They can be made to require client certificates as well just like a VPN has a private key or a certificate, encrypt their traffic like a VPN and don't pass anything through to unRAID until authentication has been satisified. And im not the only one to want this
  13. Admin, please delete/lock this thread. This conversation is absolutely useless.
  14. What is with the attitude on this forum? I asked a simple question which could even be a well known issue. I don't mind suggestions. I politely refused because it is not suitable for me, yet it was forced upon me in the next post, that is my problem with all this.
  15. I didnt ask what the most secure solution is. Please leave the security to me. I want to know why it doesnt work over a reverse proxy and how to fix it.
  16. You are not helping. I have reported these posts.
  17. The webGUI isnt exposed until you login. Anyone can attempt to login to your VPN as well.
  18. I disagree. The most secure solution is to disable the webGUI. Can we focus on solving the issue instead of discussing this please?
  19. Sorry but that doesn't really fix the problem. A VPN is not practical in my situation.
  20. Hi, i am acessing the web ui via Caddy reverse proxy. It is transparent and passing websockets as well. When i update a docker or run a script from User Scripts and the white popover window supposed to minitor the status appears, it is empty but updates once the task finishes. If i access the server without the proxy it works and refreshes as docker images download. Edit: I am using the azure theme if that makes any difference. What can i do to fix this?
  21. Hi, I disabled all VMs and Dockers and the system has been up for 5 days. I have run memtest and prime95 for 29 hours without issues. I am currently reenabling a docker or vm every 48 hours to until it crashes. If it doesnt help i will connect a monitor and keyboard but it is very difficult so i am leaving it for later.
  22. The server hung again today. Can someone please advise? I am completely out of ideas. HANG tracer-diagnostics-20180724-0733.zip
  23. The box keeps hanging at random every 24-48 hours. Yesterday it hung and i walked over with a keyboard and monitor. Monitor didnt come on, but i could switch Num Lock on and off, and if i switched tty with ctrl+alt+f1 and f2 the Num Lock switched on and off (one tty had on and the other off?). Logging in and rebooting blindly didnt work. Had to hard-reset. Today it hung again as i started a Plex sync. I have removed all USB devices (UPS and FR24 receiver) and disabled the two Ubuntu VMs now. Logs attached. I ran memtest86 for an hour a couple days ago, no er
  24. Hi how do i disable the continuous flash logging of syslog and diagnostics? I enabled it a couple days ago and cant find how to disable it any more.