CoZ

Members
  • Posts

    159
  • Joined

  • Last visited

Everything posted by CoZ

  1. Fixed! No more "bootloop" and I was able to join on my own LAN. Whatever you did - thanks.
  2. Hey @ich777, you just pushed an update out to the Valheim docker. I applied the update and was unable to connect. Checking the logs, it seems to be stuck in some sort of "boot loop". EDIT: Seems to be everyone's server having issues. No servers are coming up in the server browser at all, much less mine.
  3. So strange things are happening now; the Docker is now encoding files that it has previously encoded. I have two TV shows in the watch folder and even though they have already been encoded, the app is encoding them again to HEVC. This is quite puzzling. Ok, I am an idiot. I had both plugins installed and running: Video Encoder H264 - h264_nvenc (NVIDIA GPU) Video Encoder H265/HEVC - hevc_nvenc (NVIDIA GPU) This is not the containers fault but, my own. Initially upon configuring everything I was in such a rush to get it back up and running I wasn't paying attention and just installed everything with NVIDIA GPU in it. So it seems as though I put the container into a vicious cycle, converting the same files to x264 and then x265. This would also explain why my RAM filled to capacity yesterday and my Dual Xeons spiked to 100% on all cores. I am leaving this post up for posterity in case anyone else has this issue. Check the plugins! lol
  4. Everything is a Plugin now. You're like Oprah now; "You get a plugin — you get a plugin — you get a plugin!" I am actually liking it the more I mess with it. At first, I thought "why have all the functionality taken out by default" but now I realize why you've gone that route; much easier to customize, much easier to nail down errors. Great Job on this Sir. I thought this container was a must-have installation for any Unraid build but now, this certifies it!
  5. That's the first place I went too (well after installing all the HEVC plugins) and it's just blank. I'll re-watch the video to see what I missed. I skimmed through it to get the container up and running again and that was priority 1.
  6. So THIS is why none of my files were being automatically compressed — there was a major update and everything has to be reconfigured. LoL! This shows you how bulletproof this docker was. I set it up once and never again had to look at it. Thanks for the video @Josh.5 - that helped. It did however take a few start / stop / restart of my docker container before it actually started to do anything. Not sure why that happened? Strangely that old container seemed to have skipped some files(?) because now I've got an entire season of a watched series undergoing a conversion. Perhaps now there is subtitle support as before there was not? EDIT: Just noticed that it no longer reports how much the file was "shrunk" like it did previously. Has that moved somewhere else?
  7. Started tinkering with this. I'm familiar with Nginx Proxy Manager and have a purchased domain. However, no matter what I do it will fail to connect via the FireFox Plugin. Any ideas? EDIT: I think I got it working. Apparently the "v2" after your domain name is VERY important.
  8. I know you're busy answering all sorts of questions and I've honestly stared at this for a good 10 minutes and still just dont' get it. I was going to backup my 'worlds' since my original friends have lost interest in the game and start fresh and then restore the world at a later point once more content drops. Then I thought why do that when I can just create another world/container so decided to come here and check before I tried to do something stupid. Someone already asked the question how to run two instances of a dedicated Valheim server and you referenced this post. I'm looking at your graphic which probably an idiot would understand but I guess I'm lower than idiot status because I don't understand what I'm supposed to do here to create a "new world" or "new server"...... Help? (and sorry for not understanding this)
  9. Ok, thanks for trying to help. I can't even find the certs to copy over to DS anywhere from the NGINX proxy/appdata - oh well. Every Google search for NGINX + OnlyOffice + Docker + DocumentServer doesn't really return much so this was the last hope.. LoL
  10. You just confused me. So you're saying I should be using THAT SSL cert for both the office.mydomain and the documentserver.mydomain or the other SSL cert for both office.mydomain & documentserver.mydomain? I'll uncheck the HSTS EDIT: Still the same error: Error when trying to connect (cURL error 60: SSL: no alternative certificate subject name matches target host name 'documentserver.MYDOMAIN.com' (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://documentserver.MYDOMAIN.com/healthcheck) Using the SSL for the Nextcloud reverse proxy Using the SSL for OnlyOffice proxy I get this error: Error when trying to connect (Error occurred in the document service: Error while downloading the document file to be converted.) (version 6.2.1.24) So not sure where to go from here... both result in completely different error messages.
  11. Found it! I thought it was "gone" since I removed it and placed the CERT from the Nextcloud SSL into the DocumentServer Proxy to try and fix this whole mess but it's still present on the system since I never deleted it, just selected the "office.mydomain.com" SSL # ------------------------------------------------------------ # documentserver.MYDOMAIN.com # ------------------------------------------------------------ server { set $forward_scheme http; set $server "192.168.1.102"; set $port 9090; listen 8080; listen [::]:8080; listen 4443 ssl http2; listen [::]:4443; server_name documentserver.MYDOMAIN.com; # Let's Encrypt SSL include conf.d/include/letsencrypt-acme-challenge.conf; include conf.d/include/ssl-ciphers.conf; ssl_certificate /etc/letsencrypt/live/npm-24/fullchain.pem; ssl_certificate_key /etc/letsencrypt/live/npm-24/privkey.pem; # Block Exploits include conf.d/include/block-exploits.conf; # HSTS (ngx_http_headers_module is required) (63072000 seconds = 2 years) add_header Strict-Transport-Security "max-age=63072000;includeSubDomains; preload" always; access_log /config/log/proxy_host-25.log proxy; location / { # Force SSL include conf.d/include/force-ssl.conf; # HSTS (ngx_http_headers_module is required) (63072000 seconds = 2 years) add_header Strict-Transport-Security "max-age=63072000;includeSubDomains; preload" always; proxy_set_header Upgrade $http_upgrade; proxy_set_header Connection $http_connection; proxy_http_version 1.1; # Proxy! include conf.d/include/proxy.conf; } # Custom include /data/nginx/custom/server_proxy[.]conf; }
  12. I see no way to edit the cert that NGINX assigns to the subdomain. You just add a new certificate for the subdomain you're trying to forward and it assigns the cert. There are no options or configurations for the cert. I can only renew now or delete the cert. The only option to do anything at all is under the proxy host: Nginx variables available to you are: $server # Host/IP $port # Port Number $forward_scheme # http or https I went into appdata/NginxProxyManager/letsencrypt/keys and that directory is blank. I then took a look into NginxProxyManager/nginx/proxy_host and found a bunch of randomly titled files in there finally found one that points to something: # ------------------------------------------------------------ # office.MYDOMAIN.com # ------------------------------------------------------------ server { set $forward_scheme https; set $server "192.168.1.102"; set $port 444; listen 8080; listen [::]:8080; listen 4443 ssl http2; listen [::]:4443; server_name office.MYDOMAIN.com; # Let's Encrypt SSL include conf.d/include/letsencrypt-acme-challenge.conf; include conf.d/include/ssl-ciphers.conf; ssl_certificate /etc/letsencrypt/live/npm-24/fullchain.pem; ssl_certificate_key /etc/letsencrypt/live/npm-24/privkey.pem; It continues on and I don't want to clutter up the thread any more by posting the whole thing if this isn't relevant.
  13. When I check the box that says Disable Certificate verification I get this message (When using the CERT from the nextcloud proxy): Error when trying to connect (Error occurred in the document service: Error while downloading the document file to be converted.) (version 6.2.1.24)
  14. I just tried to assign the same CERT that nextcloud uses to the document server and now I've gotten a new error message: Error when trying to connect (cURL error 60: SSL: no alternative certificate subject name matches target host name 'documentserver.MYDOMAIN.com' (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://documentserver.MYDOMAIN.com/healthcheck) so I don't think that's going to work that way either.
  15. Not that I'm aware of having a server block for onlyoffice. I've no idea how to copy certificates or, if it's even possible since they are both using different SSL certs that were assigned to them by NGINX. Unless maybe I can try to assign the office.mydomain.com certificate to the documentserver.mydomain.com I've got even more issues now with Nextcloud, I've grenaded and wiped my install so many times, I'm running out of 'fake admin/user names' to try. I've wiped the appdata/nextcloud folder from the SSD and I've cleared out my mnt/nextcloud folder share but for some insane strange reason, the docker still remembers all the user names I've entered previously which makes NO sense at all since the appdata folder is deleted along with the template and all the data. I'm about to throw a grenade right into my Unraid tower itself at this point. I've been messing with this for 3 days now and it gets worse and worse the more I try to fix it. LOL
  16. @Siwat2545 ok sorry for the delay, tried as fast as I could. This screenshot shows the Nextcloud NPM reverse proxy settings. This screenshot shows your DocumentServer reverse proxy settings. I'm able to connect to https://documentserver.mydomain.com without any issue, I get the ONLYOFFICE Docs™ Community Edition – Welcome! without issue - either connecting to it internally from my local IP or externally from documentserver.mydomain.com I'm also able to connect to my Nextcloud install either through office.mydomain.com or, internally using my IP So this has me thinking that my reverse proxy set up is working properly for both. Just always get the Bad Healthcheck error message when attempting to get the two to talk to each other. I've checked and unchecked every option under the NextCloud OnlyOffice connector settings app but still no good.
  17. Give me a few. I'm going to screenshot the heck out of them all so you can "see"
  18. I'm not entirely sure what you're asking but I will do my best to try and answer it. Externally if I use my domain, it's an https://office.mydomain*com and it connects to Nextcloud. As far as the certs, there isn't a need to do that using NPM (as far as I know, that is, because I haven't had to copy any certs from anywhere into anything else). The certs are installed "in" the docker container for NPM. Might be the same for SWAG as well since NPM changed from NPM to SWAG (but I haven't made the move over to it as of yet).
  19. I have the same exact issue and the same exact problem using NPM. I'm able to connect to documentserver.mydomain.com withouth issue and I can see the 'Congratulations' webpage from OnlyOffice. So I'm 99.9% sure my Reverse proxy is working correctly or else I wouldn't even be able to reach that webpage. As soon as I put the address into the OnlyOffice settings page from within NextCloud I also get the "Bad Healthcheck" error. I've nuked, removed, destroyed, exploded both Docker containers over and over a few hundred times now (saw a few posts mentioning that it just started working when they did a fresh install of one or the other) but still, every time "Bad Healthcheck". I've tried to set it up from my local 192.XX..XX.XX and also connecting to it from my Domain still always the same error message "Bad Healthcheck". I've gone to the /r/UnRaid reddit thread asking for help there but no one seems to know. Figured I'd check on here but it doesn't bode well if you asked for help last month and still haven't received a reply / solution.
  20. I was going to attempt to do that myself. Instead of having to type in the IP address, just type in the Domain I purchased for my unraid server. Decided against that since I am not too familiar on how setting that all up would work and didn't want to break the server trying to get it. Should have done that from the start but now everyone is used to typing in my WAN IP address at this point.
  21. Yup. That's for running OnlyOffice in a separate docker container and pointing it back to NextCloud - which kind of defeats the purpose of having NextCloud built in with Only Office.
  22. Kind of an "off topic" question since it's not really UnRaid specific. Concerning the Valheim docker, is there some sort of Windows Program or something that can hook into the server to manage it? I know you can do admin commands from in game but is there some sort of 3rd party server admin control panel type of thing out there?
  23. Thanks for the update to the Container. Not sure what you've changed but appreciate that you are plugging away at it.
  24. Ok so the instructions would look like: Pull the new updated container down from the App Store Follow the previous post for manually adding that key to enable/disable the auto-update-check-feature Hit apply on the container ?