ph0b0s101

Members
  • Posts

    39
  • Joined

  • Last visited

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

ph0b0s101's Achievements

Newbie

Newbie (1/14)

3

Reputation

  1. Missed to thank you for information how I can build a switch by myself. Work like a charm. Did managed to build a template switch which start the server via WOL and bring them to Standby with your MQTT implementation. Great.
  2. Whatever you fixed, this was the problem Now it works and i got the message in the log aswell. > unraidapi@0.5.0 start > cross-env NUXT_HOST=0.0.0.0 NODE_ENV=production node server/index.js WARN mode option is deprecated. You can safely remove it from nuxt.config Connected to mqtt broker READY Server listening on http://0.0.0.0:80 Received MQTT Topic: homeassistant/sger-unraid01/binhex-lidarr/dockerState and Message: started assigning ID: MQTT-R-kkx4s6l1 MQTT-R-kkx4s6l1 succeeded Received MQTT Topic: homeassistant/sger-unraid01/sleep and Message: assigning ID: MQTT-R-kkx4swtl Received MQTT Topic: homeassistant/sger-unraid01/sleep and Message: assigning ID: MQTT-R-kkx4swtl MQTT-R-kkx4swtl succeeded So what is your plan for the final inplementation. So there will be also a switch or trigger of any kind, which I can use on the HA Dashboard, like reboot, restart, and so on or should I build an automation and call the mqtt service with the topic? I have to really thank you for your efford to implement this. Great 😄
  3. Hm it still seems that no command will reach the unraid server.
  4. Thank you for your reply, i assume, there must be any error on my site firing the mqtt command. Because there is nothing in the logs after i have issued the command. But when I trigger one of the docker switches it will work perfectly fine: > unraidapi@0.5.0 start > cross-env NUXT_HOST=0.0.0.0 NODE_ENV=production node server/index.js WARN mode option is deprecated. You can safely remove it from nuxt.config READY Server listening on http://0.0.0.0:80 Connected to mqtt broker Received MQTT Topic: homeassistant/sger-unraid01/binhex-lidarr/dockerState and Message: started assigning ID: MQTT-R-kkx2p44f MQTT-R-kkx2p44f succeeded Received MQTT Topic: homeassistant/sger-unraid01/binhex-lidarr/dockerState and Message: stopped assigning ID: MQTT-R-kkx2qvab Received MQTT Topic: homeassistant/sger-unraid01/binhex-lidarr/dockerState and Message: stopped assigning ID: MQTT-R-kkx2qvab MQTT-R-kkx2qvab succeeded So maybe I have to alter the command? On the mqtt manual from homeassistant there is mentioned that the payload is nessecary? https://www.home-assistant.io/docs/mqtt/service/ Sorry that I am not a big help so far 😞
  5. Hi @ElectricBrainUK, thank you for your update. I already installed the version from your beta repository. But I am not 100% sure how to use is with MQTT or the REST API. I tried it via developer tools in home assistant with the following code: but this command did not bring the server into standby mode. And for the REST API Call i did not know where I have to put the provided code example. Could you please provide some more in depth details? Sorry I am a total newbie in this subject. Reboot, Restart and so on has switches in home assistant:
  6. Sorry for my late response, i was really busy the last days. I have installed the s3 Sleep plugin, which handles the standby so far. When I manually bring the server in standby mode, I use the sleep button which is in the dashboard, after installation of the dynamics s3 sleep plugin. Sorry that I cannot provide any code 😞
  7. Thank you for your fast response. Yes I mean to bring the unraid host to sleep state, like the s3 plugin does.
  8. Hello ElectricBrainsUK, its me again and I am running your Unraid-API Docker directly in Unraid and it's working pretty good so far. I have only one open Request left do be 100% statisfied. So is it possible to get also an switch for sleep mode? You have already implemented an reboot and power_off, for me only sleep is left for maximum flexiblity. Maybe I can help to achive this?
  9. @ElectricBrainUK Thank you for giving a short feedback. So then I will wait for an update.
  10. Ok could establish an connection via the webui. But i will get still this error: ERROR ENOENT: no such file or directory, open 'config/mqttKeys' at Object.openSync (node:fs:490:3) at Proxy.readFileSync (node:fs:391:35) at default (api/getServers.js:27:36) at call (node_modules/connect/index.js:239:7) at next (node_modules/connect/index.js:183:5) at next (node_modules/connect/index.js:161:14) at next (node_modules/connect/index.js:161:14) at SendStream.error (node_modules/serve-static/index.js:121:7) at SendStream.emit (node:events:379:20) at SendStream.EventEmitter.emit (node:domain:470:12) ERROR ENOENT: no such file or directory, open 'config/mqttKeys' at Object.openSync (node:fs:490:3) at Proxy.readFileSync (node:fs:391:35) at default (api/getServers.js:27:36) at call (node_modules/connect/index.js:239:7) at next (node_modules/connect/index.js:183:5) at next (node_modules/connect/index.js:161:14) at next (node_modules/connect/index.js:161:14) at SendStream.error (node_modules/serve-static/index.js:121:7) at SendStream.emit (node:events:379:20) at SendStream.EventEmitter.emit (node:domain:470:12) Error: ENOENT: no such file or directory, open 'config/mqttKeys' at Object.openSync (node:fs:490:3) at Proxy.readFileSync (node:fs:391:35) at updateMQTT (/app/mqtt/index.js:268:30) at Timeout._onTimeout (/app/mqtt/index.js:300:5) at listOnTimeout (node:internal/timers:556:17) at processTimers (node:internal/timers:499:7) { errno: -2, syscall: 'open', code: 'ENOENT', path: 'config/mqttKeys' } The secure keys for mqtt may have not been generated, you need to make 1 authenticated request via the API first for this to work There is also no folder with mqttKeys in the config folder. Is this one of the mentioned bugs?
  11. Today I have installed the unraid-api as an Home Assistant Addon. I have configured the Addon as follows: MQTTBroker: <HA IP> MQTTPort: 1883 MQTTUser: mqtt MQTTPass: <password> MQTTBaseTopic: unraid MQTTSecure: false MQTTSelfSigned: false MQTTRefreshRate: 20 MQTTCacheTime: 60 KeyStorage: config After I start the Addon i get the following error and I have no idea how i can do the first api call manually to generate the keys. Error: ENOENT: no such file or directory, open 'config/mqttKeys' at Object.openSync (node:fs:495:3) at Proxy.readFileSync (node:fs:396:35) at updateMQTT (/app/mqtt/index.js:268:30) at Timeout._onTimeout (/app/mqtt/index.js:300:5) at listOnTimeout (node:internal/timers:556:17) at processTimers (node:internal/timers:499:7) { errno: -2, syscall: 'open', code: 'ENOENT', path: 'config/mqttKeys' } The secure keys for mqtt may have not been generated, you need to make 1 authenticated request via the API first for this to work Any hints or tipps?
  12. hm, das ist möglich, wobei ich ehrlich gesagt mega zufrieden bin im Vergleich zu vorher
  13. Audio konnte ich deaktivieren. Eine Option für CEC2019 konnte ich im BIOS nicht finden. Ich habe mal noch ein Voltcraft 3000 Messgerät rangehangen und habe als niedrigsten Wert 22W gesehen pendelt aber immer so um die 23W-24W im idle. Was meinst du denn, was ein guter Wert wäre, wenn du sagst das der Verbrauch viel zu hoch ist?
  14. Die 5W sind schon dabei gewesen, unter 25W komme ich aktuell nicht im idle mit allen platten im spindown. Die CEC Option suche ich gleich mal und schau ob es was bringt, ebenso mit dem Audio. Als Messgerät verwende ich eine Smarte Steckdose HS110.
  15. Genau die Platten sind im Spindown. Hatte auch vergessen zu erwähnen das ich 4x8GB RAM Module habe. Powertop habe ich nach deiner Anleitung durchgeführt was nochmal ca. 5 Watt weniger im idle gebracht hatte. Mit CEC2019 kann ich nichts anfangen, was meinst du damit? Ich habe gesamt 4 Lüfter (1x CPU, 2x 140mm Lüfter in der Front die jeweils durch die HDD Käfige blasen und 1x 140mm Lüfter um die Luft hinten aus dem Gehäuse raus zu blasen.