Jump to content

SMB security Settings "Private" Bug, stays at "No Access"


nxtiak

Recommended Posts

Using 5.0 Beta 3.

Everything was working fine with 5.0 Beta 2.

Updated to Beta 3, required readding/reconfiguring user accounts.

 

In Shares, when I click my share, then go to the SMB Security Settings, I have it Yes to Export and Security model as Private.

I click Apply, page refreshes and all my users are set to No Access.

I select the appropriate permissions for each user (read/write, read only, no access), I click on Apply, the page refreshes and everyone is back to No Access.

 

Weird thing is, It's odd combinations that will stick.

Users I have listed: root, istat, nxt (me), misc (a user i don't want access).

If i set root to rw, istat r, nxt rw, misc no, and click apply, it refreshes and istat is given read only and everyone no access, i can do other combinations and it has a mind of it's own after i click apply.

This is weird.

 

In the syslog, everytime I click apply this happens:

Feb  3 23:44:04 Server emhttp_event: svcs_restarted
Feb  3 23:44:56 Server emhttp: shcmd (180): rm /etc/samba/smb-shares.conf >/dev/null 2>&1
Feb  3 23:44:56 Server emhttp: Restart SMB...
Feb  3 23:44:56 Server emhttp: shcmd (181): killall -HUP smbd
Feb  3 23:44:56 Server emhttp: shcmd (182): /usr/local/sbin/emhttp_event svcs_restarted
Feb  3 23:44:56 Server emhttp_event: svcs_restarted

Link to comment

do you click on the correct apply? there are two apply buttons. one to set the export/security model and one to set the permissions.

if you click on the first apply button (just beneath the security select), the permissions will be reset to default.

to save the permissions, you have to click the apply button beneath your users.

 

i tried it and my permissions are saved.

Link to comment

Thank you. Until Beta 4 is released, I'll edit the share .cfg file, but what is the syntax for more than 1 user having write accesss:

shareSecurity="private"
shareReadList=""
shareWriteList="root, nxt"

 

I tried a comma to seperate the two usernames, that didn't work.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...