Jump to content

Nvidia mapping multiple BARs reported in LOG.

Recommended Posts

I believe the error messages are harmless in themselves, but will fill your log, which is bad. It's a BIOS problem. Normally, I'd say upgrade to the latest version available for your CPU, which would be version 3.50.


However, you're using BIOS 4.90 which is not recommended by ASRock for your 1700 processor. Did you buy the board with that version or upgrade it yourself? The best choice for Summit Ridge (Ryzen 1000-series) is 3.50. I don't know if downgrading is possible. If not, maybe version 5.00 is suitable, since ASRock doesn't specifically say it isn't, but equally likely, that's due to an oversight. Maybe ask ASRock for advice.


https://www.asrock.com/mb/AMD/B450m Pro4/#BIOS




I notice you have IOMMU disabled, so presumably you are not intending to pass it through to VMs - just using it for the server console and maybe for transcoding? Try turning on IOMMU and see if that changes things.


If your server locks up when idle, take a look at this tip:



The relevant BIOS setting is the one about "Power Supply Idle Control". Change it from the default "Low Current Idle" to "Typical Current Idle". That will prevent your CPU from entering the lowest possible idle state (C6), from which some early 1000-series CPUs can't wake up. Later generations don't suffer the same problem but the BIOS setting isn't harmful. There's a lot of anecdotal stuff on the Internet on this subject, but you don't need to globally disable C-states.



Link to comment

Wow. Thanks for the in depth answer.  I HAVE been experiencing lock ups.  Which is the reason for the updated BIOS.  I have been searching for the low power idle setting and just can't find it. Updated the BIOS trying to see if the option was added.  I guess that was a mistake.  Just found that same thread yesterday.  I did disable the global c state control.  


I hear you on the advice that it is not necessary.  However I am just going to see if I get the lockup again.  Hard to try and wait each change since it takes so long for the lockup.  I am on the road all week and just have to deal with it bit by bit when I get through to the house. 

Link to comment
1 hour ago, SageTX said:

I have been searching for the low power idle setting and just can't find it.


It's been there for some time but can be difficult to find. It's in the AGESA under the extensive AMD CBS menu. I'm more familiar with Gigabyte BIOSes than ASRock, but try this: Advanced -> AMD CBS -> Zen Common Options -> Power Supply Idle Control. I can verify that for a different ASRock B450 board, just not a Pro4, but they all have a lot in common. Note that this tweak is only useful for crashes when idle. It specifically addresses the problem where the Zen cores are put into such a low power mode they fail to wake up from it. It won't do anything for crashes when even moderately busy.

Link to comment
  • 4 weeks later...

I am curious if you found a resolution to this error?  I had it as well, my log would get to about 10% then the server would either lock or freeze for a while.  When it came back GPUStat would be empty, no GPU listed.  I had to uninstall GPUStat to get it to stop, now the log is back to normal.

Link to comment

I haven't. I actually forgot about it as I finally got the system to stop freezing.  However just this week I encountered another freeze.  Can't get to it tonight but I'll try to see if it's still posting those to the log tomorrow. 


Things I've done since though that may have changed things - updated the nvidia driver. Updated the gpustat addon.  Turned on iommu in the bios (that was a pain to find) and passed through the GTX 950 to plex docker for transcoding. 


I have no idea what the lockup was about this time but it had been up over a week this time.  

  • Like 1
Link to comment
  • 6 months later...
On 4/29/2021 at 3:09 AM, SirReal63 said:

I am glad you got it sorted out.  I have left GPUStat uninstalled and everything works as it should.I will try it again soon.

 after upgrading the gpustat i got the same message "[nvidia] mapping multiple BARs" filling up my syslog. i removed the gpustat and the messages went away.


Link to comment
  • 1 year later...

Resurrecting a bit of an oldie here, but came up when I was searching for this error message.


Had the same thing pop up when I was checking the log after a restart after a (standard) power-down triggered by my UPS.


Tried the easiest solution first (removing GPUstat) and it worked, errors gone, log now useful again and not filling up by the second.


It's an older GPU so I can't update the drivers on that side, and didn't want to check the BIOS first as it would require plugging stuff into my headless server, but interesting that it worked so well.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...