Jump to content

Cannot Change Raid Status on Formerly Combined Pool Drives

Recommended Posts

I have two HD that were first added to Unraid together in a pool.  This automatically made them a RAID 1.  Since then I followed the instructions in the manual to remove a device from a multi device pool which worked.  Both drives are now in single drive separate pools.  However the raid status of each is still raid 1.  the manual specifies how to change this in version 6.9 and up but the option in the manual is not available in my unraid gui for these drives.  As a result the raid 1 is still intact, which also means if shares are assigned different pools that the mover no longer functions.  I'm about to manually move all the files and just erase the drives and start over, but at this point don't even know if that will change the raid status.

Link to comment

Both devices from downloadpool and steampool are in the same pool, something went wrong during device removal.


You can do this:


Stop the array, if Docker/VM services are using this pool pool disable them, unassign the devices from both pools, start array to make Unraid "forget" those pools config, stop array, reassign both devices to the same pool, the one the this data belongs to, downloadpool or steampoolall (there can't be an "All existing data on this device will be OVERWRITTEN when array is Started" warning for any pool device), re-enable Docker/VMs if needed, start array.


Now repeat the pool device removal, make sure you just unassign one the devices, don't assign it to a new pool until it finishes balancing the other pool, you can post new diags after doing this to confirm all is good.

Link to comment

Ok where this goes wrong is the last part for pool device removal.  You cannot follow the steps listed in section 4.6 of the manual, which is the same as your instructions in last sentence.   Unassigning a disk results in an error, preventing the array from starting.  You also can't change the number of drives from 2 to 1.  I can do this with a new config.  Is this the right process, it's what I did last time that didn't work.


Hmm got it.  Unassign all drives.  Then change the number of disks.  Then add disks that will stay in new pool.  Thats the missing part.



Still nope.  One drive in pool.  One drive unassigned.  Step 4.6.6 for changing raid level with 1 drive still not functional.

Edited by kydsid
Link to comment
9 hours ago, JorgeB said:

There's an "I'm sure" or similar check box next to the start array button, just need to check that after unassigning the device.


Ahh that is the missing instruction.  You can restart just fine with what appears separate pools but that are not (probably shouldn't allow that as it's confusing and not actually working as it appears in the gui).  You can even ask for it to balance.  ^ that is the only way to get unraid to remove the 2nd disk, which then automatically starts a balance and removes the raid settings.  no user change of raid setting even occurs or is available as suggested in documentation.  then of course re-ad the second disk as a new pool and format it.


thanks for the help

Edited by kydsid
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...