Jump to content
We're Hiring! Full Stack Developer ×

Subfolder permission issue


Recommended Posts

New unraid user, Linux noob here. Tried to do some searches but I'm too scared to apply anything. All data is backed up. Everything has been fine for over a month on the new server with my data until today when I tried to create a new folder inside the base of the pictures folder from a windows 10 computer. It would not create. I am able to create a folder in any subfolder of pictures, just not the base.

It is a part of another share so, it is not the problem. I performed ls -l and getfacl and found the same incorrect permissions applied to the music folder and a few subfolders in my videos. 

Running fix common problems, new permissions, and docker safe permissions did not correct the issue. I can create a directory using the command line in the folder as root user. What is the next step to correcting these permissions and applying them to all the subfolders? How can I find out why the three utilities built-in are not correcting this?

I rebooted the server and an automatic parity check began. Not sure why - had zero issues that should have caused that. it is scheduled for the 1st. File verification plugin runs on the 15th. The log gave no specific reason other than to notify me by email that it was happening. Before that the only error is a time synchronization error - the clock on the server is reading the correct time. That will finish in 5 hours and I'll post the result.

 

Full disclosure: This is the first time I've tried to create a folder in the base of pictures since building this server. It may have been this way since the beginning. The original data fill was all copied from a windows 10 share using the rsync command from the server terminal.

Thank you for your help!

permissions.png

Edited by wildfire305
added log detail
Link to comment

A surface level inspection showed only three folders are affected by these permissions and only at their base. All subdirectories inside the wonkily permissioned base folder are normal. Pictures, Music, Home Videos. I dove into several subdirectories and manually listed permissions (I don't know the syntax to get it to tell me what I want to know in one shot). These are accessed by Plex and Jellyfin. Those apps also access the Movies folder which has normal permissions. I'm not saying those apps are causing the problem, just that they are the first thing I thought of that shares commonality. Those three folders in question are within the media subfolder of the main share Pool. I have some symbolic links to those folders in another share called media. That was used to control specific user access permissions to the media folder - didn't want the kids having the ability to delete or read access to the whole pool. "Home videos" however does not have a symbolic link in the media share - so we can probably rule out that as a cause.

 

Can someone share the command syntax to tell me "if directories recursively have read only permissions and not show other results"? dir /p /s /a:r is what I'm used to (I grew up on dos).

Link to comment

Performing the above command led me to a list of 6 directories with the same strange permissions. One of them contained some unimportant data. So I decided to chmod 777 it. That changed the permissions to match all the others: owner: nobody, group: users with read write execute permissions and now everything works correctly in that directory over the samba share. 

Is it safe to perform that to the other five directories and not worry about how they became read only unless it happens again?

 

Link to comment
  • 11 months later...
  • 1 year later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...