Dockers cannot talk to each other on 1st boot, have to reboot get them to work?


Recommended Posts

I am having problems on "first" boot where my docker contairs cannot talk to each other (i.e. radarr to sabnzbd) 

 

Test was aborted due to an error: Unable to connect to SABnzbd, Error: ConnectFailure (No route to host): 'http://192.168.0.53:8080/api?mode=get_config&apikey=**intentionally deleted**&output=json'

 

This happens EVERY time I reboot the server until I reboot again and then everything is great until I need to reboot again.  

 

Can anyone please help?

 

 

unraid1-diagnostics-20230303-0913.zip

Link to comment
49 minutes ago, Squid said:

So if you restart Radarr it does work?  Change the startup order in the docker tab and have Sab starting first and add in a delay after it starts (all advanced view)

 

If I restart Radarr and Sabnzbd I still have the communication problem, the only way I have found to resolve is to reboot again.

Link to comment

@Squid

 

I can confirm just by stopping and starting the array everything is now working rather than a full reboot.  I imagine that if I had stopped and started the docker engine I would have had the same result?  I have been putting up with this for a good 6 months+ but thought I would ask about it today, any ideas?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.