Jump to content

No files written to shares after certain date appearing over SMB

Recommended Posts

Not sure what’s happening here- I see the files on my shares from the Unraid GUI and are even able to copy them with the File Manager, but whenever I look at my SMB share from another device I only see older files.


Any ideas?


Also, probably a separate issue, but all of a sudden from Windows 11 on my NFS shares I am getting a “Need  permission from Everybody” error when I try to copy files.


Link to comment
2 hours ago, itimpi said:

Have you tried running Tools->New Permissions against the share in question?  

Tried that and it seems to make no difference even if everything on each share/drive is full permissions, all new files/folders just aren’t seen on all my shares.

Link to comment

This is not a known issue, so I'm asking for a bunch of details to try and figure out where to focus.


Is this a new Unraid install or did you upgrade from a previous version? If an upgrade, do you know what version you came from? Did any of the issues you have reported occur in that version or is it all new?

Pick one of your shares that you don't mind sharing screenshots and directory listings for. Then go to the Shares tab and click on the specific share, and take a screenshot of all the settings.


Also show the details of the SMB/NFS share settings if you can.


On 6/25/2023 at 2:04 PM, HDGuy said:

all new files/folders just aren’t seen on all my shares.


What is creating the files? If a Docker container, can you show a screenshot of the container config that shows the exact paths that are being passed to the container?


What are you using to read the files? If it is something like Windows Explorer, what user are you using to access the files? (the user should be listed on the screenshots above)


On 6/25/2023 at 10:21 AM, HDGuy said:

Windows 11 on my NFS shares


Can I ask why you are choosing to use NFS to share with Windows? Have you considered using SMB instead?

Link to comment

To answer the last question first I started using NFS with Windows 11 because of my issues with SMB. It’s not a new install- and I’m using my NAS solely as a media server. I think this problem started happening one or two updates ago, maybe when I first started going the non-stable branch route. I’m also having issues with the File Manager pluggin- I’m not sure if all these problems are related.

I’ll take some screenshots later- I’m also unsure if all my issues are solely with files created thr NZBGet docker. I’ll try and write some files to the NAS from another source and see if they’re visible over SMB. The file names have no special characters and appear to be completely valid.


Edited by HDGuy
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...