Jump to content

LSI 9300-8i HBA is not recognized.

Go to solution Solved by SciKo,

Recommended Posts


as the title states I've recently gotten my newly bought HBA expansion card and I can't for the life of me make sense of why it isn't working.

My build:

  • ASRock Z790 PG-ITX/TB4
  • 13th Gen Intel® Core™ i9-13900KS @ 3168 MHz
  • Samsung M.2 SSD (Gen 4)
  • 64 GiB DDR5
  • LSI 9300-8i
  • Corsair RM1000x PSU

I've connected two Mini SAS (SFF-8643) to 4x SATA cables to the LSI 9300 card giving me 8 SATA connections. 7 of those are connected to WD HDDs of different sizes (mostly WD Reds) but none is recognized when I boot up Unraid. Heavily suspecting the LSI card I found and followed this excellent guide (https://forums.unraid.net/topic/97870-how-to-upgrade-an-lsi-hba-firmware-using-unraid/) on how to upgrade the firmware and it only confirmed the obvious:

root@SkyNet:/lsi# ./sas3flash -listall

Avago Technologies SAS3 Flash Utility
Version (2018.04.02) 
Copyright 2008-2018 Avago Technologies. All rights reserved.

        No Avago SAS adapters found! Limited Command Set Available!
        ERROR: Command Not allowed without an adapter!
        ERROR: Couldn't Create Command -listall
        Exiting Program.

 The card seems to not be recognized at the hardware level and I feel clueless as I was under the assumption this particular card was supposed to be one of the easier to install with practically plug n play behaviour. The card is seated in a PCIE Gen 5.0 x16 slot which is physically larger  than the card's x8 (PCIE Gen 3.0 I believe) but as I've understood it that shouldn't cause an issue?

The card also show signs of life with it's green indicator flashing steadily (I haven't found any info on what info can be derived from that).
Edit: I just found this in their documentation - The LSI 12Gb/s SAS HBA Heartbeat LED, CR1, blinks green to indicate the HBA is capable of general activity.

I'd appreciate any and all help you can spare as I'm clueless atm!




Edited by SciKo
Link to comment

Thank you for the quick replies!

Sadly this is an ITX board so I only have the one PCIe slot. Asrock isn't offering a ton of options in the BIOS but I did try to change the PCIE1 link speed to both Gen 3 and even Gen 1 along with a multitude of hail mary changes that didn't change the outcome at all.


I have an old windows machine I can use to confirm the card is functional but comparing to what I've been able to find on the interwebs it doesn't appear to be dead.


I've read multiple occasions where Asrock MoBos were the culprit and someone confirmed switching to a ROG Zenith Extreme fixed it. Someone else did however report that switching MoBo did not fix his issue (switched to ROG Strix x470).


Assuming my HBA card is functional, what are my options?

New motherboard? 

Link to comment
  • 3 weeks later...

It is regrettably not resolved yet and truth be told is getting on my nerves -_-
I was not able to confirm my HBA card was fully functional with my older equipment so I went with my gut and assumed (based on other people's complaints about AsRock not recognizing HBAs) I needed a new motherboard. ASUS seemed recommended and truth be told there aren't too many to go for that makes good use of the 13900KS. I went with an ASUS PRIME Z790M-PLUS. That way I got one Gen 5 and one Gen 4 PCIe slot but alas, the card is not recognized at all.

I have now ordered an LSI SAS 9207-8i based off of other successful resolutions to similar issues like this but obviously since it is starting to become time critical as my server has been down for months now since I first started the move to Unraid (and have yet to succesfully get everything running) the order is missing now days past the delivery date, complete silence from all ends.

I'm sorry to say I have not resolved this issue yet.

Looking at my attempt and journey to embrace and move to Unraid I must say I'm disappointed it has been such an uncertain and costly endeavor with still a failed outcome. Unraid has generally been incompatible with everything I've tried so far and although I truly appreciate the timely help this forum continues to give I can't help but feel I should be up and running by now given the time and research I've put into making this work.


I'm sure I'll be playing happier chords should my missing order arrive and subsequently work. Should it however not work I'll have a hard time justifying to my conscience how my ~$3000 spent building an Unraid server happens to need yet another big investment (like new chipset and CPU).


My fingers are crossed for you and me both Rusty xD

Link to comment
  • Solution

Allright, it's time to post a resolution to this as I've just gotten past the point of now rediscovering all my old drives via my new HBA card. I can't really say why my LSI 9300-8i didn't work and so my theories may be of little worth. A stab in the dark would be assuming SAS3 type devices are not as widely compatible with consumer grade motherboards and so no matter which board I used the card was not recognized at all on the hardware level.

To the happy news!
I've recently installed my newly arrived LSI SAS 9207-8i HBA card into a PCIe Gen4 slot on my ASUS PRIME Z790M-PLUS and I can happily confirm the drives are now discovered and the disk array is complete and ready to start up again. I have far from tested this setup to any extent but intend to in the coming days. Should anyone however be in the same predicament I was in I can now at least offer my step forward from that. Fingers crossed it's smooth sailing from here! xD

Link to comment

A stab in the dark would be assuming SAS3 type devices are not as widely compatible with consumer grade motherboards and so no matter which board I used the card was not recognized at all on the hardware level.

There are no known incompatibilities between LSI SAS3 HBAs and current gen or older consumer platforms. If you have checked the HBA on a (PCIE 5.0 downgraded to) PCIE 3.0 x16 (or x8) slot, with minimum of 4 available lanes confirmed through the BIOS, and indeed on different motherboards, a dead HBA is likely to be the case.



The card also show signs of life with it's green indicator flashing steadily (I haven't found any info on what info can be derived from that).
Edit: I just found this in their documentation - The LSI 12Gb/s SAS HBA Heartbeat LED, CR1, blinks green to indicate the HBA is capable of general activity.

A defunct card with heartbeat is not unheard of, not entirely certain if this is indeed the case with your LSI 9300-8I. Further investigations may be needed if possible, to ascertain the health situation of the HBA.

Edited by Saito
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...