Jump to content

[Solved] No drive listed to install Windows 10 on VM


zekemdm

Recommended Posts

Hello, when proceeding to install Windows 10 on my newly created VM in the Windows Setup Where do you want to install Windows? There is no option of drive. The options available below are to refresh or load driver. The caution warning at the bottom reads, "We couldn't find any drives. To get a storage driver, click Load driver."

 

In  my eyes the VM is in good working order. I have assigned 3 CPUs, 2GB memory and 25GB Hard Drive space. The Windows 10 setup is functioning so I do not know what the cause of the problem is.

 

I have included the diagnostic file in case it is needed.

 

Thank you.

nas-diagnostics-20160228-2012.zip

Link to comment

Ok, I think I figured what the problem was. I swapped out the vitro driver from the v. 102 to v113 and I did not go back and change where it was looking in the System Settings VM Manager. Ofcourse because I had removed the version 102 it would give me an error. I have gone in and updated the system settings to look for the version 113 and the installation is in progress now.

 

Sorry for wasting everyone's time for the past hour.

 

Thanks.

Link to comment
  • 6 months later...

Hi,

 

I realize that this thread is solved... and maybe I should open a new thread? But I have the exact same issue.

My first Windows 10 Pro setup worked just fine. Then I deleted the VM and now I'm about to setup a new one.

When I reach the step "Where do you want to install Windows?" there is no disk available, just as expected.

So I follow the instructions at http://lime-technology.com/wiki/index.php/UnRAID_Manual_6#Installing_a_Windows_VM:

"... You will need to load the following drivers in the following order:

 

    Balloon

    NetKVM

    vioserial

    viostor (be sure to load this one last)

 

For each driver that needs to be loaded, you will navigate to the driver folder, then the OS version, then the amd64 subfolder (never click to load the x86 folder)

After each driver is loaded, you will need to click the Browse button again to load the next driver.

After loading the viostor driver, your virtual disk will then appear to select for installation and you can continue installing Windows as normal...."

 

But when I have completed the last driver load still no disk shows up. Have tried to do a refresh but still no disk.

I have tried using both SeaBios and OVFM, still no disk.

I also tried the different machine types, still no disk.

 

What could be the cause of this?

Link to comment

Ok, instead of using the latest stable virtio drivers (0.1.102) I dowloaded the latest (0.1.118). Still could not find my drive. But, then I noticed that yesterday unRAID 6.2 was released so I updated (from 6.1.9) and voila now I can find my drive again, still using the latest virtio drivers.

Can not figure out how I was able to install a win 10 VM from the begining... maybe some smaller update that broke something... anyway, this is how I made it work again. Hope it may help someone.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...