[SOLVED] Cant get USB flash to boot UNRAID


dwoods99

Recommended Posts

Long time UNRAID user but haven't touched my servers in years... running 5.0rc8 and it's been running well.

I was looking into upgrading to 6.2.4 -- read the upgrade page for v5 to v6.

I forgot that the Pro1.key is linked to the USB stick so I first formatted a new stick as fat32, label UNRAID, and ran make_bootable.bat with 'Run as administrator'.  Copied v6.2.4 files onto it. It did not boot -- probably because of key linked to USB (I thought).

 

Rebooted with v5 USB stick and it was fine. So USB backup of contents, on Windows 7 I re-formatted USB, label UNRAID, and ran make_bootable.bat with 'Run as administrator'. Copied v6 files onto the USB, went into my v5 files to copy contents from config/ which included shares/, disk.cfg, ident.cfg, network.fg, passwd, Pro1.key, shadow files

 

It does not boot on the UNRAID server -- never gets to an UNRAID menu, only a blank screen

 

I've tried numerous times to run make_bootable.bat with 'Run as administrator'.

I made sure virus scanner wasn't blocking it from running (although command appears to run fine).

I tried a different Windows computer.

I even used my other UNRAID server to mount the USB stick, and run the make_bootable_linux (which I got working after bypassing errors in the script such as 'realpath' command not found)

 

Please HELP with other ideas.

Link to comment

I've tried that on all ports. Even though it was functional before. Checked BIOS settings and still set to USB boot.

 

After the BIOS bootup display, it shows a cursor, goes blank for 1 sec, back to cursor but then nothing.

I can see that the USB stick is being accessed by flashing light. It just won't boot.

 

I should get an UNRAID menu regardless of existing Pro key (which is 100% valid and legit).

For that reason I don't believe the contents are wrong, even after putting v5 files back onto it.

 

I'm sure it's something wrong with not able to boot but what is the bootup sequence for UNRAID?

I ask because I want to try booting another machine.

 

Other ideas?

Link to comment

A couple questions ...

 

(1)  Are you CERTAIN the USB flash drive is set as the first bootable device?  Note that some flash drives are "seen" as hard drives on some BIOS implementations => in those cases you have to set the first bootable device as the hard drive; and the "hard drive order" so the flash drive is listed first.

 

(2)  Are you getting the initial menu to choose UnRAID, MemTest, etc. ??

 

Link to comment

1) Yes I'm sure. It was working before with the same registered USB key until I formatted to upgrade to v6 (BIG regret now).

 

2) No I don't get the UNRAID menu to choose from.

 

I've tried all USB ports on back of Antec 900 for motherboard which is over over 5 years old.

I've tried another formatted USB stick with v6 files but same problem (although I expect Pro1.key to fail).

 

I'm now trying to setup an old PC to check the USB boots on another PC.

If so then I'll have to blame server motherboard even though I can see the USB port/stick being read from (accessed).

Link to comment

When you ran the the Make_Bootable file running it as Administrator, did you hit the <Enter> key twice?  That is not really clear as you run the procedure as what is required unless you are really careful while reading the terse verbiage on the screen. 

 

I also double the advice about checking to see that the USB key is actually the first boot device.  Some BIOS have a key you can hit as the BIOS boots up to select a boot device-- use it!  I can also tell you, that some BIOS will change the boot order if it is does not find the exact USB boot device that is specified in the boot order.  This new selection (on an unRAID server) is usually a hard drive that is not bootable and the system may freeze up at that point.

Link to comment

You could try using a v5 distribution and re-doing the flash drive with it to see if it will boot okay => but if you're not even getting the UnRAID menu screen it is fairly likely that the system simply isn't booting to the flash drive.

 

Note that a few "blinks" of the flash drive is very normal, regardless of whether or not it's the selected boot device -- so that does NOT mean it's trying to boot from it.    You should absolutely get the UnRAID selection screen if it's booting to the flash drive [unRAID, MemTest, etc.].    Note that SOME motherboard/controller combos have had an issue with v6 where they will not boot to UnRAID, but WILL boot fine if you choose UnRAID GUI (a new option).    Not sure if that's been fully resolved or not with the latest release -- but since you're not even seeing the selection screen that is NOT the issue here.

 

It's almost certain that for whatever reason the system is NOT booting to the flash drive.

 

Link to comment

Yes, I ran make_bootable correctly.

 

Seems like it's a motherboard problem now.

I was able to setup an old PC and I was able to boot with a USB stick containing v6.2.4 and go into UNRAID-GUI.

Same USB stick will not boot in my server, even though BIOS sees it and adds it to bootup for removable drive.

 

I put the USB stick with v6 to boot up my second server and it also gave me the UNRAID menu.

 

Something must have popped on the Intel 775 DQ965GF motherboard, possibly after replacing CoolerMaster CPU fan.

Although it was working after until I tried re-formatted working USB stick to upgrade to v6.

 

Not sure what else to try other than find a replacement board.

Link to comment

Good question... I don't know.

I was wrong about motherboard, it's an Intel DG31PR but I can't find info about 64 bit O/S at

http://www.intel.com/content/www/us/en/support/boards-and-kits/desktop-boards/legacy-intel-desktop-boards/intel-desktop-board-dg31pr.html

 

I will try to get another usb installed with UNRAID v5 and boot with that.

 

EDIT:

I re-installed 5.0rc8 from zip back onto USB stick updating only important config/*.cfg files and booted

using other PC which booted for v6. I get UNRAID error "Failed to load COM32 file menu.c32" although it

does exist and is located in root of flash drive.

Link to comment

All of the supported processors for that board have 64-bit support, so your issue isn't that simple.

 

When you prepare the flash drive, are you (a) reformatting it to ensure it's "clean" of any residual files;  (b) labeling it UNRAID;  © copying all of the files from the distribution to the flash drive (either v5 or v6); and then (d) running MakeBootable FROM THE FLASH DRIVE with admin privileges ??

 

Link to comment

Yes, except didn't realize (never made clear in notes) you had to run make_bootable after you install a version,

like going back from v6 to v5. This was causing the failed menu.c32 messages.

 

Now I have a second USB installed with v5 and booting on a second PC.

Got the original USB booting into UNRAID menu on second PC but NOT the original server.

On server, either USB used, now instead of hanging while booting and never showing UNRAID menu, it is trying to load but causes the server to reboot repeatedly. Tomorrow I will start removing hardware and reboot from bare bones to see if that works, and then slowly add hardware back until boot fails again to pinpoint the cause.

Link to comment

Just for grins, what is the CPU on the system that won't boot?    Although every CPU I checked on the "supported CPU" list for your motherboard was 64-bit capable, I have to wonder if I missed one that does NOT have 64-bit support.  Not likely -- but if you note the actual CPU we can absolutely dismiss that as the cause of your problem.

 

Link to comment

I suspect you have a Core 2 Duo E4400, which is being mis-identified by the BIOS because you didn't update it to a level that had proper support for that CPU.

 

It's also possible that you miss-typed the number and you have a Celeron E1400, which is also a 2GHz CPU

 

Both of those are on the CPU support list for your motherboard -- and as I noted earlier, all of the CPU's on that list DO have 64-bit support, so that's not your problem.

 

Link to comment

Yes, probably Core 2 E4400. It's been a long time  ;)

 

Something is stopping the boot process. Still unsure if it's hardware or UNRAID.

I wasn't able to find BIOS option to allow me to see the boot up sequence.

Using TAB gave minimal output. I did try F10 to pick which to boot from but no change.

Image1.jpg.9ba9d6e40168b802ba52126bbc53f3f9.jpg

Image4.jpg.de52f09da66107b23945070e910cda3e.jpg

Link to comment

...

Now I have a second USB installed with v5 and booting on a second PC.

Got the original USB booting into UNRAID menu on second PC but NOT the original server.

...

 

Just to be clear, either of these will boot UnRAID on your other PC, and you can access the UnRAID console -- correct ??

 

... and neither will boot on your original server ??

 

What size are the flash drives?

 

Link to comment

Correct, both cause server to reboot and I never see an UNRAID menu.

Original licensed USB is 8 GB and I tried 2GB for the second one.

 

Removed all hardware like network card, SATA port multiplier, even the fans.

Also all RAM and computer beeped as expected, removed 1 of 2 RAM which BIOS complained about but continued to boot.

In all cases, the system kept rebooting after the BIOS, never getting to UNRAID (at least not visually).

Other than both chassis fan ports appear dead (CPU fan port ok), all connections are solid.

 

I have nothing left than to get a new motherboard/cpu (or replacement).

I'm out of trouble shooting ideas.  :P

Link to comment

Agree it doesn't sound good.

 

2GB and 8GB flash drives shouldn't be an issue at all -- some systems have problems with very large units (64GB and up) ... but you don't have that issue.

 

One other thing I've seen is some older systems that will not boot when prepared with the newer versions of MakeBootable; but will work okay with the older versions of syslinux, where the drive is prepared by running "c:\syslinux.exe -ma f:"  (where f: is the drive letter for the flash drive) instead of using makebootable.

 

It's possible your system requires that method of preparation.

 

 

 

Link to comment

Finally! Success.

 

Went back to basics using 2GB. Re-formatted, copied virgin 5.0rc8 files, copied my ident.cfg and network.cfg files,

ran makebootable as Administrator (right-click on file and select option from drop down menu).

Made sure label of USB still set to UNRAID... this was something I found tonight that a refresh of the Win7 drive list

showed the label as back to blank -- even though it was clearly in format option.

 

My server FINALLY booted back into UNRAID menu.

Back to PC to add more files back (Pro1.key, passwd, shadow, disk.cfg, smb-extra.conf, smbpasswd, share.cfg, shares/ folder),

, reboot worked again but of course UNRAID Basic mode (wrong USB for my Pro1.key).

 

Now try registered USB key with back to basic files. Didn't work. Back to PC to run makebootable AGAIN, make sure UNRAID label.

Worked.. finally. Now I could grab files from backup v5 USB contents and add back. Run makebootable once again for safe measure.

 

System back up with all the v5 plugins. Only problem was the disks were no longer listed and I had to manually select them in their proper slot. Started array with box checked for "Parity is correct".

 

Side note: even with no added files to v6 installed on a new 16GB Samsung USB, it would not boot on this server, however it boots fine on an old PC (ASUS PB5-E)... so this server will NOT be getting any more attempts to upgrade to v6.

Link to comment

Glad you're back in business.

 

As I noted, I've seen this same issue on a couple of older systems, but it's probably been two years since I encountered the issue, so I didn't originally think about suggesting it.    Glad prepping it from the old v5 distribution worked.    I'd agree that leaving "well enough alone" is a good idea at this point  :)

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.