Jump to content
-Daedalus

[6.4rc10,11,12] IT-flashed LSI 9211-8i drives not detected on X399

13 posts in this topic Last Reply

Recommended Posts

Hi all,

 

Posted about this in general support, but posting here for visibility as well.

 

Moved my rig recently from a C2750 base to an X399 Taichi / 1950X.

 

Under 6.3.5, my 9211-8i is detected fine, but with any of the RCs I tried (10, 11, and 12) they're not shown.

 

johnnie.black noticed the following after looking through diags:

Nov 18 13:59:52 server kernel: mpt3sas 0000:42:00.0: Refused to change power state, currently in D3
Nov 18 13:59:52 server kernel: mpt2sas_cm0: 64 BIT PCI BUS DMA ADDRESSING SUPPORTED, total mem (32813424 kB)
Nov 18 13:59:52 server kernel: mpt2sas_cm0: sending diag reset !!
Nov 18 13:59:52 server kernel: mpt2sas_cm0: diag reset: FAILED
Nov 18 13:59:52 server kernel: mpt2sas_cm0: failure at drivers/scsi/mpt3sas/mpt3sas_scsih.c:8937/_scsih_probe()!

While I haven't gone back to confirm this, I'm pretty sure an IT-mode H310 I had in my system previously exhibited the same behavior. (I ordered the 9211 because I thought I'd bricked it reflashing firmware).

 

If need be, I can test things, but it'll probably have to wait a while. I've spend two weekends troubleshooting this, so at the moment I'm just happy to have my server back.

Diags attached. 1402 is on 6.4rc11 (I think), 1501 is after c/p'ing my original 6.3.5 contents back to the drive.

server-diagnostics-20171118-1402.zip

server-diagnostics-20171118-1501.zip

Share this post


Link to post

That's a tough one because there's not a lot we can do about mpt2sas driver.  Two things: next unRaid release will be on linux 4.14 kernel, maybe it was a regression fixed there.  Secondly, prob you've already done this: check if later f/w is available.

 

Probably there was a regression introduced in some kernel.  Older post, but shows a workaround:

https://bugs.launchpad.net/ubuntu/+source/linux-lts-xenial/+bug/1625718

Share this post


Link to post

I also have a 1950x and x399 Taichi and two LSI 9211-8i with IT firmware.

 

With bios 1.70 both cards are detected in unRAID 6.3.5, but with bios 1.80 only a single card is usable. This may be unrelated to unRAID, as in my experience this board is *very* picky about what cards will work with it; not sure if this is the fault of Asrock or AMD.

 

What BIOS are you using, and are you able to see both cards and associated drives in the LSI boot rom utility?

Share this post


Link to post

I didn't flash the bootrom on to any cards I flashed to IT mode - there's no point if you're using it as a HBA.  I'm sure most others don't also.

Share this post


Link to post

Thanks for the responses guys.

 

Limetech: I'll give that workaround a go next chance I get, though probably won't be for a little while. Yup, checked, card on latest firmware.

Charlie: I'm using 1.80. Figured things would naturally get better with BIOS revisions on a new platform, but what do I know? :P same as above.

Helldirver: Correct, I didn't flash the bootfrom for this card either, so can't see if HDDs are detected, but as stated, the H310 I was using saw drives fine, then didn't here. I'd expect the same is true of the 9211.

Edited by -Daedalus

Share this post


Link to post
15 hours ago, HellDiverUK said:

I didn't flash the bootrom on to any cards I flashed to IT mode - there's no point if you're using it as a HBA.  I'm sure most others don't also.

Guess I'm in the minority then.  I always flash the bios.  I want to see the drives the controller thinks are connected to it.  I turn off the quick boot in MB bios as well.  I don't reboot often so it doesn't matter how long it takes as long as it is 15 minutes or less.

Edited by BobPhoenix

Share this post


Link to post

I have the same similar expander card (only one though), and a PRIME X399-A board, I ran into a similar problem. For me I got the card/drives to work by moving it to another PCIe slot and had to enable boot interrupt INIT 19 from my BIOS (this was buried in the advanced or PCIe settings, I'm not at my computer presently), then the drives started to be detected in unRAID. TR's do have two different PCIe controllers on their CPU; is possible one isn't being supported that well yet? 

 

Also running 6.4.17b (with "ugly patch" compile) since that's the start of really supporting TRs at Kernel level.

Edited by Jcloud
Added another bit

Share this post


Link to post

Apologies for reviving an old thread, but I've systematically looked though every setting in the BIOS, and I can't find anything like 'boot interrupt init 19'.

 

Any idea where that was, or if it was called something else? 

 

Edit: Swapped a 9207-8i in place of my H310, and drives are detected now. I've no idea why this works, but it works, so I'll go with it for now. It's only been online for about ten minutes at this point. Will report back if further problems. No errors in the log at least. On 6.4.1.

Edited by -Daedalus

Share this post


Link to post
4 hours ago, -Daedalus said:

Apologies for reviving an old thread, but I've systematically looked though every setting in the BIOS, and I can't find anything like 'boot interrupt init 19'.

 

Any idea where that was, or if it was called something else? 

 

Perhaps "signal interrupt 19" or similar, it's suppose to an interrupt for the bios to listen to bios of other cards.

 

But hey at least you got it working on the other port; perhaps if you have another card (assuming brand new board) you could plug it into the other slot, perhaps system doesn't like that slot, in general, or it is bad? Then again, if it has worked before, then my beautiful theory is destroyed by ugly fact.

Share this post


Link to post

Card's in the same slot as the last one. Maybe something in the kernel doesn't play nice with older cards or something? Wouldn't mind, but the 9211 that was in there is the most recommended card for stuff like this, so you'd think it'd work, and it worked fine with 6.3.5. Who knows?

 

Look all around for anything BIOSy, Interrupty, signaly, etc. Nothing that sounded like what you're describing.

 

Whatever, it's working. The 9207 is actually the better card anyway, so it's fine. Glad I'm back on the latest version anyway.

Share this post


Link to post
6 hours ago, tjb_altf4 said:

@-Daedalus is the 9207-8i still going well for you on your taichi x399?

 

Since then, there's a second one in there as well. Both rock solid. On 3.50 BIOS.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.