Jump to content

Cache drive on its last leg - no thanks to power outage?


Recommended Posts





My cache drive is OLD. It's a WD Raptor 150GB probably from 12-13 years ago. IF it's going, it owes me nothing. I just don't have a handy drive standing by to replace it with.


I log into the server admin last night to see a whole slew of pending sector errors. Like pages and pages of notices that wouldn't seem to clear no matter how many times I hit "clear all". I search the forums to see responses varying from "get a new drive NOW" to "safely ignore" - granted, the latter was aimed at SSDs. 


I was just realizing that I hadn't built my unraid backup box yet (isn't this always the way?), so I pulled a copy of everything on my cache drive to my PC last night.


Just firing the server up as I type this to figure out what to do next. Diagnostics attached. 



Events leading up


I'm trying to remember the order of events that led up to this: 

  • Last weekend we were away. My server was left on, plugged into a battery backup. 
  • Our place was hit with several storms that knocked out the power more than once. The first time, battery backup handled it. The second time was too long. Hindsight: I should have remoted in and shut things down as my UPSes weren't set up in unraid to shut down gracefully.
  • When I got home, the battery backup was squealing "overvoltage". I haven't been able to get it working since. The server was off. 
  • I didn't think anything about it; plugged the server into a surge protector and fired it up. 
  • Mid-week I updated the Plex docker.
  • We were watching shows just fine.  
  • We had more storms in the forecast so I shut down the server (cleanly). 
  • Friday I started up the server again and there was another Plex update, which I did. 
  • Saturday (yesterday) I tried to play some content but was met with an error when trying to playback. Even on content we had played just the day before. But the UI and everything else loaded fine. 
  • I logged into the server admin (currently running 6.3.5) and saw a TON of cache drive pending sector errors.
  • I copied pretty much all data from my cache drive to my PC.  
  • Last night I was too tired to think clearly; I shut down the server before grabbing diagnostics. 
  • I just tried playing something via Plex today, and it worked. 
  • There are still a ton of pending sector errors but date/timestamp is from last night up until the minute I shut it down. Nothing since?


Link to comment

Looking at the smart status for that drive, Raw_Read_Error_Rate, Reallocated_Sector_Ct, Seek_Error_Rate, Spin_Retry_Count, Reallocated_Event_Count, Offline_Uncorrectable and Multi_Zone_Error_Rate are all 0. 


As per the notices though, Current_Pending_Sector is 924.


Link to comment

Ok, so a few things then. 


Cache drive is currently home to my apps directory, domains (nothing in that dir?) downloads, system, my docker image and some content that hasn't been moved to the data drives yet. 

  1. Would it be better to remove the cache drive from the system until I can get a new one in there or leave it in place and find a replacement ASAP?
  2. The only somewhat viable option I have here to replace it with is the Crucial 240GB M500 I currently have some VMs on that I don't use. I'd be OK to do without those for a bit, I suppose, (and they could stand to be rebuilt) so long as I could be sure the next time I install W10, it'll activate.

Hrmm. It's that or order a new drive which the budget wasn't counting on.


Current_Pending_Sector is now 1024. Seems like the ship is going down quickly.  

Link to comment

Thanks @Jcloud


I converted all my data drives to XFS around when I moved to Unraid 6. Didn't bother touching the cache at the time. I backed up your answer with the following: 




unRAID OS 6 now has three file system choices for formatting unRAID drives with, with more promised in future versions. Except for the Cache Pool, you can format any drive with any file system, mix and match them as you wish. If you setup a Cache Pool, its drives must be formatted with BTRFS.





While I have no immediate plans to create a cache pool, I may as well use BTRFS now. 


Great timing - I just finished clearing off my SSD and pulling everything I could off the cache drive. The Raptor was manufactured June 2006 so it has in fact served me well :) 

Time to hook up the SSD and see if everything works after putting Humpty back together again! 

Link to comment

This is frustrating. I went to enable dockers again and got an error saying I need to rebuild the image. A bit of searching says the best thing to do is in fact rebuild. I've seen mention of a "Previous Applications" courtesy of Community Apps but I don't see this anywhere - within unraid or looking through the app repository. 


I've read that I should just be able to install them again and all will work, but I don't recall exactly which version I had installed.


Edit: Of course, no sooner do I post this, then I notice the hamburger menu on the apps tab that shows me previous apps. So I choose one, click to (re) install and... chrome hangs. I close the tab, try to reopen and get the same, non-repsonding tab. Then, as I type this, the UI loads. I chalk it up to my slow internet connection, but it would be nice to have some indication of what's happening. It seems like one docker is back. It was one I hadn't set up to use yet so we'll see if Plex comes back to me intact. 


Edit2: Now that I know where to find it, re-creating the docker image and reinstalling previous apps was a breeze. Looks like I'm pretty much back in business except for my VMs. Haven't gotten there yet. 


Link to comment


This topic is now archived and is closed to further replies.

  • Create New...