Jump to content

Slow file transfers from MacOS HS to Unraid using cache disk


Recommended Posts



After the latest Unraid update I'm experiencing slow file transfers from my Mac (High Sierra) to my Unraid server. Before the update, it was pretty snappy, but now it's transferring to the cache drive (I've checked) at a measly 13/14 MB/S.




If I use the terminal on the server or Dolphin GUI to transfer files from one disk to the other (my downloads folder to my movies folder), it transfers at full speed still, and uses the cache drive like it's intended to be used.


I've tried with OSX compatibility on or off, but it seems like I'm stuck with slow speeds atm and it's very annoying.


Any help would be appreciated.


Update: I turned off the the cache drive and it's writing faster directly to the array (25 MB/S). So yeah, that's not normal lol

Link to comment

SMB. I've used AFP in the past and it's been even slower.


To 6.5.3 from whatever the official release was before that. No RC releases.


Cache disk is formatted as XFS. Samsung 850 EVO PRO SSD. Have run TRIM commands.


Cache for the share and globally has been enabled. I've just started the mover so I can format it to BTRFS, TRIM it again, and see if the speed improves.


Which diagnostics would you like to see?

Link to comment

AFP performance and reliability are much improved if you move the Netatalk database (the .AppleDB folder in the root of the share) off the array and onto your cache. All you have to do is change the Volume dbpath like this:




That aside, SMB works well with Sierra and High Sierra - in fact it's Windows 10 users who are having all kinds of problems with SMB at the moment. Do you have Enhanced OS X interoperability enabled?




37 minutes ago, tuxflux said:

Which diagnostics would you like to see?


Your unRAID diagnostics. Tools -> Diagnostics. Post the zip file.


Link to comment

So my attempt at reformatting and trim made no difference. 11 MB/S writes and around 30 MB/S reads.


I tried both AFP and SMB, and used your suggestion John. No difference in performance. OSX compat is enabled.


Network wise everything is hooked up to gigabit ethernet except the laptop I'm currently using which uses AC wireless. I expect some performance loss with wifi obv, but it shouldn't be this severe.


Link to comment
6 minutes ago, John_M said:

So your testing was done over a wireless connection? There are too many variables there. Please retest with a proper cabled connection.

So yeah. I feel pretty silly now. Over the wired connection, everything is fine and I'm topping out the gigabit link speed. Problem solved. Gonna see what I can do to ramp up my WiFi connection.

Link to comment

I'd use it for tablets and Kindles and such and put real computers on the wired network, even if it means buying one of those USB C to Ethernet adapters. There are lots of problems with using WiFi where there's any expectation of performance. The 2.4 GHz band is overcrowded. The 5 GHz band has problems with walls and floors. A wireless access point also behaves not like a switch but like a hub, where the bandwidth available is shared amongst all the devices connected to it.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...