Jump to content
ManishGupta8

Config/go file not working (Version 6.6.5 2018-11-08)

6 posts in this topic Last Reply

Recommended Posts

Hi Folks,

I have following commands to disable Telnet and FTP but somehow even after restarting it never works and I can still do telnet to my unraid machine. If i run these commands directly from unraid terminal then telnet is stopped. Cant figure out why they are not working automatically after restart.

 

root@Tower2:~# cd /boot/config
root@Tower2:/boot/config# cat -A go                       =============> I am intentionally doing -A to see all non printable characters but if just do cat then i see as expected.
#!/bin/bash^M$
# Start the Management Utility^M$
/usr/local/sbin/emhttp &^M$
^M$
#Disable the Telnet On This Machine^M$
sed -i -e 's/^telnet/#telnet/' /etc/inetd.conf^M$
#Restarting After FTP Also Instead Of Restarting and Again restarting for Telnet and FTP^M$
#/etc/rc.d/rc.inetd restart^M$
^M$
#Disable FTP On This Machine^M$
sed -i -e 's/^ftp/#ftp/' /etc/inetd.conf^M$
/etc/rc.d/rc.inetd restart ^M$
 

 

 

 

Simple cat output also

 

root@Tower2:/boot/config# cat go
#!/bin/bash
# Start the Management Utility
/usr/local/sbin/emhttp &

# Manish -- Anything Written Below Is Customized by manish
# Manish - Disable the Telnet On This Machine
sed -i -e 's/^telnet/#telnet/' /etc/inetd.conf
# Manish - Restarting After FTP Also Instead Of Restarting and Again restarting for Telnet and FTP
#/etc/rc.d/rc.inetd restart

#Manish - Disable FTP On This Machine
sed -i -e 's/^ftp/#ftp/' /etc/inetd.conf
/etc/rc.d/rc.inetd restart
 

 

 

Can someone please help what's wrong ?

 

 

 

Share this post


Link to post

In the web GUI, go to system settings, identification, and set "use telnet" to NO.

go to settings, network services, ftp server, set "ftp server" to Disabled.

Share this post


Link to post
49 minutes ago, jonathanm said:

In the web GUI, go to system settings, identification, and set "use telnet" to NO.

go to settings, network services, ftp server, set "ftp server" to Disabled.

Jonathan - I followed your suggestion but now my GUI stopped working. :( I am not linux expert and hoping you can help me to have this fixed.

Share this post


Link to post

Thanks Jonathan it worked. It seems that when i mentioned GUI is not working it was restarting some service as now it seems to be working. Thanks.

 

But can someone explain why it did not work when i tried to do via config/go file by adding command there ?

Share this post


Link to post
1 hour ago, ManishGupta8 said:

But can someone explain why it did not work when i tried to do via config/go file by adding command there

Probably because the settings wound up undoing your change

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now