Jump to content
poniz

New dual Network Card showing wrong speed and not working orrectly.

5 posts in this topic Last Reply

Recommended Posts

I recently purchased a new new 2 port nic for my server (Intel 82546GB). I disabled the on board nic and switched the macs to reflect the change.  Then i tried to setup bonding with 802.3ad, i rebooted the server, rebooted the switch and the speed on port eth1 always stays at 100 Mbps. I've tried to force the 1 Gigabit speed on the switch but no luck. What i see in the logs is the speed changes to 1000 Mbps back to 100 Mbps. I know my switch supports 802.3ad i've this feature on my QNAP before. I've tried changing the Ethernet cables. Tried to switch to other bonding modes but still no luck.  I have attached my diagnostic file. Not sure if anyone needs any other information but my switch model is Meraki MS120-8LP.

I've set port 2 and 3 as the aggregate ports, port 2 shows no issues but port 3 has the following message. 

 

image.png.1bd2daef0b6ef906152e1f07bc6d7ec6.png

 

here is what i see in the logs

Quote

Jan 13 18:07:26 XENON-NAS kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Jan 13 18:07:26 XENON-NAS kernel: bond0: link status definitely up for interface eth1, 1000 Mbps full duplex
Jan 13 18:08:13 XENON-NAS kernel: e1000: eth1 NIC Link is Down
Jan 13 18:08:13 XENON-NAS kernel: e1000 0000:05:05.1 eth1: speed changed to 0 for port eth1
Jan 13 18:08:14 XENON-NAS kernel: bond0: link status definitely down for interface eth1, disabling it
Jan 13 18:12:52 XENON-NAS kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Jan 13 18:12:52 XENON-NAS kernel: bond0: link status definitely up for interface eth1, 1000 Mbps full duplex
Jan 13 18:13:21 XENON-NAS kernel: e1000: eth1 NIC Link is Down
Jan 13 18:13:21 XENON-NAS kernel: e1000 0000:05:05.1 eth1: speed changed to 0 for port eth1
Jan 13 18:13:21 XENON-NAS kernel: bond0: link status definitely down for interface eth1, disabling it
Jan 13 18:39:13 XENON-NAS kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Jan 13 18:39:13 XENON-NAS kernel: bond0: link status definitely up for interface eth1, 1000 Mbps full duplex
Jan 13 18:39:30 XENON-NAS vnstatd[22072]: Detected bandwidth limit for "bond0" changed from 1000 Mbit to 2000 Mbit.
Jan 13 18:39:42 XENON-NAS kernel: e1000: eth1 NIC Link is Down
Jan 13 18:39:42 XENON-NAS kernel: e1000 0000:05:05.1 eth1: speed changed to 0 for port eth1
Jan 13 18:39:42 XENON-NAS kernel: bond0: link status definitely down for interface eth1, disabling it
Jan 13 18:45:00 XENON-NAS vnstatd[22072]: Detected bandwidth limit for "bond0" changed from 2000 Mbit to 1000 Mbit.
Jan 13 18:47:37 XENON-NAS kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Jan 13 18:47:37 XENON-NAS kernel: bond0: link status definitely up for interface eth1, 1000 Mbps full duplex
Jan 13 18:47:59 XENON-NAS kernel: e1000: eth1 NIC Link is Down
Jan 13 18:47:59 XENON-NAS kernel: e1000 0000:05:05.1 eth1: speed changed to 0 for port eth1
Jan 13 18:47:59 XENON-NAS kernel: bond0: link status definitely down for interface eth1, disabling it

 

Not sure what I am doing wrong, did i miss something? is there know problem with the NIC i have ? any help would be greatly appreciated.

Thank you 

 

xenon-nas-diagnostics-20200113-2133.zip

Share this post


Link to post

Make sure all 8 pins are straight and making good connection at both ends of the cable. Stepdown from 1G to 100M is usually caused by the card or switch detecting a bad connection on one or more of the wires. Since you already tried different cables, try swapping the two cables at either the switch or the card and see if the problem moves to the other card. If it doesn't, the issue is likely in the card socket.

Share this post


Link to post

If most 1G network device without problem with Meraki MS120-8LP switch then it is problem on the new NIC. But you can take more troubleshooting.

 

Any different if  ? ( no more link down )

- Only connect 1 port instead 2 port

- Not apply LACP

Edited by Benson

Share this post


Link to post
18 hours ago, jonathanm said:

Make sure all 8 pins are straight and making good connection at both ends of the cable. Stepdown from 1G to 100M is usually caused by the card or switch detecting a bad connection on one or more of the wires. Since you already tried different cables, try swapping the two cables at either the switch or the card and see if the problem moves to the other card. If it doesn't, the issue is likely in the card socket.

I'm about to go purchase another set of cables i am using CAT7 cables.

 

 

18 hours ago, Benson said:

If most 1G network device without problem with Meraki MS120-8LP switch then it is problem on the new NIC. But you can take more troubleshooting.

 

Any different if  ? ( no more link down )

- Only connect 1 port instead 2 port

- Not apply LACP

Yea im didnt even think just to try one port and see if the speed will change. I havent tried to not apply LACP on 6.8.1. Will try both suggestions.
 

Share this post


Link to post

Ok when i tried the port on its own it wouldnt update the speed even on forced. But once i disabled LACP on the switch and force the speed it updated but then reported the interface went down, then the ported was disabled by unraid. Maybe the switch doesnt like the LACP setup on unraid or my port is some how messed up on the NIC. 

 

Quote

Jan 15 01:41:24 XENON-NAS kernel: e1000: eth1 NIC Link is Down
Jan 15 01:41:24 XENON-NAS kernel: e1000 0000:05:05.1 eth1: speed changed to 0 for port eth1
Jan 15 01:41:24 XENON-NAS kernel: bond0: link status definitely down for interface eth1, disabling it
Jan 15 01:41:24 XENON-NAS kernel: bond0: now running without any active interface!
Jan 15 01:41:24 XENON-NAS kernel: br0: port 1(bond0) entered disabled state
Jan 15 01:41:59 XENON-NAS kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Jan 15 01:41:59 XENON-NAS kernel: bond0: link status definitely up for interface eth1, 1000 Mbps full duplex
Jan 15 01:41:59 XENON-NAS kernel: bond0: first active interface up!
Jan 15 01:41:59 XENON-NAS kernel: br0: port 1(bond0) entered blocking state
Jan 15 01:41:59 XENON-NAS kernel: br0: port 1(bond0) entered forwarding state
Jan 15 01:42:01 XENON-NAS kernel: e1000: eth1 NIC Link is Down
Jan 15 01:42:01 XENON-NAS kernel: e1000 0000:05:05.1 eth1: speed changed to 0 for port eth1
Jan 15 01:42:01 XENON-NAS kernel: bond0: link status definitely down for interface eth1, disabling it
Jan 15 01:42:01 XENON-NAS kernel: bond0: now running without any active interface!
Jan 15 01:42:01 XENON-NAS kernel: br0: port 1(bond0) entered disabled state
Jan 15 01:42:15 XENON-NAS kernel: e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Jan 15 01:42:15 XENON-NAS kernel: bond0: link status definitely up for interface eth0, 1000 Mbps full duplex
Jan 15 01:42:15 XENON-NAS kernel: bond0: first active interface up!
Jan 15 01:42:15 XENON-NAS kernel: br0: port 1(bond0) entered blocking state
Jan 15 01:42:15 XENON-NAS kernel: br0: port 1(bond0) entered forwarding state
Jan 15 01:42:26 XENON-NAS webGUI: Successful login user root from 192.168.1.60
Jan 15 01:42:35 XENON-NAS kernel: e1000: eth0 NIC Link is Down
Jan 15 01:42:35 XENON-NAS kernel: e1000 0000:05:05.0 eth0: speed changed to 0 for port eth0
Jan 15 01:42:35 XENON-NAS kernel: bond0: link status definitely down for interface eth0, disabling it
Jan 15 01:42:35 XENON-NAS kernel: bond0: now running without any active interface!
Jan 15 01:42:35 XENON-NAS kernel: br0: port 1(bond0) entered disabled state
Jan 15 01:42:37 XENON-NAS kernel: e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Jan 15 01:42:38 XENON-NAS kernel: bond0: link status definitely up for interface eth0, 1000 Mbps full duplex
Jan 15 01:42:38 XENON-NAS kernel: bond0: first active interface up!
Jan 15 01:42:38 XENON-NAS kernel: br0: port 1(bond0) entered blocking state
Jan 15 01:42:38 XENON-NAS kernel: br0: port 1(bond0) entered forwarding state
Jan 15 01:42:42 XENON-NAS kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Jan 15 01:42:42 XENON-NAS kernel: bond0: link status definitely up for interface eth1, 1000 Mbps full duplex
Jan 15 01:43:05 XENON-NAS autofan: Highest disk temp is 34C, adjusting fan speed from: 153 (60% @ 831rpm) to: 119 (46% @ 687rpm)
Jan 15 01:43:12 XENON-NAS kernel: e1000: eth1 NIC Link is Down
Jan 15 01:43:12 XENON-NAS kernel: e1000 0000:05:05.1 eth1: speed changed to 0 for port eth1
Jan 15 01:43:12 XENON-NAS kernel: bond0: link status definitely down for interface eth1, disabling it
Jan 15 01:43:35 XENON-NAS kernel: e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Jan 15 01:43:35 XENON-NAS kernel: bond0: link status definitely up for interface eth1, 1000 Mbps full duplex
Jan 15 01:45:30 XENON-NAS vnstatd[22078]: Detected bandwidth limit for "eth1" changed from 100 Mbit to 1000 Mbit.
Jan 15 01:45:30 XENON-NAS vnstatd[22078]: Detected bandwidth limit for "bond0" changed from 100 Mbit to 1000 Mbit.
Jan 15 01:47:37 XENON-NAS kernel: e1000: eth1 NIC Link is Down
Jan 15 01:47:37 XENON-NAS kernel: e1000 0000:05:05.1 eth1: speed changed to 0 for port eth1
Jan 15 01:47:37 XENON-NAS kernel: bond0: link status definitely down for interface eth1, disabling it

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.