Unraid crashing my network.


13 posts in this topic Last Reply

Recommended Posts

So i've been running the trail of Unraid for 10 days or so now and am really loving it! (Probably going to switch from Xpenology). 

It's seems like a great community and look forward to being a part of it. 

 

The issue at hand... the last few days Unraid has been taking down my network. 

 

- Few days ago randomly (Wasn't doing anything but transferring files to Unraid. No different than the days prior). 

- The internet speed (not LAN) went to shit... restarted routers reached out to ISP still nothing. I then tried to take all the devices off the network but 1 and things went back to normal.. come to find out it was Unraid. Restarted it and things went back to normal. 

- Woke up this morning 2 days later and same thing... shit internet (1.2 mb/s). Unplugged the server and it went back to normal (80 mb.s). Plug it back in and it goes to shit. Only a restart of Unraid fixes it. 

- So I started looking at some logs on the router. 

- Had over 4000 active ip connections... (All to/from Unraid). 

- I have attached a few screen shots. 

- At first i thought it was an external attack. But because it ONLY goes away after unraid gets restarted (Not even the modem/router and getting a new IP from the ISP) it makes me think it's an Unraid issue...

- w/ Xpenology i had two ethernet lines bonded for improved speeds. 

- I have not touched anything network related aside form giving it a static IP during the initial install/set up. 

- I noticed Unraid seems to have already bonded the two lines?

- In terms of my network set up: From the ISP a router/modem that runs the main part of the house then one of the ports is set to a DMZ where i have another router (House out back) that runs everything out here. (unraid, desktops, ect). This way i can do what i need to do out here without effecting the main house. Granted... unraid even takes that part of the network down. 

- I'm not sure how to proceed.. anyone have any suggestions? 

 

- I'm assuming you may want the server logs. Do i just go to tools>System logs>Download? Granted this would be after the restart... 

- Unraid ip address is the 192.168.2.70

-Thanks,

 

 

Screen Shot 2020-04-14 at 6.50.47 AM.png

Screen Shot 2020-04-14 at 7.22.54 AM.png

Edited by Maximus01701
Added additional info.
Link to post

Tools - Diagnostics, attach complete diagnostics zip file to your NEXT post.

 

But, all of those remote addresses makes me wonder if you have put your server on the internet and are being attacked by bots. Your server should only be accessible from your LAN or through a VPN. Have you put it in the DMZ of your router or something?

Nevermind, I misread. Those are outgoing connections.

Link to post

I installed Nerd pack while following a tutorial to set something up. Granted... I don't remember which tutorial, or what i was trying to set up... 

But, all I've needed to do is copy files from one drive to the Array using Krusader. 

 

However, when I go in and look it says I'm only running 4 or so. 

 

Where can i see what you're seeing? 

 

Thanks again for taking the time! 

Screen Shot 2020-04-14 at 10.59.59 AM.png

Link to post
4 minutes ago, Maximus01701 said:

Where can i see what you're seeing? 

syslog

 

Seems odd there are so many various outgoing connections from your server. Are you booting in GUI mode and using the browser on the server to access the internet?

Link to post
10 minutes ago, trurl said:

What happens if you boot in SAFE mode?

I have not tried it yet. Been just focusing on moving all these files over. Currently running two Synchronizations on drives. One to confirm I can wipe/add the drive to the array and the other over the network.  It takes many hours as i'm sure you know which I can't pause/restart.. 

 

When/if it happens again I will give that a shot. I will also get the logs before I log into safe mode.  

 

One other issue you may be able to help me w/ is hanging on boot. I was going to post it in a new thread.. but maybe i should just try here.. 

 

- When i boot using the USB ports on the back of the MoBo 9/10 it will hang on the following. 

USB 1-4: reset highs-speed USB device number 2 using ehci-pci

- When I use the USB ports on the front (So from the MoBo header) it hangs 1/10 times. 

- The fix is to pull it out and reinsert it. (Not even rebooting). Then it starts right up... 

 

-Thanks,

 

Screen Shot 2020-04-14 at 11.51.08 AM.png

Link to post

You should boot from a USB2 port if possible. USB3 ports seem to lose connection for some. No need for USB3 speed (port or flash drive) for this purpose anyway since it is mostly just accessed at boot to unpack the OS archives into RAM (OS runs in RAM) or to save settings you make so they can be reapplied at boot.

Link to post

The beauty is... I have no USB3 ports ha. And the USB stick is a USB2 stick (Same one I used for xenology for years). I have more sticks I could try, but unfortunately since i'm on the trail i can only test a new stick when i purchase it. PLUS if it still doesn't work I can only try one more for 12 months. (From my understanding). 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.