Jump to content
DigitalDivide

Restore Dockers after USB Flash Replacement

6 posts in this topic Last Reply

Recommended Posts

I accidentally damaged my usb flash drive and replaced it.  Once I get my license issue resolved what's the best way to restore my dockers.

Just before my flash drive was damaged, I was in the process of replacing my cache drive, I backed up the app data via the community plugin backup/restore. When I was opening up my server to replace the drive, I accidently hit the back of the server..or more specifically hit the flash drive which broke it.  I never backed up my flash drive but have an older copy of it which has the config folder...which may be a bit out of date....should I start from scratch or copy that folder over?

 

Do I start up the server and assign the new drive to the cache, then start the array?

Then do a restore of my app data using the community plugin back up and restore? 

After that should I go to the install previous plugs and reinstall all my dockers?  

 

Not sure the exact process.  

 

I have an older copy

Share this post


Link to post

Just want to add that I do have a recent diagnostics zip file from last week.  Can I just copy that folder from the zip file to the new flash drive?

Share this post


Link to post

If you were using the appdata backup plugin, then odds on you were also using it to create a backup of the flash drive.  To restore the docker apps, you technically only require the appdata back, but ideally you also want the contents of /config/plugins/dockerMan/ from the flash back and restore that onto the replacement flash.

Share this post


Link to post
Posted (edited)

Oddly enough I didn't back up the flash drive.  I selected no for flash when I did the backup.  I'm kicking myself for not selecting yes.   

 

Anyhow I'm sort of backup.  My new ssd cache drive is coming up 

Unmountable: Unsupported partition layout

 

Not sure what how to resolve this....any idea?

 

Edit: Nevermind, just noticed I didnt' scroll down far enough...formatting it now..

Edited by DigitalDivide

Share this post


Link to post

Ran into a slight problem.  Previous to replacing my cache drive and damaging my usb flash I did a backup of my appdata via community backup and restore. When I now go into Restore to restore my appdata, it doesn't show up. How do I restore the appdata? Can I just manually copy it over or does it have to be done via restore?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.