[REQUEST] locast2plex Docker


61 posts in this topic Last Reply

Recommended Posts

Not so fast, says Plex.....

 

So I set up a recording for this afternoon and I accessed Plex at dinner to watch it.  There's no recording, but a triangle next to it in the "DVR Scheduler".  Two shows for tomorrow show scheduled, but I expect they'd fail.  When I try to watch live TV, I get a dialog box "Playback Error:  Could not tune channel. Please check your tuner or antenna."

 

Looks like it could be something with l2p.  I see this in the logs for the l2p container:

 

192.168.70.20 - - [12/Nov/2020 04:20:59] "GET /watch/1075?X-Plex-Token=redacted HTTP/1.1" 200 -
----------------------------------------
Exception happened during processing of request from ('192.168.70.20', 56744)
Traceback (most recent call last):
File "/usr/lib/python3.8/socketserver.py", line 316, in _handle_request_noblock
self.process_request(request, client_address)
File "/usr/lib/python3.8/socketserver.py", line 347, in process_request
self.finish_request(request, client_address)
File "/usr/lib/python3.8/socketserver.py", line 360, in finish_request
self.RequestHandlerClass(request, client_address, self)
File "/usr/lib/python3.8/socketserver.py", line 720, in __init__
self.handle()
File "/usr/lib/python3.8/http/server.py", line 427, in handle
self.handle_one_request()
File "/usr/lib/python3.8/http/server.py", line 415, in handle_one_request
method()
File "/app/main.py", line 127, in do_GET
ffmpeg_proc = subprocess.Popen(["ffmpeg", "-i", channelUri, "-codec", "copy", "-f", "mpegts", "pipe:1"], stdout=subprocess.PIPE)
File "/usr/lib/python3.8/subprocess.py", line 854, in __init__
self._execute_child(args, executable, preexec_fn, close_fds,
File "/usr/lib/python3.8/subprocess.py", line 1637, in _execute_child
self.pid = _posixsubprocess.fork_exec(
TypeError: expected str, bytes or os.PathLike object, not bool
----------------------------------------
192.168.70.20 - - [12/Nov/2020 04:21:00] "GET /discover.json HTTP/1.0" 200 -
192.168.70.20 - - [12/Nov/2020 04:21:00] "GET /lineup_status.json HTTP/1.0" 200 -

 

UPDATE:  So I found others with similar issues, and one of the investigation steps was to go to http://plex_accessible_ip:plex_accessible_port in a browser.  This showed the IP:port:port.  I removed the port from my config.ini (which may have been key to getting the tuner into Plex to begin with), restarted the container, and now I can watch live TV - on about half my local HD channels.  I'm not sure why this would be the case unless there is some sort of transcoding issue going on as most all my stuff is Direct Play, but at least it's progress.  Baby steps....

 

UPDATE2:  Back into Plex again I noticed a message about a new tuner detected, a SiliconDust Locast device.  I figured wth, I'll go through DVR setup again.  It seems like more channels are playing nice now (and it still only shows the SiliconDust Locast device), so maybe it's just temperamental.

Edited by BurntOC
update
Link to post
  • 2 weeks later...
  • Replies 60
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

I would say no on the OpenVPN support built-in as that's opening a whole extra can of worms that can be easily accomplished using a router such as pfSense. You can assign a docker an individual IP add

Can someone create a Template for tgorg's locast2plex docker? Also, if its possible to add built in open VPN support inside it so we can change the location of the ipAddress.     I real

I tried to get locast2plex to work on my server with no luck. I too would appreciate a simple way to set it up or a youtube video with step by step instructions.

Update - saw an update in Unraid and applied it and it wouldn't start.  Based on this line in the log, I realized it was probably failing because my password had a % character in it.  I changed it to remove that, updated the config.ini and it works now.

 

Initiating Locast2Plex v0.6.1
Opening and Verifying Configuration File.
/app/config/config.ini
Loading Configuration File: /app/config/config.ini
Traceback (most recent call last):
File "/app/main.py", line 49, in <module>
config = get_config(script_dir, opersystem, args)
File "/app/lib/user_config.py", line 10, in get_config
return UserConfig(script_dir, opersystem, args).data
File "/app/lib/user_config.py", line 52, in __init__
self.import_config()
File "/app/lib/user_config.py", line 75, in import_config
for (each_key, each_val) in self.config_handler.items(each_section):
File "/usr/local/lib/python3.8/configparser.py", line 859, in items
return [(option, value_getter(option)) for option in orig_keys]
File "/usr/local/lib/python3.8/configparser.py", line 859, in <listcomp>
return [(option, value_getter(option)) for option in orig_keys]
File "/usr/local/lib/python3.8/configparser.py", line 855, in <lambda>
value_getter = lambda option: self._interpolation.before_get(self,
File "/usr/local/lib/python3.8/configparser.py", line 395, in before_get
self._interpolate_some(parser, option, L, value, section, defaults, 1)
File "/usr/local/lib/python3.8/configparser.py", line 442, in _interpolate_some
raise InterpolationSyntaxError(
configparser.InterpolationSyntaxError: '%' must be followed by '%' or '(', found: '%restofpassword

  

Link to post
  • 2 weeks later...

Ugh...now its saying credentials missing

 

Quote

Opening and Verifying Configuration File.
/app/config/config.ini
Loading Configuration File: /app/config/config.ini
Locast Login Credentials Missing. Exiting...

 

Config is taking from github

 

[main]
locast_username=xxxx@xxx.com
locast_password=xxxxx
plex_accessible_ip=192.168.1.171

Link to post
  • 3 weeks later...
On 12/10/2020 at 8:00 AM, Bobb18 said:

Ugh...now its saying credentials missing

 

 

Config is taking from github

 

[main]
locast_username=xxxx@xxx.com
locast_password=xxxxx
plex_accessible_ip=192.168.1.171

I had the same issue. I changed the path from /mnt/user/appdata/locast to /mnt/cache/appdata/locast and everything works great. 

 

Edit: Yesterday plex decided not to play live TV. I deleted the dvr and tried to set it up again and plex does not see my device anymore. Locast seems to be loading just fine, I can access the xml from port 6077, but for some reason plex can't find my device even when manually entering the ip address. Any ideas? 

Edited by Apoceclipse
Link to post
  • 2 months later...
On 12/10/2020 at 11:00 AM, Bobb18 said:

Ugh...now its saying credentials missing

 

 

Config is taking from github

 

[main]
locast_username=xxxx@xxx.com
locast_password=xxxxx
plex_accessible_ip=192.168.1.171

Did you ever find a solution to this? I'm getting the same error.

Link to post
4 hours ago, Bobb18 said:

 

Nope...stopped trying for now

Yup, so after some more scouring I found a solution that worked for me; change the config file path from app/config/config.ini to app/config/

 

That did it for me.

Link to post
  • 2 weeks later...
1 hour ago, ziggie216 said:

I'm reading that Locast dropped the donation when COVID started but seems like in order to use this locast2plex, donation is still required?

 

Probably not the right forum to discuss your issue, but here's what a quick search brought up:

https://www.globenewswire.com/news-release/2020/03/18/2002822/0/en/Locast-lessens-coronavirus-hardships-with-emergency-offer.html

 

Link to post
40 minutes ago, ppunraid said:

 

Probably not the right forum to discuss your issue, but here's what a quick search brought up:

https://www.globenewswire.com/news-release/2020/03/18/2002822/0/en/Locast-lessens-coronavirus-hardships-with-emergency-offer.html

 

 

Thanks.. I must have read another article wrong about donating being temporary removed when I saw this 

Quote

A locast account that you have donated to (non donated accounts have streams that terminate after 5-10 mins, so locast2plex intentionally fails to prevent issues with non donating users and the DVR function). Also be sure you are running the server from the same physical location that you want channels for.

 

when I was wondering why the docker wouldn't start. 

Edited by ziggie216
Link to post

Docker.img got corrupted, had to readd L2P, and well, the new configuration sucks cause when I scan for channels from Plex, it says it found none, despite there being 46 listed in the logs. "Found 46 stations", and Plex comes back with "No channels found. Make sure your device has a signal from your antenna and try scanning again." Really really wish I didn't have to be forced to update my software, original version was working fine. Anyone else run into this issue? It's not documented anywhere else it seems.

 

FIX: Had to manually add the address and port number to Plex for it to recognize it as a tuner properly. Wtf?

Edited by Cynagen
Stupid fix for stupid issue
Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.