Asrock X570 board won't boot from USB - SOLVED


Recommended Posts

So my UNRAID system was having a bit of hardware trouble.  I was sick of the SuperMicro mobo / Xeon combination I've been running so I bought new hardware.  Namely an Asrock X570 Phantom Gaming 4 mobo, AMD Ryzen 3400G cpu, 16GB of Corsair LPX RAM (overkill but all they had at the store).

When I setup the new hardware it booted right away, I went in and did standard BIOS tweaking, then set my Boot drive to my UNRAID USB stick.  When booting, the system just boots directly into the BIOS menu.  F11 and try to Force it to boot from the USB Stick, and it does the exact same thing.  I tried all of the rear I/O USB ports and the same results.  

I grabbed a MicroSD card and flashed a new install of UNRAID onto that to try that, same results.  The system just won't boot off of the USB drive despite it being set to do so.  Anyone have input on this?  I found mentions of people running this board and CPU (not together that I found) with UNRAID. 

Lastly I just updated the BIOS on the board (no change), and made a Windows 10 Install Media to try.  The Windows USB Stick booted into the Windows Installer.  So for some reason this just isn't booting to the UNRAID sticks.

Edited by MandicReally
Link to comment
6 minutes ago, rachid596 said:

Enable cms support in your bios

Envoyé de mon HD1913 en utilisant Tapatalk
 

I was worried you would say that.  I cannot do that.  CMS Support is listed but just says "Disabled" and gives me NO OPTION to turn it on.  I'll have to try rolling back a couple BIOS versions and see if the Option was recently removed or contact Asrock.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.